Add support for Linksys EA6350 v3


#104

I received the

"WARNiNG: Makefile 'package/feeds/packages/gnutls/Makefile' has a dependency on 'kmod-cryptodev', which does not exist"

message as well, and was able to complete building the binary and uploaded it to my router. I now have Luci on there but no wireless devices are recognized, even when running all the show device info commands I could google for Linux lol.

I think somehow the build environment changed and messed up things since Escalion posted the guide. I built 4 different virtual machines running different flavors of Linux and all had build issues.

If someone has a prebuilt binary for this router with the wireless configured that would be amazing to try. Otherwise, does anyone know the simplest way to configure an IPQ4018 radio that is not able to be recognized by Luci or SSH? And how to use the knowledge to build my etc/config/wireless file? I am new to the syntax and platform.

Thanks for all your work.


#105

@keign The PR was closed and the author asked to submit an amended one; the basics seem to be good though, it's not rejected.

@renanrodriguezfranco Why are you focusing on a warning? Warnings don't break things. Errors do.


#106

Hi @anders, could you upload your binary ? I am still getting errors to build it. Thanks!


#107

Sure, you should be able to download it from: http://lab-it.se/misc/openwrt-ipq40xx-linksys_ea6350v3-squashfs-factory.bin


#108

Thank you very much @anders !!! :clap: :+1:


#109

Hello everybody! First of all, thank you for giving us a base to support this device!
With your work I can work in this device without the need of disassembly (because mine is brand new and kinda expensive).
So, I'v got my self-built image based on @escalion PR but I've got no wifi interface. From the kernel log I can see that the problem is a bad WiFi region in EEPROM and the ath10k-ct refuses to load. This happens both in the custom image I made and the one that @escalion did.
In an unrelated (or maybe related) topic, I found this patch:
ath10k calibration variant. This is important as for this DTS file, because you use the calibration, "Linksys-EA6350v3". However, in the file board-linksys_ea6350v3.bin, I can see the variant in a hex editor, which is "linksys-ea6350v3". I don't know if it is case sensitive but I think is safer to change the variant to match the one in the .bin file.


#110

Hi @NoTengoBattery I am having the same Wifi problem, there is no wifi interface, only Ethernet.


#111

Hmmm... I think I see what happend here...
What happend here is that he took the file $original_fwib/firmware/IPQ4019/EU/boarddata_0.bin and appended a sequence to it honoring this patch. Then he added sequence and appended the $original_fwib/firmware/IPQ4019/EU/boarddata_1.bin and that is the board-2.bin that he put in the commit. I don't know now but I think this has to do with some devices having no WiFi.


#112

Hey! I've got WiFi!
Do you want to check if my image boots and works with your hardware?
(Remember that sometimes you have to flash the image twice, I'll see if I can fix it)


#113

That´s great man! Thanks @NoTengoBattery
Sure! I would like to check your image, can you share it?


#114

Give it a try. It does not have LUCI and I really, really suggest you to reset your settings before and after flashing this image.
If this work, I would want a serious developer to review the problem and the solution because it's a small but dirty hack and I don't think it would make its way to upstream.

Releases in GitHub


#115

Thank you very much @NoTengoBattery !! I´ll reset my settings and I´ll flash it right away!! I will let you know how it went!
You are right, I think it would be a great idea too!!


#116

I just wanted to let you know that I had the same issue with WiFi not working but I installed your sysupgrade and WiFi works now! Now I need to get the VPN working.


#117

Hey, mine too is working now, finally! Thank you man @NoTengoBattery.


#118

Cool! Good to have a working WiFi!
Now, I need some help from a real developer (as I'm an indie developer) to make this device into upstream!


#119

Just thought I'd give you an update on how things are going.I had to flash the router twice to keep wireless function after rebooting through luci, I assume it was reverting to the previous firmware upon rebooting? Right now I'm trying to get OpenVPN to work with ExpressVPN and have been having some difficulties, but I don't think it has anything to do with your build. Keep up the good work!


#120

For OpenVPN you need a kernel module, but you cannot install it as the kernel in the image is a custom kernel.
If you want I can build a image for you with Luci and OpenVPN.


#121

That would be great, thanks! I was actually able to get OpenVPN to install with the --force-depends command, but who knows if OpenVPN is working correctly. I think the biggest issue is ExpressVPN and not OpenWRT / OpenVPN.


#122

New image uploaded. Give it a try. Just remember to reset your settings (for the moment, this is needed).


#123

Hey all, apologies for my silence lately - been rather busy with other projects.

I plan on fixing the upstreaming issues from the PR over the next couple of days.

@NoTengoBattery - what is the difference with your binary, do you have a git repo for me to look at? I could see what changes you made and include it in the PR.
Was the issue the casing of the board variant?
In the UK on UK channels the board-2.bin I uploaded worked - although I didn't do any range testing on 5Ghz (maybe I should have).

ATB, Escalion