Add support for Linksys EA6350 v3


#84

Pull request submitted:


#85

That sounds really cool, thank you! I'm happy to test, but am away on business this week - should be back home this coming weekend and keen to test - I will go through your steps and let you know as soon as I can.

cheers, Keith


#86

How do I use your branch? Should I build a chaos_calmer using:

git clone -b chaos_calmer git://github.com/openwrt/chaos_calmer.git

Sorry, I'm not well versed in git nor building software :smile:


#87

OK, I did the brave thing and RTFM :slight_smile:

I think I know what I’m doing now, so will clone your fork and follow your notes on building with Luci. Let you know hopefully this evening that I’ve got a working binary...

Thanks, Keith


#88

Quick start guide (Assuming debian based system):

sudo apt-get install git build-essential libssl-dev libncurses5-dev unzip gawk zlib1g-dev
git clone https://github.com/escalion/openwrt
cd openwrt
./scripts/feeds update -a
./scripts/feeds install -a -p luci
make menuconfig

Set the options:

Target system -> Qualcomm Atheros IPQ40XX
Target Profile -> Linksys EA6350v3
LuCi -> Collections -> luci-ssl-nginx

Save, exit.
Run make -j4
And grab a coffee.
I don't mind providing a pre-built binary if this makes life easier for you?


#89

Hey guys, first off thanks for all the work. I used the gui to upgrade to this from stock, but am getting no networking. I've got ssh into it, arp -a shows it as OpenWrt.lan (192.168.1.1), but I'm a total noob when it comes to configuring an openwrt box. Does it need a wan connection to start dhcp and such? Non-critical, just for testing, any help would be appreciated.


#90

Hey -
First, did you compile with luci or just as stock?
The fact that you have SSH'd in says that you do in fact have network.

If you mean you have no wireless, you need to enable that via uci or luci. (Search uci set wireless) - Luci is easiest (Web UI)

DHCP will run on the LAN ports out of the box - if you connect to a lan port, from your computer a quick ip a will show that it has given you an address in the 192.168.1.X range.

If you need to install luci, you will need to connect the WAN port to internet, then over SSH on the LAN run the command opkg install luci-ssl-nginx

I hope this helps


#91

Thanks for getting back to me, i compiled with luci-ssl-nginx in following with your quick start above. Not sure what I was thinking, it clearly has networking and dhcp. I had it isolated from my network, ethernet from one of my machines, and was unable to get to the browser interface. I can't give it a pure wan connection right now, so
I've patched it into my router and it's pulling an ip. Now when I try to hit it from firefox I get this message: "Power is turned off. Operate after turning the power on."
a couple forced reboots later and it comes back up with the original linksys firmware. I'm a bit confused but clearly jumped in a little too deep.


#92

must have messed up configuring the build, gave it wan, opkg update && opkg install luci-ssl-nginx fixed it. Thanks again!


#93

@escalion all great!!! :+1::+1:
installed and enjoying the better monitoring. Hopefully find what on the Wireless has been killing my RTT.

will let you know of any issues.


#94

Just finding this thread, compiling and installing now. Will let you know if I encounter any bugs.

Thanks to all of you for taking the time to work on this and get it going!

Michael H.


“An expert is a person who has made all the mistakes that can be made in a very narrow field.”
― Niels Bohr


#95

I have an issue with the 5GHz wireless. I've changed the ESSID so its different to the SSID of the other radio, but since then when any device tries to connect I either get told I can't join or the password is incorrect.
Hard to prove, but also wife tells me that performance on the 2.4GHz isn't as good as before.
Is there anything I should be doing with settings? How do devices cope with the default SSID being the same for both radios?


#96

I compiled and installed according the instructions of @escalion. Thanks for the great work!
I'm also facing issues with the 5GHz wireless (using different SSID than the 2.4GHz). In most cases I can't even join the network or client reports that the password is incorrect. When I am able to connect it only works for a couple of minutes with poor throughput, then losing the internet connection and finally losing the complete connection. I tried using several modes (legacy, N, AC), different channels and channel widths. Can there be a problem with the wireless driver?
2.4GHz is working fine, so for now I have switched off the 5GHz radio.
I keep on testing.


#97

Hi there buddy @escalion , I´ve followed your quick start guide (thank you ver much by the way) but I always get this Warning: WARNING: Makefile 'package/feeds/packages/gnutls/Makefile' has a dependency on 'kmod-cryptodev', which does not exist.
I have googled everywhere, to make it work, but no success.
Hope you can help me to create the binary to flash my EA6350v3, or somehow can you provide the pre-built binary? that would be such a great help! Thanks! Keep the good work!


#98

Any news on this? The PR was rejected and I'm wondering if I should buy the router.


#99

Thanks for adding the EA6350v3 support and the great easy to follow detailed guide.
Works excellent except for the 5GHz wireless like others have noted before me.
In my case I can get 5GHz wireless working if i set the bandwidth to 20MHz but I have not tested that much with it yet.


#100

Hello, thank you for providing the guide. I compiled according the instructions but for some reason I see no wifi options at all. Would it be possible for someone to upload a binary?

Thank you.


#101

Hi @keign by any chance do you have the prebuilt binary for sharing? I keep having this WARNiNG: Makefile 'package/feeds/packages/gnutls/Makefile' has a dependency on 'kmod-cryptodev', which does not exist.
that´s why I can´t build the binary. Hope you share it!


#102

I saw warnings for both kmod-cryptodev as well as a similar warning for libidn2 when I compiled the code but it built just fine without them. So if your build fails I would suspect there is some other issue.


#103

@anders Yes, the build fails everytime I try to do it in any Ubuntu PC (already tried 3 PCs) and I get the same result on each one.

"WARNiNG: Makefile 'package/feeds/packages/gnutls/Makefile' has a dependency on 'kmod-cryptodev', which does not exist"

I am following the same guide that @escalion shared, step by step.
Don´t know what to do. I just need to change the official firmware, because I don´t like it, OpenWRT is a lot better than the official Linksys firmware.
Can anyone share the binary for this router?
Thanks!