Add support for Linksys EA6350 v3


#186

I think I understand. Just one thing: please read the large text I wrote if you are using the custom build. It states that LuCI will start in Failsafe mode, you just look at the corner for Administration mode. No need for flashing another firmware.

For reseting the router to factory defaults you can restart the device and press the WPS button while it is booting. I can't help you with PPPoE because I don't use that feature, but you may be kicking a bug!

Here I found some interesting tips for recovering a misconfigured device. Hope to know about your router soon!


#187

OK I got a serial connection going currently and I'm trying to dig through it's output.

Here is the boot log as of now.
https://hastebin.com/uhayijoxum.cs

If you don't mind taking a look and telling me if something sticks out please let me know.
The big issue at the moment is that there is no ethernet connection running so tftp is out as far as flashing the firmware again to get a solid reset. Also as stated previously the LuCI panel is not present.

I can only assume DHCP is not functioning at the moment. I'm still try to read the log and figure this out hehe.

I follow that up with this output from attempting to reset the router manually via serial connection.

oot@(none):/# grep squash /proc/mounts
/dev/root /rom squashfs ro,relatime 0 0
root@(none):/# mount_root
[  235.879352] mount_root: loading kmods from internal overlay
[  235.910006] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[  235.912478] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[  237.065885] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[  237.066279] block: extroot: not configured
[  237.132591] mount_root: rootfs_data:/dev/ubi0_1 is already mounted as /overlay
root@(none):/# umount /overlay && firstboot && reboot now
[  266.667502] jffs2reset: This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
[  269.833060] jffs2reset: /dev/ubi0_1 is not mounted
[  269.833142] ubi0 error: ubi_open_volume.part.0: cannot open device 0, volume 1, error -16
[  269.836793] jffs2reset: /dev/ubi0_1 will be erased on next mount
[  269.845091] jffs2reset: writing /dev/ubi0_1 failed: Bad file descriptor

I'm unsure if flashing the other image corrupted the file system.


#188

OK. I don't see a corruption problem, but I don't know what is jffs2 doing in your system!
There is a high chance that you are facing a bug that @jeff reported. Probably the MAC address of the LAN is preventing you from using your PPPoE.

If you look at the /etc/config/network file you will see that the MAC address of LAN is "+1". Obviously this is a bug. I've already fixed the bug, but flashing the fixed image will break the device unless you flash the image with a factory reset.

I recommend you reverting back to stock, wait for the image I built with the fix, flash that image from stock and then trying again.


#189

I'd happily do that, however flashing to stock seems to be a problem as well, I have the stock image, however in uboot the tftp server dies endlessly.

Also thank you so very much for your support on this.

EDIT: The MAC address isn't set in network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde1:de0e:e88e::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'

#190

I'd like to make a confession in regards to a mistake I made :sunglasses:

I set the bridged Lan connection to PPPoE instead of the WAN connection and borked the entire setup.
The rescue was to reset the settings of the router via /sbin/jffs2reset after fully booting. This fixed me up entirely. I'm sorry for the interruption that was caused by my over site.

Thank you again immensely for all of your help here.


#191

It's easily done I'm afraid! Glad you got it sorted.


#192

This goes for all the people involved that may want to know about this.
(Problems with DNS (web pages not loading but able to ping ip addresses)? uci set dhcp.@dnsmasq[].noresolv='1' will fix it. I will amend that in the following release next week)

:partying_face: I JUST HIT THE NAIL with this device! Oh, I am so satisfied right now. I knew it was the calibration board! It's just amazing.

I think all of you want to give a try to my latest "release", that release will have the amazing wireless performance of stock (or arguably better).

@escalion @Afraidium @jeff @imi2003 @anders @elitedz you may be interested.


For you, @chunkeey, may I ask you if we get positive results from other people than me... can you do the commit? I don't want to make the pull request and bla bla... but I'll do if you say no. Just let me know.


Note: due to a simple yet annoying bug and it's respective bug fix (which is not in Upstream yet), you will likely end up with an inaccessible device after the upgrade. Please, do a factory reset. I will not answer questions which are solved in the "Release Notes".


#193

Took me a while to find it, but by "release notes", you're referring to

Yes?

Also there are some "challenges" with failsafe, OpenSSH, and removing dropbear (which I routinely do) -- One approach at https://github.com/openwrt/openwrt/pull/865 Yes, on my long list to "modularize" this as per project request.


#194

Yes please, I would like you(or someone with a EA6350v3) to have the honors and post the board-linksys_ea6350v3.bin update patch. Thanks to the responses in this thread, you don't have to write
that much. just add @anders and @imi2003 testament:

From before:

And after:

and add a link to this thread (Bug-Link: tag) and be done with it.

:+1:


#195

SSH works and I decided it to be like that: prevent root login and use a dummy user with sudo. Not a big deal, the user is created automatically, added to sudoers automatically and pretty much that...

I understand the problem now. I will add Dropbear and disable it. It should work without pain in failsafe mode with the benefits of OpenSSH in normal mode.


#196

Thank you, @chunkeey

I will do that as soon as I get enough feedback regarding to this. I don't want to fail twice in a row... LOL.


#197

Isn't Add support for Linksys EA6350 v3 :

already a second confirmation?

But Ok, let's wait and see. :slight_smile:

(Also Q: Do the files you sent to the ath10k Mailing list need updating as well? Or did you sent the original files there?)

Because ipq-wifi is just a stop-gap measure and I'm planing to ping Kalle in the near future so he adds the outstanding board-files to the main ath10k-firmware repo.


#198

Ok, I think you need some explanation.

First of all: the files that I tested are "new". It's the first time that I tested. The files from @imi2003 are not the same. My purpose was to test all calibration board files.

The files tested (as the codename used by OEM) were as follows:

  • hw1_DK01
  • hw1_Y9803
  • fcc_Y9803
  • eu_Y9803
  • and finally, the working one: au_Y9803

The au_Y9803 was never used or published till now. The files sent to infradead and the file sent to upstream are hw1_DK01. If this file actually works, I see myself amending the other files I sent. Else, I will keep trying till all files are tested.


#199

Hi @NoTengoBattery i've just flashed your prebuilt image, and i can confirm its working great.
Have you had a chance to test luici-app-advance-reboot from @stangri repo?
I think it would make a great addition to your prebuilt, as it lets you easily reboot between the two partitions from the web interface.
I'll test over the next few days and come back with any findings


#200

Fantastic!!

My 5GHz iperf3 TCP test speed just went from 0 to 274 Mbps (client receive) and 158 Mbps (client send) and rock stable!

Maybe 2.4GHz feels a bit more unstable than before but it's a bit early to say.


#201

Yes, I've tested @stangri's luici-app-advance-reboot and it works good. However I cannot add it to my prebuilt (it refuses to build from source) yet. If he/she can publish his/her patches to upstream, it wold make a great value addition to the device!

And I'm glad to know that it is working. As @anders said, it looks like it's not performing rock solid in the 2.4GHz band. We need more testing before saying so, by the way. For now we just have 1 (one) calibration board to test: ah_Y9803.

I will upload a new prebuilt soon because I see that nginx is painfully slow and it wastes too much resources. But for applying it you will need to do a factory reset... again. I promise that this will be the last prebuilt that requieres a factory reset.

Someone messed up with OpenSSL in upstream so you will need to access LuCI using HTTP (not HTTPS) unless you have your own self-signed certificated (is a good idea to have a backup of it instead of adding random certificates each time). I've changed nginx with uhttpd and it breaks the the device.


PS: The GOOD thing is that now that I know how this works, I pick the best performing calibration for 2.4GHz and 5.8GHz individually! So don't worry about 2.4GHz not being so good right now. With enough feedback we can optimize this device to the max!


About uhttpd and TLS: this is interesting. It worked previously until this commit.


#202

@NoTengoBattery Have a look here for the advance-reboot source


#203

Yep. I know. It refuses to build. I don't know how to integrate the source code to my build, or how to integrate the prebuilts into my image. I barely know how the build system works!
I've more concentrated in keep track of upstream changes that break my custom configuration and the board files.
If someone know how to include the source code into the build (note: not the image builder) I will definitely add it.


#204

It's (mostly) a single lua script, you can just install the normal package (without support for your device) and replace /usr/lib/lua/luci/controller/advanced_reboot.lua with the modified one on the installed system.


#205

its a single line addition to following source file

luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua

{"Linksys EA6350v3", "linksys-ea6350v3", "mtd10", "mtd11", 192, "boot_part", 1, 2},

This is the only differance from the upsteam version

Edit the file once you have run the feed update, then it will build.