Add support for Linksys EA6350 v3


Can you help me with this? I can't figure it out and the device keeps bouncing between firmwares making my job harder hehe...

Before this thread dies:
I've doing some work on this and now it's working just fine for me. As I cannot actually meet the quality control of upstream, this device won't do it's way to upstream soon.
However, I will share the code we did with @escalion and some prebuilt images in my GitHub repo.
As I told you: this has been working good, smooth and stable for me from about 8 days or more, and 4 days in a long run without re-flashing or rebooting.
I'll upload some prebuilts till either my device dies or someone can make this device into upstream.
Take a look at this release. Keep track on the repo, I'll upload prebuilts constantly.

1 Like

Thanks @NoTengoBattery!
I started to wonder what happened to you PR since it was closed.
Just flashed my router using your build, have not run many tests yet but it seems to work fine!
Sad to hear that it will not make it's way upstream anytime soon, unfortunately I'm not much of a developer so not able to help out.

This device is such a pain!

I don't want to be noisy but...
I put a new release in GitHub. All of the releases I did before were using the FCC/EU (which are 99% the same, bitwise speaking).
I was investigating the original firmware and I found that they name the files like the board. So FCC/EU are using some Yxxxx board which is not this one.
The folder hw_1 (not a surprise that if you ls -Ral /lib/firmware you will find the hw.1 folder) does contain a 2 files with the name of the board. Those files were sent here but never used in the binaries till now. I ask you to give a try.
I'll schedule the release as this (as I don't want to be annoying to those who want to help me):
Jan22: using the files sent to infradead
Jan22+8: using the files in hw_1 called "board0" and "board1".
Jan22+15: using the files in hw_1 called like the Yxxxx board
Jan22+23: maybe some conclusions? I mean... I can try all the files but those are a good set to begin!

I appreciate every byte of feedback. BTW: read the message from the Jan22 release.

1 Like

First off I want to say thank you for your great work! Really appreciated. Then a question, should I run the sysupgrade.bin or the factory.bin? Ok, figured that out, sysupgrade.bin was the one I needed. Working like a charm!

Deleted. Nothing actually relevant.

you did meet the all the points. The issue was with this comment

I didn't know if the PR was now broken or not. So I waited for the release and positive response.
I put it into my staging tree to let it do a few rounds in the CI in the next days.


Thanks to you for reviewing the code and putting in your tree, it's nothing but good news!

The bug in the script and some minor but annoying bugs are fixed in the patches you used.

I'll keep my eye on this as I see that kernel 4.19 is on it's way! And I am sure it will be a challenge.

P.S. no more prebuilts from me.

Question: mac80211: ath: add extra 'regulatory domains' . It would be great if it could be posted on the linux-wireless ML. Please tell me whenever you want to do it or if I should have a go. Either way would be fine but there's no need to post it twice. :slight_smile:

im getting the following error when trying to build from source.
im using a fully upto date Ubuntu 18.10 install.
Im building as a normal user

patch: **** malformed patch at line 36:  ;qcom-msm8960-cdp.dtb \

Patch failed! ;Please fix /home/imran/Downloads/chunkeey-12f0eb9/target/linux/ipq40xx/patches-4.14/901-arm-boot-add-dts-files.patch!

I get the same error with full chunkeey HEAD tree as well as the snapshop just for the ipq40xx changes.

Im not a developer or know how to code, but more than willing to test builds and provide usage feedback

yes, there was a leftover patch that I kept around to see the changes I did. I deleted it now, but you'll need to rebase if you want to get rid of it. Though, I would recommend that you just use , git:// , over mine since it's bound to be in a state of constant breakage ;).

You can also just download the snapshot images from the ipq40xx target over at:


(Be aware, they do not include LuCI Webinterface, just ssh at over the LAN ports and the kernel module (kmod-) packages will only stay around for a limited time.)

Thank you for the quick reply,
I've successfully built a image using the link you provided above, with luci, usb mount, samba4, dnla, and adblock.
Ive just flashed it, and so far the 5gz wifi seems a lot more stable than escalion image.
I done a sysupgrade and it has kept all settings from the previous escalion image, including samba, adblock and dnla server settings.

I will do further testing over the next few days, and come back with any findings on this thread. ( if this is the correct place?)

Great to see that the PR has been merged!
I can also confirm that 5GHz is working fine now using the standard repo build.
Really good work, thanks!

I now switched to firmware snapshot r9253-3da230a and started to use my EA6350 router as gateway at home, running it towards a 100Mbps WAN connection with an LTE backup route through the USB port (MWAN3). Sadly I can still see issues with the 5GHz Wifi. But everything else works perfectly.
Sometimes 5GHz seems to work fine, the next time it claims that the stored WPA2 password is incorrect and sometimes it's not even visible from the client end.

Have you tried the latest firmware?



If it's still a problem? Then report it to ,

No, I'm using an openwrt snapshot build from February 1 and it looks like this new firmware was released February 2. In the current openwrt source as of today I can see that version .002 is still used.
I'll see if I can update it myself or wait for someone to update it in openwrt.
Anyway, a big thanks for the information @chunkeey !

I'm having the same problem. But the problem is also present in the stock firmware and happens only with my iPhone. I have no more iPhones to test but my Macbook connects well.

Lately, however, I've seen a worst 2.4 GHz quality as it drops many packages. This does not happen in 5.0 GHz nor from Ethernet.

Are you experiencing this problem (wrong password) with an iPhone?

Now that you mention it I think I have only seen the "Incorrect password" ones on iPhone.
But the other 5GHz connection issues I have noticed on both iPhone and Macbook: Unable to connect, connected but no traffic goes through, network not visible.