Add support for D-Link COVR-X1860

What does this mean?.
Is the device officially supported already or do we have to wait for any other event (another PR merge/approval or OpenWRT new version release)?

Thanks in advance.

You're late, as usual ,)


Hi, I flashed the recovery file from here: from the recovery menu using Brave (Mac & Windows), Chrome (Mac & Windows) and Edge (Windows) . All with the same result:
It says update complete and does not reboot. (The LED is blinking red during the update until around 30% and then turns to solid white - That seems wrong already) If I manually reboot and switch to DHCP I can access ssh via root@ but there is no LuCI Web interface and I don't know what I did wrong. Any ideas on how I can get LuCI to work?

Thanks in advance

That's how it should be if OpenWrt is fully booted.

Correct, there is no LuCI with snapshot builds.
But you could maybe include it directly in firmware-selector, but not sure if it would work though (it seems it is already listed there, maybe it doesn't work with snaphots in firmware-selector).

Usually, you would connect the router to WAN, then call opkg update && opkg install luci via SSH. This only works on they same day the snaphot was built, since a new kernel will be built every night.


Thank you very much. I finally got it working. I wrongly assumed the snapshot has LuCI preinstalled.

For anyone else with these rookie mistake:

After installing the snapshot using a chromium browser, connect the cube to your ISP Box.
SSH onto it and run the code. Now LuCI is available.
If you don't have access to ssh over your network, connect the pc to ethernet and the isp box to the WAN port.
That's what I did and got it working in no time.

When Will I can expect build with LuCI

When there is a stable release of the next OpenWrt version, probably somewhere around summer 2024.

One question can install here oscam ?

If it's in the package repository, and will fit the available flash space, you can.

No chance it will be released earlier? I keep watching the changelogs and there's a section called "Support for the following devices was added" even for patches.


And it was indeed added ?

I flashed this openwrt firmware on my COVR-X1860 and I would like to go back to the original firmware. I tried to decrypt the original firmware but I keep getting errors... Is it possible for someone to give me a link for the decrypted original firmware plz?

Please help me, I uploaded OpenWRT via the recovery file but unfortunately I can't log in to the router. How can I upload the factory firmware?

where is it failing for you ?;a=commit;h=0a18259e4aa361cd9e5848c038be4b9f4e3bfcc6

1 Like

I cannot log in to the router by entering Unfortunately, Wi-Fi is not available via cable. I uploaded the recovery file using the following method. How to upload the original firmware?
Flashing via Recovery Web Interface:

  • Set your IP address to, subnetmask
  • Press the reset button while powering on the deivce
  • Keep the reset button pressed until the status LED blinks red
  • Open a Chromium based browser and goto

does it come back with stock fw, or is it only letting you go to the recovery ?

I assume you also changed the IP back to DHCP client, after doing the firmware UL ?

Yes, I changed the IP, unfortunately it still does not log in to the router. What file do I need to upload to return to the original firmware?

one from d-link, one can assume ... ?

You have to download the firmware from D-Link, decrypt it and then you can use it in the recovery web interface

Edit: regarding the problem with login after flashing OpenWrt: I assume you downloaded a snapshot image? Did you include luci in the image?

By downloading the firmware from the manufacturer's website, uploading it via recovery this way. Unfortunately, the router flashes red and there is no Internet.