Add support for D-Link COVR-X1860

Hello everyone, I own 3 satellites and after reading this thread I ordered 2 more from Germany (I'm in Italy) at the half of the price!
I'm quite happy with the stock firmware, even if it is maybe too much simple, but I'm in contact with the dlink support to understand if the following annoying problem could be fixed:
I reduced my network configuration to the following setup: ISP router in bridge mode - main COVR - D-Link DGS 105 which is confirmed by support is ok (the switch must support standard IEEE 1905.1a) - secondary COVR
What happens is when I move between the 2 covr with a VPN connection active (IPsec) the connection drops and I need to reconnect. Since I work with this VPN this is quite annoying

I want to ask you if this is an expected behavior and if with OpenWRT this problem could be fixed.

Thanks in advance

OpenWrt would give you IEEE 802.11r support, but in order to profit from that, your roaming client has to support this as well.

looking at the Intel documentation, my wireless card (Intel® Wi-Fi 6 AX201) should support it:
https://www.intel.com/content/www/us/en/support/articles/000021562/wireless.html

What makes me suspect is the note: "Windows® 10 currently doesn't support 802.11r with Pre-Shared-Key (PSK) and Open Networks."

I'll investigate and let you know

The firmware is working stable over the last weeks, so thank you @RolandoMagico!

The only issue I experience is wifi Roaming. My Android device (Samsung A52s) is dropping here and there the connection after roaming. The config looks ok compared to my old wifi settings (of course no AX standard). I searched the forums and this are my roaming settings right now:

BusyBox v1.36.1 (2023-08-05 13:32:03 UTC) built-in shell
 (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r23694-9b80635510
 -----------------------------------------------------
root@OpenWrt-EG:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01
.0/0000:02:00.0'
        option channel '11'
        option band '2g'
        option htmode 'HE40'
        option country 'DE'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option dtim_period '3'
        option encryption 'sae-mixed'
        option key 'password'
        option bss_transition '1'
        option ieee80211r '1'
        option mobility_domain '2222'
        option reassociation_deadline '20000'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option max_inactivity '300'

Anyone has an idea? The rest of my environment seems to work fine.

I believe I read somewhere that wpad doesn’t support sae (anymore)?

I will try WPA 2. Thank you!

I've dug into this a fair bit as I've been experiencing a very similar-sounding issue on two Android phones, one of them very consistently.

The gist of what I've figured out so far: at some point (it seems to be related to roaming between the access points), ARP replies don't seem to make it to the phones anymore. This then causes the phone to have no idea where any IP address is, which results in no internet, no LAN connections, no pings making it through in either direction, nothing.

There are a couple of GitHub issues about this and people have reported that re-enabling the hardware MAC address learning (instead of the DSA-based learning) fixes the issue. I applied the patch from https://github.com/openwrt/openwrt/issues/9706#issuecomment-1326281353 on an experimental build and I'll be giving that a shot.

1 Like

[quote="RolandoMagico, post:93, topic:161862"]
Started recovery mode, uploaded COVR-X1860_RevA_Firmware_102b01_decrypted.bin: Stock firmware is running again.[/quote]

Could you provide the file COVR-X1860_RevA_Firmware_102b01_decrypted.bin ?
I'm trying to compile dlink-sge-image but i got hundreds of errors (undefined reference to `EVP_MD_CTX_new')

Thanks

Ok, i figured out how to compile and decrypt the stock firmware getting the same size/SHA256.

So, I want to test OpenWrt but i want to be sure I can also revert to stock firmware, just in case i cannot figure out how to use it. Is that "COVR-X1860_RevA_Firmware_102b01_decrypted.bin" file the one i will need to go back on stock?

you said "Started recovery mode, uploaded COVR-X1860_RevA_Firmware_102b01_decrypted.bin: Stock firmware is running again.": how can I start OpenWrt recovery mode?

Yes, that’s the file you need if you want to go back to stock firmware.
For entering recovery mode, there are some posts here, for example Add support for D-Link COVR-X1860 - #206 by PhoenixG36

Thanks!
While from stock firmware to OpenWrt if I understood I should use the "factory" image from your builds directly from the stock web GUI, right?

One last question, which is the difference between:
COVR-X1860_Build_20230806_Mesh_kmods
COVR-X1860_Build_20230806_Mesh
COVR-X1860_Build_20230806

Yes, you're right

COVR-X1860_Build_20230806 is the default build
COVR-X1860_Build_20230806_Mesh is a build which contains additional packages for meshing
COVR-X1860_Build_20230806_Mesh_kmods is the same as the previous but provides additional kernel modules, e.g. for setting up WireGuard

If you plan to install special packages, please check also the builds here: Add support for D-Link COVR-X1860 - #159 by Ditti4
They should make installation of additional packages much easier.

@RolandoMagico do you know why is taking so long to add this to the official build roster?

Can a mod give us an idea?

Hi @zimmie, I don't have more information than what I already wrote before: Add support for D-Link COVR-X1860 - #58 by RolandoMagico

The firmware change worked perfectly for me, only this router did not give me the contracted speed of 900mg symmetrical. Although I forced the network ports of the router and the ont, it only gave me 100 megabytes. but i put my tp-link AC3150 Wireless MU-MIMO Gigabit Router as main and the 2 D link conv 1863 modules as dummy router. I am delivered by cable and by Wi-Fi 650 mg speed. I was satisfied.

Do you mean 100 Megabytes/s or 100 Megabit/s?

Did you tried hardware NAT offloading? It will normally improve your routing speed.

Thanks so much @RolandoMagico , in the end tired of the stock firmware I decided to flashed all my devices with your build and all my roaming problems are finally solved. I can move all around the house with my VPN connected and no more drops are happening!!
I did not use mesh but just standard access points with 802.11r fast roaming enabled since all my access points are connected with network cables.

Great job!!

PS: I want now to migrate the VPN server (OpenVPN) from my raspberry to the router and I saw with the "kmod" build should be possible. Which is the right procedure to move from one OpenWRT firmware to another?

I flashed the main router with the "COVR-X1860_Build_20230806_Mesh_kmods" firmware and installed kmod-tun package included in the release from LuCi.
when i try to install openvpn-ssl i got this error:

root@RouterMain:~# opkg install openvpn-openssl
Package openvpn-openssl (2.6.6-1) installed in root is up to date.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.131-1-d76ed90c7772a112198f54848c0dd523) for kmod-tun

How can i proceed?

You either have to install the kernel modules manually from the archive in the kmods release or you use the other images which are provided above. They should make installation of kernel modules much easier