Add support for D-Link COVR-X1860

How are you testing this speed? Within your network or is this an internet speed test?

What does your WiFi setup currently look like, are your channels crowded?

Speed test app android


1.wifi router with internet
2.D link oryginal firmware
3.D link openwrt software

Sorry, again a noob question from me:

Can I force opkg to use a different version? I installed all kmod packages for wireguard. That worked fine with your provided packages. After that I wanted to install the luci and wireguard tools and I ran into errors (I need a newer Kernel version for the packages):

Installing luci-proto-wireguard (git-23.073.81399-59a6f06) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci-proto-wireguard_git-23.073.81399-59a6f06_all.ipk
Configuring luci-proto-wireguard.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-lib-chacha20
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-hash
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-lib-poly1305
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-lib-chacha20poly1305
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-kpp
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-crypto-lib-curve25519
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-udptunnel4
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-udptunnel6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.125-1-0f0db065e0b57643d380de80339ea0ed) for kmod-wireguard

When I try to upgrade the kmod-wireguard package, I get following warning:

Details for package kmod-wireguard
Version: 5.15.125-1
Size: ~37.36 KiB installed
Dependencies:
kernel VERSION INCOMPATIBLE
kmod-crypto-lib-chacha20poly1305 INSTALLED
kmod-crypto-lib-chacha20 INSTALLED
kmod-crypto-lib-poly1305 INSTALLED
kmod-crypto-hash INSTALLED
kmod-crypto-lib-curve25519 INSTALLED
kmod-crypto-kpp INSTALLED
kmod-udptunnel4 INSTALLED
kmod-udptunnel6 INSTALLED
Description
WireGuard is a novel VPN that runs inside the Linux Kernel and utilizes state-of-the-art cryptography. It aims to be faster, simpler, leaner, and more useful than IPSec, while avoiding the massive headache. It intends to be considerably more performant than OpenVPN. WireGuard is designed as a general purpose VPN for running on embedded interfaces and super computers alike, fit for many different circumstances. It uses UDP.

The installed version of package kernel is not compatible, require 5.15.125-1-0f0db065… while 5.15.123-1-7c335438… is installed.

Except that VLANs are working and it seems it could replace my main router.

Not sure if forcing installation is a good idea. As far as I remember there were posts in the forum recommending not to do that.
Building an image with all the required packages is probably the better option.

1 Like

best to use normal firmware releases so 23.05.0-rc2 atm
doh tho not in there yet

1 Like

Nah, I don't force that installation if there is a warning. :wink:

I just configured all my settings via SSH and without luci, also worked fine. So I will just skip that package. So VPN is working now. Thanks!

Can u help with that ?

use the firmware selector https://firmware-selector.openwrt.org/?version=23.05.0-rc2&target=ipq806x%2Fchromium&id=tplink_onhub
select version 23.05.0-rc2 "as the current master has problems people say here atm"
select the arrow next to "Customize installed packages and/or first boot script'
add the extra packages you want
request build

Thx but I want back to stock firmware im try 4 days....

This is for TP-Link Onhub?

doh yes that will teach me for opening many tabs
the COVR-X1860 isn't in there yet
but when it is you can do it that way

1 Like

If you want to go back to stock, you'll need the stock firmware and you'll need to decrypt it. The stock firmware can be downloaded from here: https://ftp.dlink.de/covr/covr-x186x/driver_software/COVR-X1860_fw_reva_102b01_ALL_multi_20230630.zip

The decryption can be done using @s_2's dlink-sge-image tool, but it needs to be compiled first. I'm assuming the tool you already tried out (dlink-dec.py) works in a similar fashion. You then take that decrypted firmware image and feed it to the device through the recovery mode.

I have problem with complied that , but I get decrypted firmware. Can ask you do you have problem with wifi speed ? 2.4 only 20mhz 40 no work.

40 MHz channels in 2.4 GHz won't work in congested areas unless you choose to violate the IEEE 802.11n-2009 by setting the noscan option in the OpenWrt settings.

Ok I'm test today wifi and CPU loads for all is like 80% if I'm test lan is like 5-10 % that can be problem with max transfer 330mb ?

Is software flow offloading enabled in your setup? see also OpenWrt software offloading configuration

1 Like

Yes, that no work for wifi, only for lan.

this is true but there are but there are only so many channels
and usually the neighbours using the same channels
interfere more on 40Mhz then 20Mhz
so 2.4G is good for range and simple IOT stuff
and phones when further away from 5G
try to move to 5G and 6G
tho I do recommend having 2 or 3 5G access points around
but only bother with 1 2.4G one turned on
all dependent on location layout and usage

1 Like


U can see wifi test https://www.waveform.com/tools/bufferbloat
Test with only ethernet 1gb Hardware flow offloading on show max 5% cpu usage.

Hi Kolmodor,

I also noticed 40 MHz channels are not working on my build based on a snapshot some weeks ago. Rural area, so uncongested 2.4 GHz environment, also setting noscan option didn't change anything. What made me even more suspicious: I've got an D-Link DAP-X1860, which is almost the same device, featuring the same chipset - I'm running v22.03.05 on one unit (and a v22.03-ish snapshot build on another one) and 40 MHz channels work perfectly.

After digging around in the forum a bit, I found the following thread: MT7621: WDS with channel width > 20 MHz and AX not working in newer snapshots - #24 by ThiloteE

So, yeah - it's a bug, but according to the topic, it should be fixed by now. However, I didn't have time to try out a more recent build.

3 Likes