Add support for ASUS RT-AX89X AX6000

I've never used OpenWRT before, so just asking in general. Is it OK to use the snapshot image or would it be better to wait until stable image has support for it? Also, is it possible to first install the snapshot and then switch to stable?

that last part I can definitely ask that question...once I actually do it.

Snap shot image does not allow you to install software. at least, not through luci or maybe not at all. the goal of the snap shot image provided is to test the basics of the router. So far, its seemed to have password with flying colors already.

It does, via luci, opkg, (online-)imagebuilder or asu (assisted sysupgrades)/ owut. There is only the catch that your installed (aging) snapshot quickly gets out of sync with the constantly updated/ rolling package repositories, which often means that you can only install addon packages on the same day your snapshot image has been built. You can still install 'everything', but you might have to sysupgrade to a newer (today's) snapshot image before.

just checked and it seems like your right slh. but it has to be done through the command prompt/terminal since luci does not have a "software" tab in the webgui interface.

After trying to install some packages, I do get an error message saying that they are incompatible with the snap shot

it does/should have ...

that's exactly what @slh wrote ?
https://openwrt.org/releases/snapshot

you could try solution 4 from
https://openwrt.org/faq/cannot_satisfy_dependencies

I was trying to say confirm that what slh said was true. Like I am trying to say "yes, this is right and you should believe him". My foul up!

Not concerned too much with installing software in this firmware. official is coming out soon.

all good,

as for "soon", it might actually slip into 2025, but I haven't been keeping track of the progress.

seems PR got merged two days ago ?
official snapshots are being built
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=qualcommax%2Fipq807x&id=asus_rt-ax89x

@robimarko I'm creating a techdata entry, so we can have a proper wiki page for the device, but I need to get the radio specifics, they're not in the git commit.

can you assist ? tell me what to write, or fill it in yourself.

https://openwrt.org/toh/hwdata/asus/asus_rt-ax89x_b_revisions

What details do you need?

Mainly WLAN HW field, the Qualcomm names of the radios, QCN... ?

Btw, is aarch64_cortex-a53 the correct arch ?

Yeah, for packages that is correct.

thanks, wiki page updated, should now contain (mostly) relevant info.

https://openwrt.org/toh/asus/rt-ax89x

3 Likes

I’ve been running the firmware from the firmware selector and just upgraded to today’s snapshot. Been playing around with it, and so far it’s been solid.

Would love to have a version that includes a bunch of nice tools out of the box, like the one remitor made. Looks like he did a few custom scripts, as I can not download some of his installed packages from the repo.
Also it seems like luci is not up by default aswell, I need to install it upon flashing, but that’s standard with snapshots iirc..?

So far, the only thing I can’t get up is fan control. There is a package for gpio_fan installed, but no matter what I do, it only spinns during boot. For some reason, even when I revert to asus firmware, it refuses to run once up.
The router is heating up quite a bit, feels like 80°C to the touch on the backplate.

I have swapped the original fan with one from noctua (90x15 black) to be extra silent, so I don’t want to close up the box and use it in action until I know it’s cooling as intended. There is no way I can check once it’s closed, the thing is dead silent, truely increddible :slight_smile:

Fan will kick on after CPU reaches 70 degrees C, there is nothing to control

scroll up 9 posts.

Well something is getting hot.
What would you suggest me to read out the temps?

Also I have no issue with installing packages. All cool

Nothing to install, just go to /sys/class/thermal and you will see all of the zones there

1 Like

Hi, I tried again using the SFP+ module with openwrt and with stock firmware on netgear switch.
It is working with stock firmware but not with openwrt.
I understood that it had worked with I guess other type of switches.
Any idea how to had other devices driver for SFP+ support ? (I don't really know how it is managed on openwrt).

You sure its 10G SFP?

Cause, due to SSDK we cannot yet use the normal kernel SFP driver that is able to parse the info and adjust the link

My switch is the netgear S3300-28X-PoE+. It has two SFP+ port (supporting 10G, 2.5G, and 1G) and 2 10G ports. The 10G works well though.
When using stock firmware on asus RT-AX89X, on the netgear configuration panel, I see that the negotiation is written as 10G link.
Due to SSDK, SFP kernel driver is not supported for SFP 1G, but is suppose to work for 10G, is that right ?