Add OpenWrt support for Xiaomi "Redmi AX6000"

Hello,

DFS RADAR restrictions seem to be hard coded in 802.11ac (5GHz) routers as a result of FCC regulations. The good news is that there are ways to avoid getting 'kicked off' by using non-DFS channels instead. For example, wifi routers using country code 'US' on the 5GHz radio band can use channels 36, 40, 44, 48 and 149, 153, 157, 161 and 165, to avoid DFS issues.

SNB Wi-Fi Dynamic Frequency Selection (DFS) FAQ

For those looking for a bit more refinement and/or living in other countries, the following wifi specifications on Wikipedia should help:

List of WLAN Channels

Hope this helps!

~TheCyberTecky

I'm fairly certain that the "6Ghz bug" is just DFS doing what it's supposed to be doing, maybe the output in LUCI could be handled a little more elegantly or even handle channel fallback.

Users generally forget to set a country code or aren't familiar with their country's channel restrictions. They also underestimate the prevalence of military radar, especially near coastlines. Most people that just want reliable Wi-Fi shouldn't be using DFS channels at all.

Also what about software updates, is the system up to date. I forgot mine and the 6GHz bug was there.

I set up DNS addresses that should come via dhcp on the lan interface, but when I connect, I still see one DNS address 192.168.1.1. Is this setting not working?

/etc/config/network

....

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option delegate '0'
list dns '8.8.8.8'
list dns '1.1.1.1'
list dns '192.168.1.1'

....

OpenWrt SNAPSHOT r27243-dd1bfbe971 / LuCI Master 24.212.79282~65b8002

Custom dns for clients goes in dhcp options, correct?

uci add_list dhcp.lan.dhcp_option="6,8.8.8.8,1.1.1.1,192.168.1.1"

if I add dns servers here: web management > network > interfaces > lan edit > Advanced Settings > Use custom DNS servers, then the entry appears only in the file /etc/config/network with the following lines:

config interface 'lan'
...
list dns '8.8.8.8'
list dns '1.1.1.1'
list dns '192.168.1.1'
...

and it doesn't work.

now I tried to do it like this:

uci add_list dhcp.lan.dhcp_option="6,1.1.1.1,8.8.8.8,192.168.1.1"
uci commit dhcp
service dnsmasq restart

and it worked, now I get the dns I need on the device.
in the file /etc/config/dhcp a line appeared:

config dhcp 'lan'
...
list dhcp_option '6,1.1.1.1,8.8.8.8,192.168.1.1'
...

it turns out that custom DNS settings for local network clients do not work via web management

You need to set dns per-interface. The dnsmasq dns settings are for the router itself, not the clients.

Has anyone tried MESH on this router. Details are a little vague. Thanks

You mean like with dawn or usteer? I use a Redmi AX6000 as my main router with openwrt and have 2 other openwrt based router acting as wifi AP's. I configured the fast roaming on every device and used dawn, but I disabled recently because there were many anomalies. Right now I let the client devices connect to which ever AP they want to and now it looks stable. Sidenote: I have wired backhaul connection, don't now what you mean by MESH.

I have recently set up an AX6000 as my main router and 3 other mediatek devices as APs with usteer and fast roaming. There was initially a lot of anomalies in this setup but step by step I think I've managed to make it just work and I would never go back.

(issues and fixes: Most of it has been my wanting to use experimental features: I've had to disable/not enable WED on any filogic devices (AX6000, AX3000T), also not use hardware offloading or packet steering on the main router, some tweaks ot usteer)

Can you share the usteer tweaks you used? I don't think I would like to turn off hardware offloding, but maybe I would give a try to usteer.

Yes, I read in post somewhere in this forum about usteer, and the thing people needed to set to make it do anything was negative roam scan SNR, I think the relevant parts should be these

    option roam_scan_snr '-55'
    option signal_diff_threshold '5'
    option roam_trigger_interval '11000'

You also need to install bridger package on the dumb ap's.
And for fast roaming to work, you need to install the full wpad, like wpad-mbedtls (and uninstall the wpad-basic package)

About disabling hardware offloading and WED, if you have them on - the fast roaming will simply not work at all. The test I found - that 100% triggered errors was using a VPN on my phone and attempting to fast roam - that plainly does not work when hardware offloading is enabled i.e the network will not function at all.

And the AX6000 imho does not even need Hardware flow offloading in any regular usage. I manage to saturate my gigabit fiber from my phone over wifi without hardware offloading - I litteraly can't go faster than that. I struggle to see any upside - it has a fast CPU it manage to do everything you want, , and hardware flow offloading(or WED) simply does not function together with fast roaming (and other features like QoS/SQM as well) so it is pure downside. As far as I can tell, you can only use software offloading until the bugs are fixed.

1 Like

Has anyone started to run into problems trying to update these - I'm currently on r25967, trying to use attended sysupgrade downloads new firmware, appears to apply it and reboot, however upon coming up it hasn't upgraded, same applies if I upload an image (via luci or SSH), any bright ideas / how do I troubleshoot why the image isn't applying?

Running r27662 from a few days ago built from image without issue. Have not tried anything since :man_shrugging:

1 Like

shot in the dark here as I had a similar problem in the past:

can you ensure fitblk package is installed? If not, install that and try sysupgrade again.

That did it, thanks!

1 Like

Hello guys!

How's it going?

I'm trying to update from SNAPSHOT r27730-3d7040b7d6 to the latest SNAPSHOT version.

When I installed the latest version the opkg command was missing, /usr/libexec/package-manager-call: line 88: opkg: not found

I'm using owut to generate the upgrade file and I noticed that luci-app-opkg 24.191.51591~bff2a43 missing to-version

Is there any problem with this package or is there any new way to manage packages?

Thank you in advance.

Regards.

Read here

2 Likes

Thank you so much @Lexeyko. :heart:

1 Like

After installing the package luci-app-package-manager I continue having the same problem: /usr/libexec/package-manager-call: line 88: opkg: not found from luci and -ash: opkg: not found from ssh. :frowning: