Add OpenWrt support for Xiaomi "Redmi AX6000"

Does this happen when using the latest snapshot build?

I am currently using: OpenWrt 23.05.3 r23809-234f1a2efa / LuCI openwrt-23.05 branch git-24.073.29889-cd7e519

Have you tried wpa3 encryption only? Anything in the logs?

To all you guys experiencing this, can you post your dmesg and of your logread output? Is there anything do go on based on these logs?

Unfortunately, I don't have logs of when the problem occurs.

my System Log is spammed with messages from hostapd about "BEACON-REQ-TX-STATUS" and "BEACON-RESP-RX"

and the Kernel Log is spammed with banIP blocking warnings

I even know how to configure banIP to stop spamming messages in the log, but I have no idea how to configure hostapd to suppress these log records.

If you know what to do about hostapd, I'll configure it here and as soon as the problem occurs on the 5ghz network, I'll post the logs of what happened.

Suggest that you temporarily disable banIP to keep the logs from getting spammed and wait for the wifi crash to occur again, then post what I asked above. Without some details, diagnosing this is going to be impossible.

As I said, I know how to suppress the banIP log, the problem is the spam of hostapd logs on 802.11kvr packages.

There must be some way to suppress the hostapd log about "BEACON-REQ-TX-STATUS" and "BEACON-RESP-RX", otherwise it will be impossible to share.
I've already configured it to use 1MB of RAM and ROM to keep the System Log recorded, but this hostapd spam consumes this space in a matter of 5 hours of the device being turned on.

I do not know/not using 208.11kvr AFAIK. Perhaps someone else experiencing the crashes can post the logs.

I managed to make a filter to cover these 802.11kvr packets.

I basically followed these steps: Suppress logging of beacons - #4 by grrr2

Now I have disabled my "fix", which restarts the wifi every 12 hours, and just wait for the problem to occur and see if it registers in the log.

For all with Radio breaking issues. Running 6 days now without issues. Below my radio settings. OpenWrt 23.05.3 (r23809-234f1a2efa) UBOOT version
I do use South Afrika and Taiwan to be flexible with with TX power and avoid DFS. (but it works on other countries fine to, tried US)

Also don't use 30 dBm transmit power, no phone can send back at that power level, its useless in almost all cases. 21 dBm is more then enough for almost all situations (besides making a wireless bridge between 2 AX6000 devices long distance, better antenna make more sense then). (14 dBm on 2.4 Ghz)

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option channel '6'
option band '2g'
option htmode 'HE40'
option txpower '14'
option country 'TW'
option cell_density '0'
option he_bss_color '10'
option he_su_beamformee '1'
option log_level '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'AccessPoint'
option encryption 'psk2'
option key 'secret'
option ieee80211r '1'
option mobility_domain '4f60'
option ft_over_ds '0'
option ft_psk_generate_local '1'

config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option channel '100'
option band '5g'
option htmode 'HE80'
option country 'ZA'
option cell_density '0'
option txpower '21'
option he_bss_color '20'
option he_su_beamformee '1'
option log_level '0'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'AccessPoint'
option encryption 'psk2'
option key 'secret'
option ieee80211r '1'
option mobility_domain '4f60'
option ft_over_ds '0'
option ft_psk_generate_local '1'

1 Like

I put this configuration to test 5 days ago, and the 5ghz wifi really didn't cause any more problems:

 config wifi-device 'radio1'
 31         option type 'mac80211'
 32         option path 'platform/soc/18000000.wifi+1'
 33         option channel '36'
 34         option band '5g'
 35         option htmode 'HE80'
 36         option cell_density '0'
 37         option noscan '1'
 38         option country 'BR'
 39         option txpower '27'
 40
 41 config wifi-iface 'default_radio1'
 42         option device 'radio1'
 43         option network 'lan'
 44         option mode 'ap'
 45         option ssid 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
 46         option encryption 'sae-mixed'
 47         option key 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
 48         option ieee80211r '1'
 49         option ft_over_ds '0'
 50         option ifname 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
 51         option doth '1'
 52         option ieee80211k '1'
 53         option time_advertisement '2'
 54         option time_zone '<-03>3'
 55         option wnm_sleep_mode '1'
 56         option wnm_sleep_mode_no_keys '1'
 57         option bss_transition '1'
 58         option proxy_arp '1'

I put it back on channel 149 and power 30 dBm, to see if the problem will occur.

Can I activate Beamforming and BSS Coloring on this router?

I believe it is enable by default

1 Like

@darksky, the problem just occurred, follow the log.

It seems like it has something to do with using channel 149, because using channel 36 with the rest of the settings the same, there simply aren't any problems with 5ghz wifi
detail, even with power at 27dBm the problem occurred.

config /etc/config/wireless

30 config wifi-device 'radio1'
 31         option type 'mac80211'
 32         option path 'platform/soc/18000000.wifi+1'
 33         option channel '149'
 34         option band '5g'
 35         option htmode 'HE80'
 36         option cell_density '0'
 37         option noscan '1'
 38         option country 'BR'
 39         option txpower '27'
 40
 41 config wifi-iface 'default_radio1'
 42         option device 'radio1'
 43         option network 'lan'
 44         option mode 'ap'
 45         option ssid 'xxxxxxxxxxxxxxxxx'
 46         option encryption 'sae-mixed'
 47         option key 'xxxxxxxxxxxxxxxxx'
 48         option ieee80211r '1'
 49         option ft_over_ds '0'
 50         option ifname 'xxxxxxxxxxxxxxxxx'
 51         option doth '1'
 52         option ieee80211k '1'
 53         option time_advertisement '2'
 54         option time_zone '<-03>3'
 55         option wnm_sleep_mode '1'
 56         option wnm_sleep_mode_no_keys '1'
 57         option bss_transition '1'
 58         option proxy_arp '1'

syslog

syslog: