Add OpenWrt support for Xiaomi "Redmi AX6000"

Right now, 5Ghz speed is superb, but 2.4Ghz speed is slow (6Mbit). I've tried a lot of settings, but without success. Can anyone who has sufficient speed share their settings?

Slow speed in N is not a big issue, but the coverage is also really low right now.

Edit: reset the router and speed is okay now with default settings. Not sure what was wrong.

1 Like

Can I update next builds straight to x-wrt fork from luci webui? (*.bin Stock layout)

Currently on openwrt stock layout after flashing the Snapshot+installing luci.

Is there a difference in luci webui between both versions (snapshot without luci & x-wrt)

Any actual comparision about performance?

Hi,

Does anyone know what's the purpose of ppe1? I tested all the traffic including LAN<->WAN, WLAN<->WAN and LAN<->WLAN, all the traffic is offloaded to ppe0. I also checked the source code of function mtk_flow_offload_replace.

        entry = kzalloc(sizeof(*entry), GFP_KERNEL);
	if (!entry)
		return -ENOMEM;

	entry->cookie = f->cookie;
	memcpy(&entry->data, &foe, sizeof(entry->data));
	entry->wed_index = wed_index;

	err = mtk_foe_entry_commit(eth->ppe[entry->ppe_index], entry);

Seems that entry->ppe_index is not set before call mtk_foe_entry_commit.
@lukjod @umayer I saw both of you edited the WED part of Linksys E8450 device page. MT7622 and MT7986 should be similar. Any idea? Thanks.

I didn't modify information, I just rearranged it. I'm sorry, I cannot help.

OK, thanks all the same.

Somewhere in this long threat someone did a comparison. Both OpenWRT and default ROM go to 950+Mbit. So no reason to not go for OpenWRT.

hello there,
I follow the guide on the below video
https://www.youtube.com/watch?v=zUvNv61Ylno
and I used their FW version in the video (I don't know if it's the same one here or not)
router is working perfectly, full speed compared to stock FW without any issue,
however, I tried to download (Luci-app-SQM) it's giving me the below message:


please keep in mind, I did restart by mistake before doing step (squashfs-sysupgrade.bin) in stock layout method, and it seems I lost the access to old Stock FW (192.168.31.1),
the questions is, can I use the FW version in ( https://openwrt.org/toh/xiaomi/redmi_ax6000 ) ?
also, I wanted to go for U-boot mod layout method, but I lost the access to (192.168.31.1) completely,
can I execute all the steps from (192.168.6.1) SSH ?

Excuse me for the explanation, I'm not expert with Openwrt,

Thanks in advance.

I would suggest to flash the X-WRT AX6000 build. If anything goes wrong you can restart the process using the MiWifi repair tool.
Maybe there's a better solution, but I guess that you're in a hurry.

thank you for your reply !
can you please share with me the X-WRT build link along with steps to follow ?
appreciate your cooperation.

https://downloads.x-wrt.com/rom/
Flash via Luci.
note: router IP= 192.168.15.1
user/passwd: admin/admin
Ssh user/passwd:root/admin

This boot message means the lan port can run at 2.5gbps?

[ 1.162116] mt7530 mdio-bus:00: Link is Up - 2.5Gbps/Full - flow control rx/tx

I'm unable to flash with X-WRT, error message,
you mentioned there is better solution, can you please explain more about it ??

AX6000 ports are 1G, but the interconnection between the CPU and radios and the switch is at 2.5 Gbps, so in theory you can push up to 2.5 Gbps to/from the CPU and radios and the ethernet ports using multiple ports.

1 Like

You can ignore the error message before flashing. Works fine (at least in my case).

I have the same issue (37 Mbit in 2.4G and 6 Mbit in 5 GHz). Did you definetively fix it?

Hi all,

I've had a bit of an issue today... when installing the ubootmod layout my ax6000 has lost power, right after formatting and creating the new ubi volume at step 7 from the wiki:

ubidetach -p /dev/mtd5; ubiformat /dev/mtd5 -y; ubiattach -p /dev/mtd5
ubimkvol /dev/ubi0 -n 0 -N ubootenv -s 128KiB
ubimkvol /dev/ubi0 -n 1 -N ubootenv2 -s 128KiB

I can't now ping etc.. the device, I'm assuming it's no longer able to boot. Am I looking at UART to get this back to life, is anyone able to advise?

I did take a backup of the BL2, Nvram, Bdata, Factory and FIP files before hand, also have another ax6000 which is working well with OpenWRT if that helps at all.

Thank you!

Rob

Well, at this step you should still have the OEM u-boot, so configure IP 192.168.31.100 in your computer and check if u-boot is trying to boot from network from 192.168.31.1 (tcpdump, wireshark).

If not, try with UART, and hope that OEM u-boot hasn't disabled it.

If UART is disabled, you'll need a programmer to reflash the SPI-NAND flash.

Thank you, I take it if it is trying to network boot I can make the file available via TFTP?

Remove the wifi channel and add a new one. Default setting will give you a good performance.