Add OpenWrt support for Xiaomi "Redmi AX6000"

Your TV may not be able to connect to DFS channels, or it's possible that it's been kicked off by a radar scan so you might try power cycling the TV to see if that fixes it. Otherwise you'll need to stick with channel 36 or 149, but then you'll be limited to 80mhz.

And affected by the multiple wall/low throughput bug. To me that is the only reason to use 160MHz/channel 100.

Does anyone happen to know when this device will be moved to stable build? The snapshot seems to be working perfectly. Unless I'm just not noticing something lol

1 Like

Probably the next major release, OpenWrt 23 maybe?

Ah okay. Was thinking with the release of v22.03.3 that just came out it would've been. But I'm not sure how releases work exactly. Thank you!

mt7986 seems have mainline hw qos/nat support if you enable hw offload....no need to sw SQM

1 Like

I am into the same poblem.
scp command step requires me a password.

How do you contninue?

Using scp will require the same password as using ssh (unless you defined a key file).

I am at the previous step of installing the snapshot.
I have to send the file to the router using scp.

I have not ssh password and I do not know how to define It.

Post the command you are using and the output of it. Remembering that you need to append a -O to the call to scp like this scp -O ...

Please, find here my tries via Ubuntu and Windows

use winscp under wine worked like magic.

The "Windows.jpg" snapshot is executed from AX6000 shell, not from Windows cmd, so clearly won't work.

In Ubuntu you're just connecting to a new key in a reused IP address. Common in an installation like this. Just run the command mentioned in your screenshot ssh-keygen -f ... and should work out fine.

Please, find again screenshot according to previous comments.

Thank you again

you are trying to root access Xiaomi OEM firmware at 192.168.31.1,
did you change root password after gained root access (XiaoQiang)?

no... until I know

my experience with this AX6000 model, is that there is no root password asked after gained root access (unlike AX3200 there is password generated from router serial number.)

Just change root password, then try SCP again.

this is the problem.. I do no t how to change it. Could you describe me the process, please??

in Xiaomi OEM/Openwrt firmware, enter passwd

3 Likes

Hello
I have a problem.
I followed the procedure to install openwrt (stock layout).
But after step 3 and reboot, I no longer have SSH or telnet access.
And I no longer have access to the configuration web page.

Any idea?
Thank you and have a good day.

Edit:
His WAN interface does have an IP that was given to it by DHCP on my network. (192.168.1.20)
There is no visible wifi network.
The LEDs are blue and fixed.

I tried to connect via SSH/TELNET/Web from the WAN side network (192.168.1.20), and from the LAN (192.168.31.1) without success. I did a scan on 192.168.31.XXX, 192.168.1.XXX and 192.168.0.XXX but I cannot see the router from the LAN.