Add OpenWrt support for Ubiquiti AirCube ISP (UBNT ACB-ISP)

I have added the factory image to the data entry for the AirCube, it should be showing up on the wiki's device page now.

Hi all again,

@c-mauderer
it seem it works.
LED ist blinking, is that normal?

But I have an other problem in activating the POE passthrough
If I use the "live change" I got an error
grafik

What went wrong?
Have I to add some additional software packages?

Michael

Edit:
Maybe this will help?
grafik

there is no gpio11?

I reflshed the sysupgrade image,
did a reset of the aircube

now poe pass through works...

you did a great job

Michael

P.S. for playing around with the LED, it is usefull to ad another software package?

I never tried the PoE pass through (only guessed the pin) but someone else did and it seemed to work.

The LED won't stop blinking. I started to work on it but never finished it. The LED is controlled via SPI. There is already an upstreamed Linux kernel driver for the LED that would work. But the SPI has to be emulated using GPIOs and the Linux developers managed to optimize that too well. The SPI is too fast and therefore the LED only sometimes does what it should do. After taking a look at the GPIO-SPI driver, I found out that it is really tricky to slow it down for my use case without loosing performance for all other systems. My AirCube is somewhere where I never see it and therefore it never was a high enough priority for me to fix that.

ok I understand :slight_smile:
The Poe works now after reflashing, don´t know why, but it works :slight_smile:
On WAN side I use a Nanostation M2 so I need only one pwersupply :+1:

The LED thing is secondary, I thought perhaps there is additional software needed.
If this is the current state, no problem :slight_smile:

Again Thanks for this work
Michael