Adblock support thread

I posted them because the list can be added to adblock for openwrt.

1 Like

Check that the entry shown below match your config, e.g.:

If you have multiple relevant devices/interfaces to track please add the custom device named "any" ... and restart adblock afterwards.

1 Like

Ok it's working again! Thanks :pray:t3:

I have gone through the configuration. Even though I will be able to create multiple dnsmasq instances, still Adblock seems only one on one instance at a time. This is my understanding that it (adblock) cannot work on multiple instance simultaneously. Is this correct?
Indeed the options to change blacklist and configuration changes (eg. Safe search) as per different internal host IP is something lot of users looking to. Any working solution for this please..

In case, you are willing to do some work yourself, have a look here

It (also) does ad blocking. Configurable per client (MAC), of course.

Yep, that's correct. Multiple dnsmasq instances with different adblock configurations like separate black/whitelists source files etc. are not supported.

I am using Raspberry PI and wireless SSID based client segmentation is not feasible. If I have one network, will this solution work?

@peter2 @reinerotto this adblock support thread is long enough - even without discussions about other tools, solutions ... whatever. Thanks!

1 Like

Yes.. We understand that. Sorry for spamming the support Chanel.

I've added the new source list in adblock 4.1.0-2 today - thanks!

What would cause this (some OK and some NX)? The domains are all the same. It is in the block list.
Openwrt 19.07.7
Adblock 4.0.7-5

Why is the domain name blacked out? NXDOMAIN does not necessarily have to be triggered by adblock, it may also be triggered by the local DNS or the ISP.

The domain name is the same in each case. Let's just say it is It is in the block list, so they should all be NX, right? is not in my blacklist, but getting NX. it is may be by my upstream DNS.So for you also same. is not real. I was just trying to make the point (and obviously doing a poor job of it) that ALL the heartbeat."domain".com addresses were the same and was in the Block list but were getting different results. That didn't seem proper.

Don't expect useful answers without providing any kind of useful information, e.g. the 'real' blocked domain and the adblock status ... that's the bare minimum.

Updated the blocklist source panel with more sources. Thanks!

I have only just tried adblock (4.0.7, on OpenWRT 19.07.7) for the first time, although I have had the packages installed for some time.

I am trying the 'Force local DNS' option, but it doesn't seem to work. My config is as follows. I don't know where the adblock.extra section comes from - do I need to set the adb_forcedns option there also, or remove that section?

# uci show adblock'dnsmasq''uclient-fetch''wan''0''0''1''0''0''1''1''53''1''br-lan''adguard''1'

The behaviour I see is that I can still bypass the local router's DNS. The first host in /tmp/dnsmasq.d/adb_list.overall is

$ dig +short @
$ dig +short @

You've borked your adblock config during update, please re-install the package via opkg with the "--force-reinstall --force-maintainer" options.

1 Like

Thanks, that fixed it.