Adblock support thread

Just the wrong test. That test is made for adblock browser plugins which blocks on element level ... adblock and other tools like pihole blocks on (sub)-domain level and can't block elements on a page.

Thank you for the response.

The uBlock Origin extension is highly effective in my desktop Firefox: I don't see any ads from YouTube, but the adblock service in OpenWRT is not that effective for YouTube (which I'm mostly interested in): it does not block any ads from YouTube when I watch it on my MiTV 4K 55''. Is there a way to get blocklists uBlock Origin uses and apply it to the OpenWRT service?
The DNS report says that it blocked only 0.09% (much less that even 1%) DNS requests even though I enabled nearly all the blocklists

Adblock has no chance to be as effective as uBlock/ABP. This is, because
"... ABP and uBlock need to evaluate the URL of each net request against their dictionary of filters, ..."
which adblock can not do.
At least, not easily for https-traffic.
Which is the main reason, that goggle etc. hype https, with the fake argument of "security" for the user.
Adblock uses DNS-blocking, which can block all yotube, but not something like youtube/adverts.
On the opposite, a firefox/chome extension can "see" the complete URL, and can take appropiate action.
Correction: ... can still take appropiate action. Until such extensions are forbidden completely.

1 Like

If you have money for a 4K TV, you should also be able to pay the Youtube subscription (or the rate of other content providers).


Thanks! I had some DNS issues that caused slow responses and have addressed those, so no more timeouts.

Thanks also for pointing out the older regex; I needed to update the sources file as I had been using a customized version of a slightly older master.

Really appreciate your responsiveness on this as well as your work on the app!

That is true, but I am a software engineer and I like to play with software, so I figured it might be fun to configure my router to block ads.

Will man-in-the-middle help me resolve this problem? I use the router only by myself, so there are no ethical issues

Yes, there is a chance. With Firefox, as on Chrome goggle might use "pinned certs" for youtube, as it is same co. However, in case it works today, it might not work tomorrow, as https is a fast moving target. Be prepared for a lot of learning, in case you want to go this route first time :slight_smile:

1 Like

My apologies if this has already been covered, the thread is massive.

Is there any method someone's come up with to allow temporary passing of ad dns queries without turning off adblock?

I know this is a corner case but please bear with me a moment.

There are times when one user, for just a short period of time, say to load one page, would like ad blocking off. Either because a site they're interested in is behind an interstitial ad page or a web search would have them go through an ad.

And yes, I'm very aware that one "link" causes loads of network traffic and identifying the traffic and what needs blocking and not based on what's going through a meat puppet's mind may be beyond what's reasonable.

So, I'm asking just in case I'm not the first and someone's got some ideas :slight_smile:

I too needed a temporary selective not adblocked access from some devices, but adblock cant be configured that way. So, I ended up creating a separate wifi network, similar to a guest network, and configured it to use outside DNS servers so no ads are blocked. This config does require switching from one wifi to another for unblocked access, but it's better than logging in to the router to turn adblock off then back on.

I thought I installed both adblock and luci for adblock using opkg install [URL] but now when I try to access web interface I'm facing error

/usr/lib/lua/luci/controller/adblock.lua:7: attempt to call global 'view' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/adblock.lua:7: in function 'v'
	/usr/lib/lua/luci/dispatcher.lua:614: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:262: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>    

Should reinstall adblock work or what option do I have?

I'm on OpenWRT 18.x version would like to update to 19.x too.

Adblock 4.x is not compatible with 18.x ... stay with adblock 3.x.

You can easily configure to static links to suspend/resume adblock without further login to LuCI etc., just install the package "luci-app-commands" and follow the following description:

The commands you need to configure are "/etc/init.d/adblock suspend" and "/etc/init.d/adblock resume", after that share both public links with your wife, kids etc., e.g. as browser favorites.

Good luck! :wink:



I've updated from 3.5.5-2 -> 4.0.6 and noticed the white-list parsing seems to have changed.
Yes there is a message telling me that wildcards are not allowed, yet in 3.5.5-2 they worked.
when I put in the while-list, domains like where white-listed as well.
But in 4.0.6 this doesn't work anymore, may I ask what changed and why wildcards/top-level's aren't allowed?

Also when the white-list is saved all spaces/capital letters are removed from the comments
#Test Comment becomes #testcomment

I want to block a sub category of shallalist list called hobby/games-online. I modified the existing shallalist source as follows

        "shallalist": {
                "url": "",
                "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "categories": [
                "size": "L",
                "focus": "general",
                "descurl": ""

Unfortunately, that did not work. What is the right way to add the category in shallalist?


There is no such "hobby" category (doublecheck I've tested that successfully with e.g. "hobby/cooking".

Which dns backend did you use? In general wildcards are not allowed for whitelisting.

...because they are not allowed in domain names.If you need "spaces" in your comments use hyphens

Thanks, will hobby/games-online work?

yep, should work.

I use dnsmasq-full and when using the previous mentioned version of adblock using top level domain whitelisting worked. But it's not really about wildcards I guess, as it worked before. I don't know what the processing is doing differently in the new version, but isn't it possible to remove any reference * from any blocklist when is whitelisted?

Yes, spaces are not allowed in domain names. But the comments are not part of the domain names. I do see the reason why spaces and other disallowed characters are removed to prevent user errors, but formatting the entire file seems a bit harsh. Having spaces and capital letters in commentary is kinda useful.