Adblock support thread


No, adblock works per DNS instance. In principle there are two options:
a) Disable 'Force DNS' in adblock (it's disabled by default) and configure an external DNS on certain devices, e.g.
b) go the VLAN way and add an additional DNS instance without adblock


Just for reference, same settings are used.
OpenWrt SNAPSHOT, r9213-50b3044eeb - Adblock Version 3.6.4 - dnsmasq 2.80-6
OK! No out of memory.

OpenWrt SNAPSHOT, r9526-d0b969eee8 - Adblock Version 3.6.5 - dnsmasq_2.80-11
[78186.409776] dnsmasq invoked oom-killer: gfp_mask=0x14201ca(GFP_HIGHUSER_MOVABLE|__GFP_COLD), nodemask=(null), order=0, oom_score_adj=0

Tbh, I think it's unrelated to adblock since it worked fine before, adblock does contribute to the OOM but it's probablly some other underlying change that causes it.
From what I've seen in both those snapshots is that dnsmasq is stable on 121mb memory usage, and system memory is about 220mb free so why linux now kills dnsmasq because of OOM is beyond me.


first awesome plugin thanks! But is it possible to change the redirect to a specific ip?
Would be 10/10.


Great addon. The ads on WordPress sites used to be blocked e.g. but they have recently reappeared. Adblock Plus (the browser extension) deals with them so I guess they are blockable in principle. Any tips?


No, adblock answers with an empty response and status 'NXDOMAIN' ( no such domain ).


The ads on WordPress sites used to be blocked e.g. but they have recently reappeared.

I fixed it by getting the latest config

cd /etc/config
mv adblock adblock.old
mv adblock.conf adblock

Then into luci, turn on adguard, save and apply. No more WordPress ads.


Great, thanks for your feedback!:+1:


Hey, @dibdot & @slim0287 having the exact same problem.
Currently running on

Firmware Version: Lede SNAPSHOT r8810-09004e6e13
Kernel Version:4.14.88
Adblock Version: 3.6.5

DNS Quesries do not show at all when I hit refresh or if they show up they are too short and wrong date... as the example below which is taken as I write this.


My settings are the following.

Thank you in advance!


Please enable adblock debug, hit the "Refresh Report" button and send back the logread output (logread -e "adblock"), additionally provide the output of ps | grep [t]cpdump



Here you go

Fri Mar 15 19:45:57 2019 user.debug adblock-3.6.5[18384]: f_report ::: action: report, report: 1, search: +, count: 50, filter: false, print: false, reputil: /usr/sbin/tcpdump, repdir: /opt/adblock/, repiface: br-lan, replisten: 53, repchunksize: 5, repchunkcnt: 10, bg_pid:

When I hit ps | grep [t]cpdump nothing happens...


the tcpdump background process is not running ... make sure that your 'repdir' /opt/adblock really exist. After you've corrected this entry adblock needs a full stop/start cycle.

root@openwrt:/opt# ls -l
drwxr-xr-x    2 root     root          2048 Mar 15 19:45 adblock
root@openwrt:/opt/adblock# ls -l
-rw-r--r--    1 root     root           726 Mar 15 19:45 adb_report
-rw-r--r--    1 root     root           726 Mar 15 19:45
-rw-r--r--    1 root     root          1034 Mar 15 19:45 adb_report.json
-rw-r--r--    1 root     root          5610 Mar 12 12:10 adb_report.pcap0


did you check if tcpdump comes up (see my first post to you) after a stop/start of adblock?


Please excuse my ignorance but how am I doing this?
If i just hit tcpdump then it starts to capture packets...


In LuCI under System => Startup => Restart adblock or in CLI /etc/init.d/adblock restart


Oh sorry, I thought tcpdump start was something different,
the adblock restart thing I already did it many times, but I did a whole router reboot and it seems it fixed the issue. I'll keep an eye and will let you know.

As always thank you for your support!


would you consider building pixelserv-tls binaries for openwrt? i used it with entware without problems, easy to understand and blocked ads nicely with no dns errors on webpages. I recently tried nxdomain approach on openwrt but it does not block anything without displaying dns errors and package looks like bloatware, difficult to configure.