Adblock support thread


#711

Just block the toplevel domain (this automatically blocks all corresponding sublevel domains), in your example just add xyz.com to your blacklist and refresh the block lists afterwards.

Please note: adblock also supports syntactic sugar to whitelist a certain subdomain (e.g. aaa.xyz.com) even if the toplevel domain (e.g. xyz.com) is on your blacklist.


#712

@dibdot Unsure if it's working as expected, what IP should domains in the blacklist resolve to?
My router hostname is apu and a linux box hostname on the LAN is i-5, I've tried the same after restarting dnsmasq and adblock.

root@apu:~# grep deloton /etc/adblock/adblock.blacklist 
deloton.com

root@apu:~# /etc/init.d/adblock query deloton.com
::: results for domain 'deloton.com'
  + deloton.com

root@apu:~# nslookup deloton.com
Server:		192.168.1.10
Address:	192.168.1.10#53

Name:      deloton.com
Address 1: 194.187.98.221
Address 2: 194.187.98.167
*** Can't find deloton.com: No answer

[strykar@i-5 ~]$ nslookup deloton.com
Server:		192.168.1.10
Address:	192.168.1.10#53

Non-authoritative answer:
Name:	deloton.com
Address: 194.187.98.221
Name:	deloton.com
Address: 194.187.98.167

So it appears to be resolving in spite of existing in the blacklist, what am I missing here? The same results for any domains I add to the blacklist.
/etc/config/adblock - https://paste.ubuntu.com/p/cg9GvxVcpP/


#713

what's the ip address of your router? On your apu device try nslookup deloton.com 127.0.0.1


#714

can anyone help me with the adblock, i enable the adblock for wan and not seeing any add being blocked on any of the device.


#715

I've had similar issues when using more than one local DNS server.
Try using the Force Local DNS setting in adblock and see if it helps.


#716

Btw, dnsquery report says it blocks "wpad" domains, not sure where that block resides.
I've disabled automatic proxy detection in windows, it still shows up for some reason.


#717

This is unrelated to adblock. You'll receive "NX" for wpad cause this domain can't be resolved locally. Setup uhttpd for wpad distribution or disable these pac file requests in windows.


#718

I got whitelist mode working with dnsmasq option 'serversfile' as pointed out in the linked thread.
However there is no LUCI component added in dnsmasq to edit the serversfile entries.

What would be the simplest way to get LUCI for this feature, either through dnsmasq or adblock.

Tried luci-app-adlock built for 14.07 and 15.05; didn't work. It did add a menu in Luci- >services but gave below run time error.

/usr/lib/lua/luci/dispatcher.lua:461: Failed to execute cbi dispatcher target for entry


#719

adblock was never released for 14.x or 15.x - I don't support/care these historic releases. Please update to 18.x or forthcoming 19.x.


#720

I've tried, something in windows still looks for them. No biggie, just annoying to see it. Even my LG TV tries to look it up.......


#721

Hi! there's a small display bug in the report, when the hostname (in /etc/hosts) contains an underline.

:::
::: Top 10 Clients
:::
  + 1988     ::: SHIELDTV
  + 769_DESKTOP::: DESKTOP_PC
  + 677_IPHONE::: IPHONE_8

#722

Sure, I can fix this in a later version ... anyway, underscores are not allowed in hostnames

The Internet standards (Requests for Comments) for protocols mandate that component hostname labels may contain only the ASCII letters 'a' through 'z' (in a case-insensitive manner), the digits '0' through '9', and the hyphen ('-'). The original specification of hostnames in RFC 952, mandated that labels could not start with a digit or with a hyphen, and must not end with a hyphen. However, a subsequent specification (RFC 1123) permitted hostname labels to start with digits. No other symbols, punctuation characters, or white space are permitted.


#723

Thanks for the info! I replaced all underscores with hyphens.


#724

I just updated to the new stable 18.06.2 builds of Openwrt and the Adblock version is still 3.5.5. When does Adblock get updated builds in the stable builds?


#725

The stable branch is only for bug fixes - the current adblock 3.6.x development will be part of OpenWrt 19.x. Of course, you could download & install the latest adblock stuff manually on top of your 18.06.x build, just use the download links in the first post.


#726

Has anyone successfully got youtube ads blocked? I am using the web version in a browser on my smart TV, not the smart TV app version.
Thanks!


#727

In the past, for commercial "standard "software packages, at least, it was good practice, to do validity checks on the input data. Which not only meant range checks for numbers.
Also, has something to do with 'egoless programming'.


#728

Huh!? Maybe you should stick to the facts - the issue has already been resolved with this commit. Apart from that this is an Opensource project and not a commercial one (which often receive never updates) ... make us happy with your knowledge and contribute!


#729

Hello, is there a deep setting for bandwidth advertising?


#730

Thought I'd try 3.6.5-1, ugetted both Adblock and Luci ipks off the links of post #1. They seemed to be the (correct for me) x86-64, uploaded and installed apparently OK.

And according to the Luci package manager, they are the correct items. But, I don't see any of the runtime data, even though it seems that Adblock runs. I see in the logfile that it started, though the number of sitelists doesn't change from 3800 or so despite my checking more. Luci package isn't working right? Something else needed to get that version working I'm missing?