Adblock support thread


#670

Thank you for this new version.

I just installed it (Xiaomi WiFi Router 3G), it remains to test new features.


#671

Eh, what list blocks raw.githubusercontent.com? I'm sorry if this has been answered before.
Is there any way to find out?

EDIT: Added it to whitelist as workaround. I just thought it was a weird domain to have in a blocklist.


#672

Most probably you are using an old adblock config with a buggy adguard regex - please update at least the adguard section and re-run adblock.

since adblock 3.6.2 you can search in backups, too ... to find out the respective source list.


#673

@dibdot I have to stick to barrier_breaker. How can I get your latest version (3.5 or 3.6) to work with BB? I can re-build using BB sdk. Do you think that will work fine?


#674

BB? Well, that's really quite old ... :wink:
The frontend (LuCI) won't work.
The backend should work, maybe there are procd related auto start problems, if so please set adb_trigger to timed in your adblock config. Said that, this is a completely unsupported configuration ...

Good luck!


#675

Thanks.
Currently I am struggling to get the backend running.
I even tried setting adb_trigger to timed. No difference. Any steps to troubleshoot?
root@OpenWrt:/tmp# /etc/init.d/adblock restart
root@OpenWrt:/tmp# /etc/init.d/adblock status
::: no adblock runtime information available


#676

No, I never used BB. Just try to start adblock directly in /usr/bin/adblock.sh and go from there ...


#677

Nah, adguard isn't enabled and I'm using the 3.6.3 config now.
I guess I have to enable backups and grep the files?


#678

No, just use the query function, see here


#679

Must be some file i need to clear maybe, I get:

:::
::: results for domain 'raw.githubusercontent.com'
:::
  + raw.githubusercontent.com
:::
::: results for domain 'githubusercontent.com'
:::
  + raw.githubusercontent.com

#680

You haven't enabled adblock backups, with backups in place you will see something like this:

query


#681

I made some progress, however a few errors still remain.
Will /usr/bin/adblock.sh free the shell prompt and move to background if successfully running?
I want to use the whitelist feature so believe I need to use the later versions.
I had 3.1 working on BB.

root@OpenWrt:~# /usr/bin/adblock.sh 
adblock instance started ::: action: start, priority: 0, pid: 22470
user.info adblock-3.6.3[22470]: blocklist with overall 2 domains loaded successfully (AWF-5G, OpenWrt Barrier Breaker unknown)

root@OpenWrt:~# /etc/init.d/adblock status
::: adblock runtime information
/etc/rc.common: line 138: json_load_file: not found

nslookup shows the domain blocking is not working.


#682

Oh sorry, my mistake.
It was adb_list.urlhaus.gz.... I'll remove that list, didn't really trust it in the first place.
I really like the new features, good job!
Perhaps you could add a note in the luci-app that backups need to be enabled to get the full functionallity.


#683

@dibdot Thanks to your help, I was able to run version 3.5.0 successfully on BB.
blacklist worked so basic things are in place.
However I am not able to use the whitelist feature.
I emptied adblock.blacklist and added a domain in adblock.whitelist and restarted the app.
However I don't see this file getting generated: /tmp/adb_list.jail
Any directions please?

root@OpenWrt:/tmp# /etc/init.d/adblock status
::: adblock runtime information
  + adblock_status  : enabled
  + adblock_version : 3.5.0
  + overall_domains : 0 (normal mode)
  + fetch_utility   : /usr/bin/uclient-fetch (libustream-ssl)
  + dns_backend     : dnsmasq (/tmp)
  + last_rundate    : 16.01.2019 12:35:24

#684

extra option 'adb_jail' in adblock config enabled? Default is '0', enabled is '1'.

Edit: If you're only interested in the restrictive 'jail' list, it might be easier to maintain that list manually, see here


#685

I didn't find adb_jail in adblock.conf in version 3.5.0 when this feature is first added.


#686

It's not a mandantory option, therfore not part of the stock config. Usually the setup is done via LuCI ... you should always consult the online readme, here the link for 3.5.0: https://github.com/openwrt/packages/blob/c44e40809eb30e937e390b541807515ed594b664/net/adblock/files/README.md


#687

So i enabled adb_jail option and restarted.
whiltelist is not working. All sites are accessible.
Here are some outputs, if it helps.

root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option serversfile '/tmp/adb_list.overall'

root@OpenWrt:~# cat /tmp/adb_list.overall 
root@OpenWrt:~# cat /tmp/adb_list.jail 
server=/rediff.com/#
server=/#/
root@OpenWrt:~# /etc/init.d/adblock status
::: adblock runtime information
  + adblock_status  : enabled
  + adblock_version : 3.5.0
  + overall_domains : 0 (normal mode)
  + fetch_utility   : /usr/bin/uclient-fetch (libustream-ssl)
  + dns_backend     : dnsmasq (/tmp)
  + last_rundate    : 16.01.2019 20:46:10

#688

Sorry with historic releases like BB you are on your own, no more input from my side (maybe others chime in).


#689

Thank you for your work and the great addon.
I'm on the latest snapshot release (3.6.3) and everything works great.

I noticed, however, that the report function only evaluates a certain time interval.
The router is already running for one day. Do you know which option this affects?

root@LEDE:~# /etc/init.d/adblock report
:::
::: Adblock DNS-Query Report
:::
  + Start    ::: 2019-01-17, 05:02:32
  + End      ::: 2019-01-17, 06:36:03
  + Total    ::: 200
  + Blocked  ::: 0 (0.00 %)
:::
root@LEDE:~# uptime
 08:28:24 up 1 day,  3:27,  load average: 0.06, 0.07, 0.07