Adblock support thread


I also noticed this problem, on wifi side does not block the ads on YouTube.
I use the version compiled by Daniel Petre for wrt1900acs v2, Kernel Version 4.14.90 SNAPSHOT r8392+474-3dba852547 / LuCI Master (git-18.354.50772-49c558a) Adblock Version 3.6.0


@herik @oli
Hard to block 100% ads on youtube, because:
dibdot says:
Please remember that you block always on (sub-)domain level (and not on page element level!) - the same applies to other projects like pihole. For remaining ads on advertising platforms like youtube, facebook etc. it's likely that you need additional browser plugins which are hiding ads on DOM level, e.g. injecting JavaScript to skip the YouTube ads ... anyway you'll never get 100%.


@ leeandy
Now i understand why on the wifi side does not block all ads, thanks for the reply.


Which is the reason, that goggle etc. are strong advocates of https. To invalidate the use of "simple" ad-blocker like "Adblock", not to harm goggles etc. business.


This is unrelated to http/https protocols - legit content & ads are served from the same (sub-)domains, that's the problem.


I've pushed adblock 3.6.1 to snapshot repo. This version supports multiple tcpdump interfaces & ports, see - LuCI interface has been updated, too.


Upgraded about 16h, it's work great. Thanks you.



After enabling Adblock and adding many lists, I cannot update Magisk and its modules with its Manager program. Using Query domains tab, I found out its blocking Then, I whitelisted both and on Edit Whitelist tab by adding these lines:


Still, the connection cannot be established by Magisk Manager. What am I doing wrong?

Here is the configuration page:



I don't know this Magisk software - maybe others chime in.
Anyway, please start with a fresh adblock config (use the "--force-maintainer" option during opkg install) to update your regex expressions, esp. for adguard. Also you can use the new Report Manager to find blocked domains during your Magisk update.

Edit: Please always "Refresh" your blocklist after you've added/removed domains from your blacklist/whitelist.


Ok, but I don't want to reset everything. So, I may use that option later. I do refresh my blocklist, but it doesn't seem to change anything.
Is adding domains with a "+" sign ok?


Shifting this conversation from a different thread....

"Package adblock (3.5.5-3) installed in root is up to date." Luci still says 3.5.5-2. ?????

That's an "expected" cosmetic issue, as I have forgot to update the version number within the main shell script - just ignore it.

AdBlock whitelist doesn't appear to be working?

No, whitelisting works fine. Check with /etc/init.d/adblock query if the domain is still found/blocked. If so, update your whitelist and "Refresh" your blocklist afterwards.


I switched the 2 entries I have in my whitelist, one of which is, then "save" the configuration.

"Refreshed" the blocklist, and still receiving "Server not found" message. Same via login to my router:

root@LEDE:~# /etc/init.d/adblock query
::: results for domain 'airvpn dot org' <can't put more than 2 links in my message per forum rules>

  • no match


@dibdot Adblock may also can contain block ads on Spotify App?

Host Content:


— Spotify Ad Block

— Spotify Ads Block End



no, just domains - one per line.


I'm using spotify premium! :wink:
Feel free to ad lists as you like ... maybe it's easiest to create a github account and host your personal list there ...


Then you have a problem with another domain or it's completely unrelated to adblock.


FYI. I shutdown AdBlock, and was able to access AirVPN again. Started AdBlock up, reloaded the blocklist, and still can access AirVPN. Not sure what's going on, but my OpenWRT instillation, including AdBlock, has usually been rock solid. This seems too quirky to be right.


just for your information: has changed the feodo tracker downloads -
the feodo domain list used by adblock has been abadoned - you could remove this one.



I have 4 Blocklist Sources to add :

Can i just copy reg_id and change url on option adb_src ?

Thank you


Should work, just try it. BTW, please make sure that config source 'xxx' is always unique in your config.