Adblock support thread


#427

Hi,
first of all thank you for this great package. I would like to know if there is any performance comparison in terms of blocking capability of each solution adblock, ublock origin and pi-hole.
I noticed that ublock origin is the best solution especially due the fact that many Web sites stream the content together with the ads and so it is the only one that can block them without blocking all the Web site. A brief analysis between ublock origin and pi-hole. However, in theory, adblock and pi-hole should be able to block the same contents since they work similarly at DNS level.
In practice, I noticed that pi-hole is better than adblock (I used this list of Web sites as benchmark). I'm using the latest version of adblock v3.4.3 with dnscrypt-proxy (force local DNS and flush DNS cache options enabled) and all block list sources enabled plus custom filter standard privacy (overall domains 102294).
Is it normal or I can do something in order to improve openWRT performance?
Thank you


#428

Hello and thanks for this great package.

I have a big issue when I try to add a blocking source to conf file, for example:

config source 'Liste FR+EasyList'
  option enabled '0'
  option adb_src 'https://easylist-downloads.adblockplus.org/liste_fr+easylist.txt'
  option adb_src_rset 'BEGIN{FS=\"[|^]\"}/^\|\|([^([:space:]|#|\*|\/).]+\.)+[[:alpha:]]+\^("\\\$third-party")?$/{print tolower(\$3)}'
  option adb_src_desc 'Liste FR'

In LEDE I have this message in overview:

Please update your adblock config file to use this package.
During opkg package installation use the '--force-maintainer' option to overwrite the pre-existing config file or download a fresh default config from here

Do I need to do something or made I something wrong ? I have tried to modify an existing source and same message...
And I have tried modify the list with luci-app and with Putty and same error... Reboot - nok

And then when I go to "Advanced" I have this message:

/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute firstchild dispatcher target for entry '/admin/services/adblock/advanced'.
The called action terminated with an exception:
/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute cbi dispatcher target for entry '/admin/services/adblock/advanced/blacklist'.
The called action terminated with an exception:
...usr/lib/lua/luci/model/cbi/adblock/blacklist_tab.lua:9: bad argument #1 to 'access' (string expected, got nil)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:460: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>

I have adblock (3.4.3-1) and luci-app-adblock (git-18.147.69097-36945b5-1) ...
Thanks for help :wink:


#429

You used an invalid section name (with spaces!) which is not allwoed and leads into an non readable uci config file.

To check your uci syntax, ssh to your router and run something like that, e.g.

root@blackhole:~# uci show /etc/config/adblock 
uci: Parse error (invalid character in name field) at line 109, byte 34

Hope this helps.


#430

@dibdot It does not work, when I click Save it is deleted.
I put it below of 'reg_de' or in the last line.
luci-app-adblock v3.5.2-1

config source 'reg_de'
	option adb_src 'https://easylist-downloads.adblockplus.org/easylistgermany+easylist.txt'
	option adb_src_rset 'BEGIN{FS=\"[|^]\"}/^\|\|([^([:space:]|#|\*|\/).]+\.)+[[:alpha:]]+\^("\\\$third-party")?$/{print tolower(\$3)}'
	option adb_src_desc 'focus on german ads plus generic easylist additions, daily updates, approx. 9.200 entries'
	option enabled '0'

config source 'reg_es'
	option adb_src 'https://easylist-downloads.adblockplus.org/easylistspanish+easylist.txt'
	option adb_src_rset 'BEGIN{FS=\"[|^]\"}/^\|\|([^([:space:]|#|\*|\/).]+\.)+[[:alpha:]]+\^("\\\$third-party")?$/{print tolower(\$3)}'
	option adb_src_desc 'focus on spanish ads plus generic easylist additions, daily updates, approx. ??? entries'
	option enabled '1'

#431

Probably you're using a LuCI snapshot image!? Please post the output of:

opkg list-installed | grep "luci -"

Nevertheless you could use a shell editor like nano and edit the config file.


#432

@dibdot I'm not at home, but if I have a snapshot installed, I think the kernel is 4.14

if you leave me the steps as edit the file with putty when I'm at home I'll try.

or add in Adblock EasyList Spanish, as the other languages


#433

@Help_ME The LuCI bug you've mentioned is unrelated to any kernel version. Until this commit you could only edit very small files in LuCi. To fix it, get & install a fresh snapshot.


#434

Thanks for the great work mate but it doesn't work for me unfortunately.
All the SSL libraries and packages are well configured with all the desired hosts downloaded.

I added all the facebook websites to blacklist but they open in all the connected devices.
Hence, to check if the ad block is really working, I took some random websites from adguard blocklist and they did open :frowning:

Adblock log says all the 45000 domains are successfully loaded with dnsmasq taking 14% of RAM but it fails to block any website in blacklist or hosts file. Any ideas ??
I have the Express VPN(Open VPN) loaded into my router which recommends Google DNS to be configured into the router. Are there any extra steps to be taken if we are using VPN & Google DNS in the router ??


#435

Using adblock 3.5.2-2 on 17.01.4

Using default blocklists and "forcesrt=1" I get:

# grep uimserv adb_list.overall
server=/adclient.uimserv.net/
server=/advideo.uimserv.net/
server=/madclient.uimserv.net/

if I add blocklist "reg_de" and "forcesrt=0" I get:

# grep uimserv adb_list.overall
server=/adclient.uimserv.net/
server=/advideo.uimserv.net/
server=/madclient.uimserv.net/
server=/uimserv.net/
server=/adclient.uimserv.net/
server=/advideo.uimserv.net/
server=/madclient.uimserv.net/

If now "forcesrt=1" I get:

# grep uimserv adb_list.overall
server=/uimserv.net/

up to this point it works as designed. Brilliant work.
Now I whitelist "adimg.uimserv.net" and still get the same result.
Looking into dnsmasq manual I would expect:

server=/uimserv.net/
server=/adimg.uimserv.net/#

The manual say:
"The special server address '#' means, "use the standard servers", so --server=/google.com/1.2.3.4 --server=/www.google.com/# will send queries for *.google.com to 1.2.3.4, except *www.google.com which will be forwarded as usual."

Thanks for your support


#436

This is the expected behaviour with the current release level - the whitelist function is only a grep against the existing blocklist ... and adimg.uimserv.net is not in the list.

I'll try to implement that feature with the next release. Thanks for your input.


#437

Winspy

https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/data/hosts/win10/spy.txt

moved to

https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/data/hosts/spy.txt


#438

Yep, thanks - I've already pushed 3.5.2v2 with the config change on github few days ago (https://github.com/openwrt/packages/pull/6186)

Thanks again!


#439

@dibdot Dirk, after 3.5.3 upgrade this morning, there seems to be a problem with the luci-app-adblock UI.

Adblock-OpenWrt

After noticing the problem, I decided to delete and create a fresh adblock config from the adblock-opkg file just in case there were newer changes that might cause this problem.

Unfortunately, it did not resolve the problem. So for now I have setup my config via SCP and all is working well now. Just the UI problem remains for now. Please let me know if there is anything I can provide to help test.


#440

did rm -rf /tmp/luci-* help?


#441

can someone here try if these domains resolve with adblock enabled, I had to disable it which also made resolving anything feel a lot faster


https://makefrontendshitagain.party/


#442

Thank you for the quick response. I ran that command just now, followed by a reboot. Unfortunately the UI problem still persists.


#443

Can't reproduce your problem by now. Please provide the output of opkg list-installed | grep "adblock"
and ubus call system board. Also it would be nice, if you provide me the complete link where you downloaded the luci package. Which browser did you use?


#444

Generally, I look for the first snapshot package target which contains it. This morning, it was:
https://downloads.openwrt.org/snapshots/packages/arm_cortex-a5_vfpv4/packages/
and
https://downloads.openwrt.org/snapshots/packages/arm_cortex-a5_vfpv4/luci/

/$ opkg list-installed | grep "adblock"
adblock - 3.5.3-1
luci-app-adblock - git-18.159.27957-81c6606-1
/$ ubus call system board
{
	"kernel": "4.14.43",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Linksys WRT3200ACM",
	"board_name": "armada-385-linksys-rango",
	"release": {
		"distribution": "OpenWrt",
		"version": "18.06-SNAPSHOT",
		"revision": "r6987-dd49c62",
		"target": "mvebu\/cortexa9",
		"description": "OpenWrt 18.06-SNAPSHOT r6987-dd49c62"
	}
}

Please let me know if there is anything else that might be beneficial.


#445

OK, you are on the 18.06-branch and not on the latest snapshot ... few days ago, there was a treewide change to convert HTML tables to div based markups (together with additional styling changes) in LuCI, see here. These changes are not in 18.06 tree - @jow any plans to backport this to 18.06?

Options for you:


Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds
#446

This does sound like the smartest solution for the time being. That way I benefit from any underlying adblock changes while still retaining the functionality from the slightly older front-end. This should work well as long as there are not any significant underlying development changes coming up soon for adblock.

I can confirm that this suggestion is working well for me and I will continue running the latest adblock (as I always have) while not upgrading the luci-app-adblock package for now until the issue can be resolved on 18.06 branch. Hopefully a backport will be feasible for this branch.

Thank you for your time as always and for your thorough and detailed troubleshooting steps. Have a great weekend!