Adblock support thread

Oh sorry I thought I wrote about that but it seems I forgot...
Every time the log tab says No adblock related logs yet!

Maybe I can send an ssh command next time it will happen?

Ok is stuck again.
What should I do? How can I obtain a log file?

Thank you.

We need adblock debug logs (see online readme), maybe you already see other adblock unrelated problems if you check the logs (ssh to your router and type "logread")

Nothing adblock related on logread.
Nothing if I type logread -e "adblock"
Nothing if I type /etc/init.d/adblock report

Thank you.

Which OpenWrt release did you use? Please post the output of /etc/init.d/adblock status

  /etc/init.d/adblock status 
::: adblock runtime information   
+ adblock_status  : running   
+ adblock_version : 4.0.7   
+ blocked_domains : 100525   
+ active_sources  : adaway adguard bitcoin disconnect malwaredomains malwarelist reg_vn spam404 stopforumspam youtube yoyo   
+ dns_backend     : dnsmasq, /opt/adblock/tmp   
+ run_utils       : /usr/bin/curl, /usr/bin/awk   
+ run_ifaces      : trigger: -, report: br-lan   + run_directories : base: /opt/adblock, backup: /opt/adblock, report: /opt/adblock/tmp2,

I'm running Davidc502 build.

Maybe I should try to complete uninstall adblock and re install it from scratch?
After uninstalling, I have to manually delete the folder on /etc/adblock to be 100% clean?

I don't know this unmaintained build - most probably its related to this build and not to adblock itself.

@davidc502 builds are far from unmaintained...
Problem is that only adblock behaves that way and is from v4 that I started to see this bug.

I will try again to install everything from the start to be sure and reply back.
Is there any ssh command, for adblock verbose debugging?

just ask in the davidc thread... 70%+ chance this is related to whatever is happening with opt ... as dibot dibdot says, it's not 'common' by any means...

1 Like

I ran David’s builds until recently, and never had an issue. As @wulfy23 says, something about /opt rings a bit strange. What does ls -ltr /opt return

drwxr-xr-x 5 root root 2048 Nov 20 01:32 adblock

opt is a usb driver used specifically for adblock and some other reporting tools which are working fine.

@dibdot :wink:

1 Like

Change back your base temp directory and your dns directory to their defaults (remove these entries) and reboot your router.

Edit: BTW, it's always useful to define a (wan) trigger interface.

What's the recommended list of blocklist sources these days? And how much for a R7800? over or under 300k? 400k?
Tips appreciated.
I'd like to block as much as possible, without chocking the router. :smiley:

Adblock is fine writing it’s temp directories to USB, but it makes absolutely no sense to do so.

The interface trigger on the other hand would seem to be critical. If it’s not set in the config or enforced in the init, Adblock would never get a service reload from one boot to the next - unless of course the user issues a service reload or manually edits the config.

Nope, when the trigger interface is not set adblock starts after a certain timeout (configurable via trigger delay).

Hi, I installed AdBlock on the Router and always thought it worked, however I have a doubt that now I explain.I have installed both Adblock on the router and also an addon on the browser to check what actually blocks the router and the result is that the addon blocks a lot stuff that I don't think should pass. Why does the addons activate and block elements (AdGuard or even more Origin) even if the AdBlock is active on the router? If you need screenshoots please ask but I think the configuration is correct.

That's a wrong expectation, answer see here Adblock support thread

So its normal @dibdot ? I think I understand that the cookie is detected but requests to that domain are blocked by AdBlock. Correct?

Actually the problem was the trigger been to unspecified.
Now it does not hang on running. But I face another problem.
If I restart the router everything works as expected and the status is enabled and around 100k domains blocked.
If I leave it for a couple of hours, the 100k blocked domains, return to 0
Again no logs.