Adblock only for one specific interface

Hello,
I know that this question has been answered multiple times, but I'm not able to get this working. I would like my "lan" interface to have Adblock enabled, and my "app" interface to not.

So to do that I have created multiple DNS entries, here's some of my dhcp file:

config dnsmasq 'lan_dns'
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases.lan'
        option resolvfile '/etc/resolv.conf.lan'
        option nonwildcard '1'
        list interface 'lan'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option instance 'lan_dns'
        option interface 'lan'
        option start '30'
        option limit '150'
        option leasetime '12h'

config dnsmasq 'app_dns'
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/app/'
        option domain 'app'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases.app'
        option resolvfile '/etc/resolv.conf.app'
        option nonwildcard '1'
        list interface 'app'
        list notinterface 'loopback'

config dhcp 'app'
        option instance 'app_dns'
        option interface 'app'
        option start '30'
        option limit '150'
        option leasetime '12h'

And here's some of the network file:

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.12.1'
        list dns '192.168.12.1'

config interface 'app'
        option proto 'static'
        option type 'bridge'
        option netmask '255.255.255.0'
        option ipaddr '192.168.13.1'
        option ifname 'eth0.2'
        list dns '192.168.13.1'

Adblocker is still working on both interfaces, but I don't know exactly why at this point (but I'm pretty sure I'm doing something wrong).
Thank you for your help

3 Likes

Thanks for your answer. I do not think I'm concerned about local resolution, so I restored the original dhcp config file.

I tried to assign other DNS to the specific interface:
image

But I still see no ads, so for some reason is still not working. Any advice?
Thanks again

That's not it.
Check here for option 6.

2 Likes

Thanks to both. That worked!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.