Adblock not working as expected


I am trying to set up adblock. It seems to be running OK, I added the following sources: adaway, adguard, disconnect, energized_ultimate, yoyo (around 460K domains). But adds are still showing like crazy if I disable adblock in my Chrome browser. I thought that OpenWRT adblock performance would be similar to browser based adblock. Is this expected or am I doing something wrong?

Below is my configuration:

Status / Version

enabled / 4.0.6

Blocked Domains


Active Sources

adaway, adguard, disconnect, energized_ultimate, yoyo

DNS Backend

dnsmasq, /tmp/dnsmasq.d

Run Utils

/usr/bin/aria2c, /usr/bin/awk

Run Interfaces

trigger: wan, report: -

Run Directories

base: /tmp, backup: /etc/adblck, report: /tmp, jail: /tmp

Run Flags

backup: 1, reset: 0, flush: 0, force: 0, search: 0, report: 0, mail: 0, jail: 0

Last Run

start, 0m 35s, 970/547/699, 02.09.2020 18:49:31

Thank you!

  • Verify that OpenWrt is your only DNS server on the client.
  • Make sure to disable DoH in the browser.
1 Like

Thank you, I used ISP Ipv6 DNS. I changed this setting to auto and now it seems it works. I have a feeling that internet sites are now loading slower. Is this due to adblock?

1 Like

It may be the latency of your upstream DNS provider:

What kinda machine are you running OpenWrt/Adblock on?

1 Like

The problem resolved for itself, now pages load fast as expected. I run modified version of OpenWRT (FriendlyWRT) on NanoPi R2S (4 core 1,5Ghz, 1 GB RAM).

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.