Adblock not blocking ads?

I've installed Adblock and luci-app-adblock

It initially didn't appear to be blocking adverts in Chrome.

I then disabled secure DNS and thngs are better, but I'm still receiving 'Taboola' promoted content.

I've tried adding '' to the block list, but it hasn't worked.

Any ideas?

I've just tested it as I use adblock as well. The content is coming from, using the default blocklists, it should be blocked:

::: domain '' in active blocklist
  - no match

::: domain '' in active blocklist

::: domain '' in backups and black-/whitelist
  + adb_list.adaway.gz  

Confirm adblock is in fact filtering, by running on a client that's using your upstream DNS with adblock:


If you get NXDOMAIN that means adblock is filtering and the JS loader shouldn't be able to load. Browsers like to aggressively cache these days. If it does return DNS info, something in your DNS chain is bypassing adblock.

1 Like

Blocked/redirected externa DNS calls?

And are you sure the ad is actually hosted by taboola, and not some CDN?

If your client's an android device, you need to disable DoT too.


Adblock is definitely working. I tested it by loading the Daily Mail (not a site I usually visit, but I know it is stuffed full of adverts and scripts). The Taboola content is somehow getting through on this page:

If you try and load in Chrome, does it resolve the JS?

Could be cache issue?

1 Like

It was the cache. Thanks for your help.

Always cache isn't it! Glad it's sorted!

I'm seeing these messages in the logs. Do I need to install another package?

Wed Jun  9 15:50:52 2021 adblock-4.1.2[7788]: Please enable the 'DNS Report' option to use the reporting feature
Wed Jun  9 15:50:54 2021 adblock-4.1.2[7880]: Please enable the 'DNS Report' option to use the reporting feature

Reporting needs the following in the global config /etc/config/adblock

option adb_report '1'
/etc/init.d/adblock restart

Requires you have tcpdump-mini or full tcmpdump to generate reporting data though, install either with:

opkg install tcpdump-mini


opkg install tcpdump

If you have the flash space for the full toolset.

1 Like

Perfect. Thanks for you help. I appreciate it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.