Adblock-fast: ad-blocking service for dnsmasq, smartdns and unbound

Thanks for the report, should be addressed in 1.0.0-5 (available in my repo), I'll create PR/merge changes to OpenWrt repo in the next 24-48 hours.

Thanks for this new project. Adblock-Fast has been working great for me for the past couple weeks (WRT32X, running 23.05-rc4 right now). I removed Simple-adblock and replaced it. Currently version 1.0.0-4. No issues to report but it's nice others helped find bugs :slight_smile:

1 Like

Adblock-fast mistakenly recognizes some domain files as hosts files (in system log) and thus only blocks a small percentage of entries.


Latest version 1.0.0-4 on OpenWRT 23.05 rc4.

Another issue is that the force redownload button in Luci does not work.

Both of these issues do not exist on simple adblock Openwrt 22.03.5

Should be fixed in 1.0.0-6 in my repo, I'll create PR/merge changes within 24 hours.

Also fixed in the luci-app version 1.0.0-6.


Thnx for this tool! 1.0.0-6 seems to be working / reloading fine.

1 Like

@ Stangri: does your Adblock work with Openclash in Openwrt ?? if yes i would like to know what are the settings to be changed or simply the default settings work out of Box ?

Thanks in advance.

I've added a brief adblock-fast status section to the Status->Overview in the most recent luci app build.

I welcome any suggestions what should be shown there.


luci-app-adblock-fast 1.0.0-6

These msgids ("Size", "block" and "allow") are missing from PO files so they cannot be translated:

1 Like

The Size is going to be made localizable in version 1.0.0-7.

The block/allow is how the GridSection renders the values, if you edit any of them, you'll see localized text, however in the GridSection itself it shows the literal value from the config file. @jow -- anything I can do about it? This is the js snippet:

		o = s3.option(form.ListValue, "action", _("Action"));
		o.value("allow", _("Allow"));
		o.value("block", _("Block"));
		o.default = "block";
1 Like

Try this:

o.textvalue = function(section_id) {
  var val = this.cfgvalue(section_id);
  return val == "allow" ? _("Allow") : _("Block");

Hi, I have adblock crashing, after a certain number of hours. I attach a screenshot of the memory. What could be the problem?

Please elaborate on that.

@stangri Pleas can we have a name for the lists in LUCI. I am talking about the table under the heading, AdBlock-Fast - Allowed and Blocked Lists URLs
Because most people will not know what"" is going to block.

Can you give me like 3-5 examples of what are you talking about? Also, what names should be shown for the URLs that users add manually and that don't come in the default config-file?

In adblock the lists have names like: adaway, adguard , adguard_tracking , android_tracking , anti_ad , antipopads , anudeep , bitcoin , and smarttv_tracking
This is not all of them. I am just trying to think like some one that has never used a router add blocker before.
The learning curve for OpenWrt is big as it is.

you can just make a name field so people can label the custom lists what they like. You could install the other adblock packages and see which things they got rite.

I also see Service status - Version - Stopped in the GUI

However in terminal it is still running

root@router:~# service adblock-fast status
adblock-fast 1.0.0-7 is blocking 380256 domains (with dnsmasq.servers) [✓]

And when checking I get result of 93% which confirms that it is still active.

=> Possibly a glitch in the UI ?

I've tried to reply from mobile and it didn't seem to have worked.

What version of the luci-app-adblock-fast do you have installed?

Version info:

root@router:~# opkg info luci-app-adblock-fast 
Package: luci-app-adblock-fast
Version: 1.0.0-7
Depends: libc, luci-base, adblock-fast, jsonfilter
Status: install user installed
Section: luci
Architecture: all
Size: 9760
Filename: luci-app-adblock-fast_1.0.0-7_all.ipk
Description: Provides Web UI for adblock-fast service.
Installed-Time: 1698775138

Oh, I was going to post the exact same thing, service shows as Stopped but ads still get blocked, so looks like an UI bug.