Adapting IPv6 setting from TP-Link to Openwrt

While using tp link firmware works well with ipv6 but not on openwrt.
Openwrt gets a public wan ipv6 but not able to assign to other devices.
Help me as a beginner as I tried whole last month to get ipv6 but failed and abandoned for indefinitely.
But now, it my last hope for getting working this time which I hope the community could help me.

For replacement I will be using a x86_64 mini thin clint pc dell wyse 3040 with TP-Link USB to Ethernet AX88179.

TP-Link XZ000-G3 V2 and TP-Link Archer A6 V2 (to be replaced with the mini pc for routing, firewall, DHCP and other to releif existing router).

IPv6 Setting from TP-Link

Internet Connection Type: Dynamic IP (SLAAC/DHCPv6)

Public ipv6 address: /64
Primary DNS: 2606:4700:4700:1111
Secondary DNS: 2606:4700:4700:1001

Advanced

Get IPv6 Address: DHCPv6
Prefix Delegation: Enable

DNS Address:

Use the following DNS Addresses
Primary DNS:2606:4700:4700::1111
Secondary DNS:2606:4700:4700::1001

LAN

Assigned Type:SLAAC+Stateless DHCP
Address Prefix: /64
Address: /64

You have to locate all the same checkboxes under wan6
No transition protocols involved.

Well thanks for the reply
I did but it's confusing especially LAN ipv6 DHCP setting
It is vast number of setting what to be changed and have different term and name

You have cloned mac and alteted dns, you just need to apply those in wan6 if defaults fail.

It looks like the ISP has a conventional IPv6 prefix delegation. Two non-default settings you may need to change are reqprefix on wan and ip6assign on lan. Check if you are getting a prefix on wan and of what size. You can see this on the main status page IPv6 Upstream or on the CLI use ifstatus wan6. Try different values of reqprefix in particular 48, 56, and 60. The larger prefixes (smaller mask number) are preferable since you have control of more bits to delegate them to LAN(s).

Set ip6assign on lan to 64 if you don't have any additional routers downstream. The default is 60 but 64 will work if you can only get a /64 from the ISP.

#in /etc/config/network

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option device 'br-lan'
        list ip6class 'wan6'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ip6assign '64'
        list ip6class 'wan6'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'
#in /etc/config/dhcp

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'

This is the best option.

See my post here to see help you...

[Solved] Help to config IPV6 correctly on my router - Installing and Using OpenWrt - OpenWrt Forum

1 Like

@mk24 @lleachii
Thanks for the suggestion and sorry for delay but it cant delegate ipv6 other than router itself or directly connected to the gateway

this is my local network diagram

and this is the interface page screenshot
image

@lleachii
i have used the config and edited on my pc but stuck at ipv6 /128

Also for some reason there 5 IPV6 address 1 was local and others were start with 2405 and so on

Public IPv6 addresses (GUA) that are routable on the Internet start with 2 or 3; those are the ones of interest here. You have a /64 from the ISP, this should transfer to your one LAN and the LAN interface's IP will be the ::1 of that /64.

Bridged ("dumb") APs operate at layer 2, they don't route by IP. So the IPs (v4 and / or v6) will be passed on to users as the same prefix. If the rest of your network is only switches and bridged APs you don't need to configure anything related to IPv6 on them. The users will have their IPv6 access routed and controlled at the main router.

You may want to hook up the TP Link again to see if the ISP gives you more than /64 on it, and only if they do, work toward OpenWrt also obtaining that larger prefix. Although I don't expect the stock firmware to do much with IPv6 other than delegate a single /64 like you have now.

just now, ipv6 is working after switching back to TP-Link router
all the devices in the lan were able to pass ipv6 test

anyone can help
any way to what is wrong and how to diagnose problem better in layman terms
last, any resource that can help me understand what is going behind the problem

Your wan6 shows a /64PD from your ISP which means you can't subnet further, so you need to use relay in order to get IPv6 to your devices, edit wan6 and Lan interfaces and setup relay as per below, note because the /64 is small only devices on your Lan subnet will receive ipv6

config dhcp lan
option dhcpv6 relay
option ra relay
option ndp relay
...

config dhcp wan6
option dhcpv6 relay
option ra relay
option ndp relay
option master 1
option interface wan6

1 Like