Activation of network connection failed


I can't configure a openwrt router on a fedora 38 with gnome because it gives me the "connection failed - activation of network connection failed" message and disables the connection.

When did linux distros become so opinionated that they'll not allow you to hold an internetless network connection?

How to get around this?


Do you mean connect to a router running openwrt ?

checked ?

1 Like

Your post is unclear (perhaps more detail is needed). Are you referring to:

  • router running OpenWrt; or
  • or a PC/laptop running Fedora (i.e. not related to OpenWrt)?

To be clear, OpenWrt allows you to connect to LAN - even if WAN doesn't have established Internet connectivity.

but, some clients will disconnect again, until forced to stay on a network "without internet access",
how this is determined is OS specific, but often by using an internet based canary domain.

True; but this isn't the Fedora forum. Maybe someone can expound on this.

I agree, let's wait for OP's answer ...

1 Like

OP back here.

I'm sorry for all the confusion. Yes, it is a Fedora doubt, not an OpenWRT doubt.

First and second time I flashed a router with OpenWRT I couldn't configure it using a notebook with Fedora because it kept disconnecting after failing the connectivity check (because the router didn't have internet yet). This time I only had that notebook in hand, so I had no other option.

The thing is, when you search online for that problem, 99% of people are actually connecting to a network that was supposed to have internet, which is why I figured you guys here might have the answer.

This is a good place to start. Although the proposed solution doesn't work for me. In the end, for some reason, it slowed down the connectivity checks and gave me enough time to configure the router before disconnecting me. So in a way it solved the problem.

Thanks y'all!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.