Activate RW to restore ART mtd backup


I have ART partition corrupted but also a backup of it but I am struggling to found a way to write it back.

From this there are 2 ways, activating RW or using uboot.

Currently uboot is not an option for me but I am not finding a way to install kmod-mtd-rw in this router tp-link WR741ND v2 (OpenWrt 18.06.8, r7989-82fbd85747)

root@OpenWrt:/tmp# opkg install kmod-mtd-rw_4.4.92\+git-20160214-1_mips_24kc.ipk 
Installing kmod-mtd-rw (4.4.92+git-20160214-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mtd-rw:
 * 	kernel (= 4.4.92-1-45d282495a15974d60f8edb091d0e2a9)
 * opkg_install_cmd: Cannot install package kmod-mtd-rw.

Any other way to activate the RW?

1 Like

OpenWrt 18.06.8 and kernel 4.4.x do not fit together.

for mips_24kc

  • 17.01.x is kernel version 4.4.x
  • 18.06.x is kernel version 4.9.x

There must be something wrong in your opkg configuration.


If it's a release build, and the router is connected to the Internet, the proper version will be in the repository and can be found and installed automatically. Run opkg update then opkg install kmod-mtd-rw.

I don't think it exists for 17.01 but it should be in 18.06.

Hi tmomas,

Thanks for fast answer, just flashed the (17.01.7, r4030-6028f00df0) and got same result.

Maybe is this package but I couldn't found any other for mips_24kc < 19.07.x

Hi mk24

I went straight to the repository ( triggered by opkg update and there is no candidate for kmod-mtd.

Or maybe I went to the wrong one but don't think so.

Packages that are target specific rather than platform specific, such as kmods, are under the target directory. In other words there are several system on chips (targets) with the MIPS24kc CPU core (platform) and they have different kernel builds thus needing their own build of kmods. But packages that run in userspace will run on any MIPS24kc chip without much concern for the exact kernel, thus they are stored in a separate place to reduce space.

This should be the one for 18.06.8. Note kernel version is 4.9.214



Was convinced that package was in general ones, not sure why using the automatic was not loaded, maybe failed to get some info from opkg update but now manually worked fine.

ART backup restored and all working perfect!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.