Activate 4G roaming


You could try to add timeout your config and set to 20s

option timeout '20'


uci set network.4G.timeout=20
uci commit network

so you get some more time for registration.

1 Like

I started all over with a stable release so I can install all neccessary packages.

I installed the follwoing packages:
opkg install picocom uqmi usb-modeswitch kmod-mii kmod-usb-net kmod-usb-wdm kmod-usb-net-qmi-wwan uqmi kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan
as well as:
luci-proto-wireguard, luci-app-wireguard, luci-proto-qmi

and trying to run the internal modem now. here the output shows no lte so far:

Terminal ready
+COPS: 0

+CGDCONT: 1,"IP","internet","",0,0,0,0
+CGDCONT: 2,"IPV4V6","ims","",0,0,0,0
+CGDCONT: 3,"IPV4V6","sos","",0,0,0,1

+CGACT: 1,0
+CGACT: 2,0
+CGACT: 3,0

content of /etc/config/network:

config interface '4G'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'internet'
        option pincode 'xxxx'
        option auth 'none'
        option pdptype 'ipv4'
1 Like

I am not expert but
is a bible for this modem


AT+CPIN?   PIN status            
AT+CGREG? Network Registration Status
AT+COPS? Operator Selection
AT+CSQ Signal Quality Report
AT+CGACT? Activate or Deactivate PDP Contexts
AT+QCFG Extended Configuration Settings
AT+QSPN Query the Service Provider Name

Perhaps check roam service

Not sure why ims and sos are v4+v6
Maybe try all v6 or all v4




Also I do not use a PIN (I removed it with an Android phone)

But all these are guesses.

Finally try WIND and Voda GR and in the worst case get a local SIM.

Congratulations with your persistent searching
Good luck!

If you would like to try my version of uqmi, I can compile it for you. I just need to know what stable version of OpenWrt you are using.

1 Like

@mrhaav : just curious ... what extra functionality does your version of uqmi provide?
I run openwrt-21.02.3-ath79-generic-glinet_gl-x750-squashfs-sysupgrade.bin ... I ask because I have not enough room on my /overlay for qmi-utils and its dependencies

@Surfer2010 : it seems to me Cosmote somehow does not always want to provide good service to the SIM in the GL-X750v2. To rule out dependency on your specific German provider and SIM you could perhaps test with another European SIM of any different kind or with a local Cosmote SIM. You will have to find volunteers to borrow their SIM for a while :slight_smile: ... or you could try to get a Cosmote prepaid.
The Quectel specific forum may sure be another place to concurrently search for advice.
Good luck!

I cannot know for sure but since the multicard works just fine inside the smartphone, i doubt this would be the cause.
But tomorrow I will switch cards to check both the working one inside the router and the trouble one i side the smartphone.
I will report back on this

I don't understand what difference this would make, what can your version do different/better?
OpenWRT 21.02.03 r16554-1d4dea6d4f

I have added commands to modify the stored apn profiles in the modem, so you don´t need to use AT-command or qmicli, and I have modify the way the modem connects to the network.
If the default apn profile is incorrect I will put the modem in airplane mode and correct the apn profile.
Then I will release the airplane mode so I get a "clean" attach to the network.
I have also added a daemon that verify that the modem is not disconnected from the network. If the modem is disconnected, the daemon will re-connect and update the new IP-address to the interface.
I´m not using ping so it will not "cost" any thing.
The daemon will as well send the rrsi value to an external script to trigger your signal strenght LEDs and notify if you receive any SMS.

1 Like

[...] since the multicard works just fine inside the smartphone [...]

Agreed, but it is not only the SIM, it is the combination SIM provider hardware software and perhaps versions or aspects such as protocol negotiation and possible bugs or shortcomings.
Switching two identical multicard SIMs may not necessarily provide any new information. I am more interested in trying another SIM.
fwiw: I have multiple equivalent SIMs from same provider and have once, abroad, experienced one SIM to work in a phone but another one not in a MiFi 4G hotspot.

New day, new luck ...

I did some testing again, this looks better now doesn't it?

root@OpenWrt:~# picocom -b 115200 -r -l /dev/ttyUSB3
picocom v3.1

port is        : /dev/ttyUSB3
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : yes
hangup is      : no
nolock is      : yes
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        :
omap is        :
emap is        : crcrlf,delbs,
logfile is     : none
initstring     : none
exit_after is  : not set
exit is        : no

!! Settings mismatch !! Type [C-a] [C-v] to see actual port settings
Type [C-a] [C-h] to see available commands
Terminal ready
+COPS: 0,0,"COSMOTE 1&1",7

+QSPN: "COSMOTE","COSMOTE","1&1",0,"20201"

+CGDCONT: 1,"IPV4V6","","",0,0,0,0
+CGDCONT: 2,"IPV4V6","ims","",0,0,0,0
+CGDCONT: 3,"IPV4V6","sos","",0,0,0,1

+CGACT: 1,1
+CGACT: 2,0
+CGACT: 3,0


+CGREG: 0,5


and here the uqmi command results:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-serving-system
        "registration": "registered",
        "plmn_mcc": 202,
        "plmn_mnc": 1,
        "plmn_description": "\u0016\u0001",
        "roaming": true
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "lte",
        "rssi": -67,
        "rsrq": -8,
        "rsrp": -94,
        "snr": 124
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
"Out of call"
1 Like

wow ... good progress ...

Not sure why current settings shows "Out of call"

Does ifconfig wwan0 show an IPv4 address? And perhaps also an IPv6 address?

I have compile with openwrt-sdk-21.02.3-ath79-generic_gcc-8.4.0_musl.Linux-x86_64.
It´s available for download at:


and install with:

opkg install uqmi_2022-04-22-0.5_mips_24kc.ipk
1 Like

I guess this will replace existing uqmi or will both live together?

Thanks for your work. You should perhaps attempt to pull your work upstream. :slight_smile:

Yes, it will replace the existing uqmi.
You can always go back to official uqmi with --force-downgrade.

1 Like

Here are a few EU 4G roaming hints that helped me

  1. use APN config of your country provider in LUCI
    i.e.: not some APN config of some provider abroad
  2. use "" as APN in modem CGDCONT
  3. use option plmn 'mccmmc' in network
    (to stick to a stable provider mcc mmc abroad
    e.g.: "option plmn '208010'" for France SFR)
  4. use some looping script to kindly ping (v4 and v6 in my case) say,
    and restart network if it fails

I could keep connection operational for days with only minor blackouts

Next time abroad (later this week) I will try hints given on Zyxel NR7101 Device Page
Disable SIM based automatic APN configuration

Deactivate MBN
set AutoSel OFF
disable VoLTE

I suppose this also will help avoid trying unwanted providers.

update disabling SIM based automatic APN configuration works fine in own country with own provider but abroad it may require to use option plmn 'mccmmc' in network config. In other words: one then may need to manually select the wanted provider mcc & mmc abroad.