Activate 4G roaming

I have an GL-X750v2 (c6-e) Router (4g modem).
In Germany it works fine, i set it up so once disconnected it will reboot and all fine.

Now i moved it to Greece and wifi works but no internet/4g working.
Connectivity/coverage is fine, roaming is activated on the simcard in general

How do i activate it on the openwrt setting/conf?

Thanks.for your help

Check How to enable 3G roaming? - #3 by laurentppol

Try not setting an APN, that should use the default APN stored in the SIM card.

Also test the SIM in another device in the same location to be sure that the network works. Confirm the band being used locally is supported and enabled in the modem.

1 Like

Do you mean GL-X750v2 ? I have (older) GL-X750

I access AT commands with

# picocom -b 115200 -r -l /dev/ttyUSB2

+QCFG: "roamservice",2

to set it this way I did


Last time I traveled I could get IPv4 but, unlike my phone, not IPv6.
I travel again in June and will try again both IPv4 and IPv6.
(IPv4 and IPv6 work for my provider my country)


You can scan for available networks with:

uqmi -d /dev/cdc-wdm0  --network-scan

Thanks for all the help.
Where do i type the
uqmi command
Or picocom and at commands?
Ssh into it?

ssh indeed and you may have to install uqmi and picocom (for AT modem terminal access) with opkg

Install is hard to do with no Internet connection :frowning:

share internet via wifi from your phone, join the network from your router.


DL the package(s) to your computer, then transfer them to the router, and install.

1 Like

Or, if, by any chance, you can have access to a wired LAN with internet connection elsewhere, then, you can use and configure the GL-X750v2 WAN ethernet port to connect to that LAN and access the Internet.
This is how I do it when upgrading my (older) GL-X750 because some 4G specific driver needs to be downloaded, and, that temporarily poses similar chicken and egg problem: no internet connection to download the required packages

1 Like

Don't you have uqmi all ready installed?

1 Like

For a box with mobile radio that looks reasonable indeed :-). In the notes I made for first install (few years ago) uqmi was not part of the image. Perhaps today it is. In any case, it was certainly a suggested package for such 4G/LTE box and OP mentions the device works in Germany. Then chances are big @Surfer2010 installed it already indeed ...

trying to do this, but which is the modem?

How do i find what /dev/ttyUSB2 the INTERNAL modem of the GL-X750v2 is?

result of this scan:


It looks like you are connected to COSMOTE, PLMN: 20201.

         "mcc": 202,
         "mnc": 1,
         "description": "COSMOTE",
         "status": [

Can you run print this?

uqmi -d /dev/cdc-wdm0 --get-serving-system
uqmi -d /dev/cdc-wdm0 --get-signal-info
uqmi -d /dev/cdc-wdm0 --get-current-settings

there may be a few /dev/ttyUSBN which one is the modem, perhaps try. In my case (GL-MIFI and GL-X750) N=2

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-serving-system
        "registration": "registered",
        "plmn_mcc": 202,
        "plmn_mnc": 1,
        "plmn_description": "\u0016\u0001",
        "roaming": true
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "lte",
        "rssi": -60,
        "rsrq": -10,
        "rsrp": -91,
        "snr": 5.200000
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
"Out of call"
1 Like
Bus 001 Device 004: ID 2c7c:0306 Quectel EP06-E
Bus 001 Device 003: ID 05e3:0752 Generic USB Storage
Bus 001 Device 002: ID 05e3:0618  USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.104 ehci_hcd EHCI Host Controller
root@OpenWrt:~# dmesg | grep tty
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.348655] printk: console [ttyS0] disabled
[    0.353299] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.362402] printk: console [ttyS0] enabled
root@OpenWrt:~# picocom -b 115200 -r -l /dev/ttyS0

root@OpenWrt:~# picocom -b 115200 -r -l /dev/ttyS0
picocom v3.1

port is        : /dev/ttyS0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : yes
hangup is      : no
nolock is      : yes
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        :
omap is        :
emap is        : crcrlf,delbs,
logfile is     : none
initstring     : none
exit_after is  : not set
exit is        : no

Type [C-a] [C-h] to see available commands
Terminal ready

Can you try this first and print the result:

uqmi -d /dev/cdc-wdm0 --start-network --apn internet

if you don´t get a negativ number try this:

uqmi -d /dev/cdc-wdm0 --start-network --profile 1

Seems roaming to COSMOTE 202 1 is true ... not_forbidden looks good, not sure what not_preferred means.

If you put the SIM in a smartphone. Does it work? And, if so, using which provider?


If your phone then searches for any network APN. Maybe another one (also) works?

I experienced years ago European roaming went flawless, but it seems, meanwhile, more and more providers have silent deals to prefer or forbid other ones abroad, and sometimes they only offer restricted service (say 4G not 4G+ or IPv4 not IPv6). I suppose this is not legal but it is.

Whichever providers have strong signal where you are, hopefully allow you to roam.

When you are in AT command can you show output of