Acme (2.8.5/2.8.6) not working with dns_cf

Is anyone using acme either from the acme package (2.8.5) or directly from github (2.8.6) with dns_cf?

Just upgraded to 19.07.3 and struggling with getting acme to add the relevant TXT record to Cloudflare. Tried with the same global API key I've been using before and tried with the API Token -- can't get it to work either way.

Tested with doing CF_Token and CF_Account_ID exports on command line and then running /usr/lib/acme/ --issue --dns dns_cf -d ${HOST}.${DOMAIN} --debug 2 --test.

I get the Error add txt for domain:_acme-challenge.HOST.DOMAIN.

I have a script which requests certificates and it worked just fine for a while, broke with the 2.8.x update I guess.

Double-checked the global key/token, tried rolling them and updating values in OpenWrt -- same result.

Not sure what the issue was, I've rebuilt my custom 19.07.3-based image yesterday and flashed it and certificate issue worked as expected.

I've had problems restarting uhttpd tho, it wouldn't properly start with the new certs until the new uhttpd.defaults section was removed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.