Accidently flashed the Linux kernel with minimal file system

While upgrading my Xiaomi Mi Router AC2100 to a new 21.02 version, I’ve accidently flashed (from the Luci web UI) the Linux kernel with minimal file system from OpenWrt Firmware Selector (

How do I get an OpenWrt Luci web interface firmware image back in the router again, can anyone please help ?

Thank you so much!

I'm no expert but I guess you have to enter failsafe-mode and configure the client mode (sta) through cli. To enter failsafe mode you have to press the reset as soon as the power led blinks (after a fresh boot) and release when it blinks faster. You need to set your computer ip address to <>, your net mask to <> and your gateway to <>, unplug your ethernet cable and connect with the new settings. You'll need to ssh (cli) into the terminal (powershell admin mode if you're in windows), input mount_root, enter.. passwd to input a new password ... then modify your settings in /etc/config to get internet connectivity. Openwrt has lots of helpful guides. Here's one to start with

Why would you need admin mode?

I guess I haven't tried without it before... so dunno, :sweat_smile: I'm on manjaro so I'm used to sudoing for most things.

Hello and thank you for your answer!

Unfortunately, the router enters rescue mode but I can't reach the device through ssh with root credentials (it times out). I've tried pinging the gateway but I can't reach it.

Just an additional info, when I power on the router normally (without holding reset to make it go into rescue mode) the power light remains stagnant with yellow colour, it never blinks.

Any ideas on how to get out of this are more than welcome!!!

Thank you guys!

power cycle the router and as soon as the POWER LED starts blinking (slowly) keep the reset button pressed down until you see the same POWER LED start blinking rapidly. That's when you know you're in fail-safe mode. Once there, setup your lan port with <> for ip address, netmask <> and gateway <>. Unplug the ethernet cable and connect it to LAN1. It should allow you to ssh into it afterwards. At least that's what I have been doing with all of my devices so far.

If you let the initramfs image boot normally, it will start up with default settings every time, because it starts a fresh copy in RAM every time never retrieving any settings from flash. You should be able to DHCP an IP from it and connect to If the LED does something other than blink fast, then slow, then come on steady, or if you can't DHCP an IP, the router is bricked too badly to consider OpenWrt recovery mode.

Never run your ssh client as root, that is a security risk to your PC. Tell it you want to log in as root on the server with ssh root@ or ssh -l root This does not require root privileges on the client machine.

Hello Francisco, and thank you for your answer!

Sorry for the delay in getting back and answering but I didn't have the time to try to recover the router.

Unfortunately the recovery process you mentioned wasn't enough to recover the router. I tried preaty much everything even flashing the original firmware through tftp in recovery mode from my mac (both with and and nothing.

Eventually, installed xiaomi recovery tool in a VM in bridge mode with the Ethernet adapter in my mac. After enabling the communication from the tool to the router in the Windows firewall of the VM it finally went through. Successfully flashed the original xiaomi firmware into the router.

Now I will go back to install openwrt :slight_smile:

Thank you!

Hi Mike, thank you for your answer!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.