Accidentally I disabled ubus. Now I can't connect to device. Reset button doesn't work. Can I recover router without UART?

Hi, I'm using openwrt 12.09 on HG553 router.
Accidentally I disabled ubus daemon in luci ui.
After that I can't connect to router. Wifi - works but any interface not. I can connect to wifi but no network. I launched openwrt on virtualbox to test what happens in such case - all network interfaces are just down. I can check it through the console on virtualbox.
What to do in such case? I can see the only the failsafe mode UDP packet from router ethernet interface. Led is not blinking, just on.
I tried to press reset button many times. After power on, after led is on, after UDP packet. Router network is not up. Not responding on ARP requests. Not sending anything, except one UDP packet.
Can I get router back without connecting UART?

1 Like

If you have button and you can even see the failsafe UDP packet, you should be able to enter the failsafe mode.

You just need to push the button inside a two-second window during boot. (Right aftr you see the UDP packet). In practice you may need to repeatedly push the button during boot...

Failsafe kicks in before any changes to the config, so your ubus changes never get evaluated.

3 Likes

I don't think 12.09 (yes, 12.09!) has failsafe.

Allowing OpenWrt to boot up completely then holding down the button for at least 5 seconds then releasing it should initiate a reset to defaults.

That may be something that depends on ubus though. Almost everything depends on ubus.

Failsafe has been there before 12.09 and exists in 12.09, too, as seen from the preinit scripts of 12.09:

AA 12.09:
https://git.openwrt.org/?p=openwrt/svn-archive/openwrt.git;a=tree;f=package/base-files/files/lib/preinit;h=ac19cf53c77b8a5b4fb400af0ab84f6073f9d71d;hb=506ec5f7f4b92fea9cee93ad576f8e760034b91b

Backfire 10.03:1:
https://git.openwrt.org/?p=openwrt/svn-archive/openwrt.git;a=tree;f=package/base-files/files/lib/preinit;h=01bb5a029d9d055fe4eba522803c5d0527080abb;hb=refs/heads/backfire_10.03.1

But as HG553 is apparently a Broadcom device, I am not sure of the failsafe support for it. (Failsafe was there for many targets like ar71xx, but maybe not for all targets. Failsafe was generalized in 2010, but I have no knowledge about Broadcom specific stuff.)

1 Like

Doesn't work anything. Device is booting and even wifi is on. But all interfaces are down. I can't reset it or do failsafe. Will wait for UART dongle.
The device have 2 buttons - one for reset, another for wifi. I tried both, no effect.

Got UART. Connected it and enabled ubus through serial console. Everything works fine now.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.