Accessing LuCI after configuring as dumb AP

I followed the user guide instructions to use LuCI to configure it as a dumb AP. It works fine, but now I want to tweak some of the wifi settings, but how can I access LuCI now?

Use the address you set for the lan interface.

Thanks for the quick reply. I tried that but it just times out when I try to go to that IP. (I tried it while connected to the dumb AP's wifi network.)

What ip did you set? What is the address of your main router?

The main router is 192.168.86.1. The dumb AP is 192.168.86.2.

then that's the IP you should use.

you can always do a reset.

Have you tried connecting your computer to one of the LAN interfaces of the router with a cable and setting your IP address manually to something near the dumb AP?
Something like 192.168.86.5 (on Windows this can be done by opening a terminal window (wt) as Administrator and entering netsh interface ipv4 "Ethernet" set address static 192.168.86.5 255.255.255.0 192.168.86.2 reverting this back is done with netsh interface ipv4 "Ethernet" set address source=dhcp)

Joost

I tried connecting with a static IP of 192.168.86.5 on one of the LAN interfaces and it still didn't work.

I actually configured it twice, the last time I had to enter failsafe mode and do "firstboot && reboot" and reconfigure it. Both times I lost access to LuCI once it was a dumb AP. It really seems like this is just what happens when you follow the LuCI dumb AP instructions. I did see one other tutorial that mentions disabling the firewall through the command line, so maybe that is necessary as a step to be able to access it?

No, you should not need to disable the firewall. You can leave it as is.

You might want to reset again, then run through the guide step-by-step. Show us your config before you restart your router.

What is the best way to show you the config?

I think I just followed the online guide, I did it twice and got the same result. I think it would be easy for someone else to also reproduce the same issue by following the LuCI dumb AP instructions.

Possibly related, I was hoping to find a way to make the dumb AP's LuCI interface also be accessible from elsewhere on the network (even when not connected directly to it), but I wasn't able to find clear instructions on how to do that.

As far as I am aware, the dumb AP guide is accurate. But we can see if there is anything missing or incorrect.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I noticed that the command line version of the instructions have disabling the firewall as one of the steps, and the LuCI instructions have disabling the firewall as an option, so I did another "firstboot", and did the same steps again. But this time I disabled the firewall first before applying the interface changes, and that made it work!

So following the LuCI instructions (at least on my Archer A7) results in a device that is no longer accessible (either by LuCI or SSH). But disabling the firewall first before applying the other changes keeps it accessible.

This absolutely should not be required, but I'm glad it worked for you. I suspect there is something else going on, though...

which guides were you looking at?

Yeah, I don't know why. I followed the "Configuration via LuCI" instructions on https://openwrt.org/docs/guide-user/network/wifi/dumbap. It was just starting with a fresh current version OpenWRT installed on an Archer A7, and then I just followed those steps.

Yikes! It looks like the command line options for "Step 1: Modify the network" are just plain wrong! I don't have time to edit this, but in OpenWrt 21.02 and later, a bridge must always be defined outside the network interface stanza -- doing it within an interface will break it!

I'd like to see what your configuration looks like -- this way I can see if there are any remaining errors that were implemented as a function of following that guide. The specifics for this request are a few posts up.

There is a paragraph about 21.02 and later:
https://openwrt.org/docs/guide-user/network/wifi/dumbap#switch_and_dedicated_wan_devices_post_2101

Maybe just remove the part before as that can be confusing indeed?

About disabling the firewall, not sure if we should still give that advice at all, most is layer two traffic and the firewall is not involved so the impact is minimal.

But disabling can break things and although there is a warning people tend to not always read carefully:

do not do the next steps regarding turning off services labeled firewall, dnsmasq and odhcpd because your GUEST network will need these.

I have just tested my Xiaomi 4C + v23.05.3 offical fw, after setup dumb-AP followed the instuctions.
I got luci access on both LAN port and Wifi to the 192.168.1.2, no problem and no need to turn off firewall / dnsmasq / odhcpd.

If I connect the WAN port to main-router by cable, the luci access will not work (pc cannot get an IP from main-router), I have to connect one LAN port to the main-router by cable.

To enable the WAN port, I should be config the br-lan included "wan" port.

yes, or skip the wan port for now.

after the 3 ticks, save and apply, enabled WAN as same as LAN ports.

My /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'               <------
	list ports 'eth0.1'             <------
	list ports 'eth0.2'             <------

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.2'     <------
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'    <------
	list dns '192.168.1.1'          <------

config device
	option name 'eth0.2'
	option macaddr '11:22:33:44:55:66'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 2 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'