Accessing coda modem from lan

Hi, i've found the wiki here: https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat
and found the reddit thread referencing it here: https://www.reddit.com/r/HomeNetworking/comments/16lmxj9/hitron_coda_56_login/

i've followed the instructions and no joy. i've reverted and tried twice, same results.
the modem is the coda, not the coda56. i did access the coda UI but only before it had served an IP to the modem ( |Hostname|OpenWrt|
|Model|Ubiquiti EdgeRouter X|
|Architecture|MediaTek MT7621 ver:1 eco:3|
|Target Platform|ramips/mt7621|
|Firmware Version|OpenWrt 23.05.0 r23497-6637af95aa / LuCI openwrt-23.05 branch git-23.236.53405-fc638c8|).

once the modem has served an IP address i ran into the issue others did. i tried DHCP using the second modem port and noticed the modem did serve a second IP address, but that didn't allow access either. any ideas what could be going on with this modem variant? it's important to be able to see how the modem is connected when it's connected.
thanks,
jeff

I contacted Hitron America support. They say a new fw has been delivered to xfinity for internal testing that allows accessing the gui from an ip address on the lan. It also should allow connections over WiFi on the lan.
Fingers crossed on a timely rollout.

With the old firmware you could look at running a https proxy server on the router, which would re-originate the https connection from the lan to have a 192.168.100.0 source IP and a fresh TTL.

1 Like

thank you. i'll look into that.