Access point temporarily full

I had a strange behavior and saw "Access point temporarily full" on my phone. Is this the access point, where the phone is connected, which is full? Hard to believe, that it is really full.

How many devices / phones can be used with 1 openwrt access point?

Not sure, but I thinks there were less than 10 devices connected.

The AP is part of a wds-system. After a reboot of all possible routers everything worked again.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
1 Like

It varies by the WiFi driver. Typical limit is 16, 32 or something...
Example:

Based on search, the error might also be due to DHCP address pool exhaustion.

1 Like
root@C7v5-S1:~# ubus call system board
{
	"kernel": "5.15.137",
	"hostname": "C7v5-S1",
	"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
	"model": "TP-Link Archer C7 v5",
	"board_name": "tplink,archer-c7-v5",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.2",
		"revision": "r23630-842932a63d",
		"target": "ath79/generic",
		"description": "OpenWrt 23.05.2 r23630-842932a63d"
	}
}
root@C7v5-S1:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd08:8224:9470::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.178.59'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.178.1'
	list dns '192.168.178.1'

config device
	option name 'eth0.2'
	option macaddr '0c:....:13'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'
root@C7v5-S1:~# cat /etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Bed-5-mix'
	option encryption 'sae-mixed'
	option key '....'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '11'
	option band '2g'
	option htmode 'HT20'
	option country 'AT'
	option cell_density '0'
	option txpower '5'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Bed-4-psk2'
	option encryption 'psk2'
	option key '....'
	
config wifi-iface 'wpa3_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Bed-4-sae'
	option encryption 'sae'
	option key '....'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option ssid 'mainrouter'
	option encryption 'sae-mixed'
	option key '....'
	option mode 'sta'
	option bssid 'CC:....:CA'
	option wds '1'
	option network 'lan'
root@C7v5-S1:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

It was for sure less than 16, except connection were kept, when phones were shut down. Driver is ath79/generic

Maybe, my Fritzbox without Openwrt shows again and again devices which do not exist as active. In the meantime I have stopped using random MAC-addresses with phones, but they come and go, this changes within hours. The Fritzbox showed about 20-30 devices, so not too much IMHO. No idead, what else uses random MAC adresses like phones.

No obvious issues with the AP.

How large is the dhcp pool on the main router ? Does that device have the ability to display the remaining available leases? (Not connected devices, but actual pool availability)?

1 Like

That is the CPU architecture family, not WiFi driver.
For most ath79 devices, the WiFi driver is ath9k.

1 Like

You mean the router, which is responsible for dhcp? It is a Fritzbox 6890. At the moment there are 22 devices active. So I am guessing, it was below 30 devices, which where active. About 15 devices are inactive, some with no IP-address, probably with random MAC and I don't know from where they come.

https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c7_v5 says ath9k and ath10k.

I am using OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256

You showed us the config from the AP; however, if this is an issue with the DHCP server, we need to see the config on the main router.

Sorry the DHCP-server runs on a FRITZ!Box 6890 LTE with FRITZ!OS 7.57.

How can I find out, if the router uses ath9k or 10k?

After a reboot everyhting works again. I only would like to know how many connections are possible at the same time to the AP.

Does the main router have configuration options that you can show us? Specifically, somewhere there should be some settings for the dhcp server (unless that is hidden from view such that it is unavailable to users).

It sounds like the problem is indeed the main router - we can’t help you with that, except to suggest that you use your openwrt device in router mode instead of dumb AP mode.

Your network sounds weird. (Lots of devices, some them unknown...)

It you have lots of temporary clients, some with random MAC, you can exhaust DHCP pool as the same device might reserve a new IP address at each connection.
You might at least shorten the DHCP lease time, so that addresses get released quicker. (OpenWrt default is 12 hours, not sure abou Fritzbox. You might shorten that to 3 hours or so.)

Ath10k-ct limit is 32, unless you toggle the special parameters linked in my message.
You might be quite near that limit.
Might be more likely than the DHCP exhaustion speculation.

I fear I can make screenshots only, but there is a manual:

Yes there is a setting for lease time, it was set to 10 days and I changed it to 2 days, but I fear it doesn't influence the time until devices disappear. AFAIK the condition is, that all available IP-addresses must be used.

The 2nd setting, is the range for DHCP.

Please note, I am far away to use all possible IP addresses.

Very difficult to realize, at least for me. The Fritzbox has 3 Openwrt-devices connected via Ethernet, but all in the same network.

There is 1 printer connected to the Fritzbox via Wifi, the other connections are to the 3 openwrt route via Ethernetr. It can happen that an openwrt router is offline for a while. The easiest way at the moment is to uses DHCP with the Fritzbox and Openwrt doesn't use DHCP.

At the moment I don't use VLAN, but it is planned.

Not sure if I have somthing misconfigured, but I think the FritzOS is a little bit buggy.

You see 2 devices, the 1st, an openwrt-router, shows an IPv4-address. It was always inactive until I changed the IP. With the new IP the Fritzbox shows it active. Same with another openwrt-router, which is not on the image.

I checked again and the 2nd without an IPv4 can be queried, it is from Espressif. It is in the Fritzbox guest net, normally the IPv4 addresses of the guest net are shown and have a special symbol. That is new now.

One of the devices without IPv4 is an openwrt router. I can use this router where the IP is not shown without any problems, Wifi works fine.

No problem, if I know now that the only devices without IP are from the guest net. Another device in the guest net is a washing machine, so strange, because I saw these devices very often in the Fritzbox devices list.

Now random MAC is disabled.

If you use random MAC with phones you get another IP with every SSID. Checked it, changed the SSID and looked for the IP, back to the old SSID there was the old IP again.

Unsure, if this is a good time in my situation, I want to have the same IP with every device. I am trying 2 days now. Note I don't use random MAC anymore, so I should have enough local IP addresses.

The other thing is, that the Fritzbox releases a device only, when there are no free IP addresses anymore. I have now hundreds of free IP addresses.

Please note, I have a lot of access points.

These 20-30 devices are not connected to this 1 AP, where I had problems. I am pretty sure, that there were below 16 devicesto this AP connected. Another openwrt-AP worked fine at this time.

The manual suggests that the DHCP range is 192.168.178.20-200 -- is that consistent with what you have? 181 addresses in the pool should be sufficient for most home networks, even with randomized MAC addresses on the client devices.

No, I kave 30-240

Openwrt starts now from 11-23 including placeholders.

20 devices active at the moment. Ok, assume it have been 10-20 more when the problem occured.

Well, 111 IPs in the pool should also be enough in most homes.

I tested with random MAC. not knowing what this means for IPs. But when I say about 10 phones with 4 SSID, it are 40 IPs, it should be also enough. So no idea why it became full.