Access point multiple routes

Hello community,

I've been playing around with the idea of a "centralized AP" and wondering if that's even possible (given the hardware supports spawning enough Wi-Fi networks).
The idea is quite simple:
Use a router as "dump" AP, but for multiple SSIDs - Ok what do I mean with that?
I have two separate routers (which I can't replace for various reasons) and it would be neat to have only a single access point for Wi-Fi devices, which will route the traffic to the corresponding router, which will then take care of the proper routing further itself (be it outside (to the internet) or inside (to another subnet/VPN) or whatever).

As example:
2,4GHz + 5GHz SSID: Office -> Route traffic to office router
2,4GHz + 5GHz SSID: Home -> Route traffic to home router

I've a TP-Link Archer C7 v5 here and would like to realize it like that.
I would just go ahead and configure it as "dumb AP" and plug in LAN 1 the office router LAN and in LAN 2 the home router LAN.

Is this a possible scenario?

I'd appreciate any advice - thanks alot!

Cheers,
Steffen

Yes, that's possible. Just make a VLAN for each network, and then create/add the SSIDs to the appropriate Interface/VLAN.

2 Likes

Hello lleachii,

thanks for your answer.
When it comes to VLAN I am a total noob and this really goes over my head.
I have a couple of questions regarding this and someone might be able to answer this:

  • If I start applying VLAN tagging I guess I have to apply the tagging on all routers and switches. Is that correct?
  • From what I understood from a quick research I only need to apply the tagging on the switches and routers, so the "end-devices" are not concerned with this, correct?
  • I do have (luckily) only managed switches, which are capable of VLAN tagging - going forward with VLAN tagging I assume I cannot integrate "dumb" switches anymore, correct?
  • I do have a pppoe-pass through on my modem (DrayTek Vigor 165), so I do the pppoe-dial-in via my router, but the modem applies VLAN tag 7 (for Deutsche Telekom) on the way out. Do I need to change the behaviour, so that I do the VLAN tagging on the router?
  • My assumption was I can plug in direct connections from the access point to both routers via separate LAN cables and both routers are not connected to each other directly. Why do I need VLAN tagging? As those are separate cables - I assume because the traffic on the access point comes in on a single interface and can it only be distinguished which route to take based on the VLAN tag applied, is that correct?

I attached a PNG (unfortunatly I couldn't attach a PDF or similar) with my network plan (I am doing such a plan the first time, so please bear with me! :))

Thanks beforehand for any advice!

Cheers,
Steffen

No.

No.

No.

No.

You can.

You don't, you just need to define another VLAN in the OpenWrt if your AP can physically connect to both networks. Your ports can be untagged, hence no tagging or trunking. I think you're trying to make things too complex. See the graphic on the web GUI at Network > Switch for an easy guide.

Also, per the Community Guidelines, please refrain from signing your posts.

Thanks for your answers, I have a follow up question to the answer of you on one of my questions:

From what I understood from a quick research I only need to apply the tagging on the switches and routers, so the "end-devices" are not concerned with this, correct?

No.

If I interpret your answer correctly, tagging needs to be applied also for the "end-devices"? Seems a bit cumbersome.


Okay, I don't get it.
I just took a look at https://openwrt.org/docs/guide-user/network/vlan/switch_configuration to understand, the concept of VLANs in OpenWrt.

There it says within the section VLAN explained with default scenario of most OpenWrt routers

  • Tagged on “CPU (eth0)” means that the two VLAN ID tags used in this example (1, 2) are sent to the router CPU “as tagged data”. Remember: you can only send Tagged data to VLAN-aware devices configured to deal with it properly.
  • Untagged means that on these ports the switch will accept only the incoming traffic without any VLAN IDs (i.e. normal ethernet traffic). The switch will remove VLAN IDs on outgoing data in such ports. Each port can only be assigned as “untagged” to exactly one VLAN ID.

What I get from the text is "if you do tagging, make sure your network hardware is capable to do it". Or is it only meant for the router itself and doesn't concern any other network hardware at all?

So I read further down and there are what is called "software VLANs" (section: Creating driver-level VLANs).

I am a bit confused right now. Is there any difference between those things? What do I need to apply?

Your ports can be untagged, hence no tagging or trunking.
So there is a difference between a VLAN and VLAN tagging or trunking?

Sorry for the questions, that might seem straight forward for you (or any other experienced network engineer), but as said, I am really new to VLANs (or "complex" networking in general).

Really appreciate your help!

No tagging on end devices. I understand that you have 2 free ports on your AP, just declare each one untagged on their own VLAN. THIS VLAN ONLY NEEDS TO EXIST ON THE OpenWrt AP. Simple.

:confused:

Basically...but both understandings are slightly wrong. In most OpenWrt devices there is a switch, that has one phy called eth0. In order to use the switch's ports, VLANs must be declared. VLAN 1 is commonly used for LAN and VLAN 2 for WAN. Cisco devices are also common for needing VLANs declared before usage in this manner.

I'm suggesting you use VLAN 1 (already existing) and create a VLAN 3. You do not have to mark the ports at tagged, as you will use 2 Ethernet cables for this setup. You DO have to mark the CPU (eth0) as tagged.

1 Like

Thank you very much for the clarification.
I think I somehow mixed VLAN and VLAN tagging and this is what got me confused.

Will try this as you adviced tomorrow - thanks again!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hello community,

this is the second time I create a topic regarding this particular scenario, as the old topic, which I refer to (https://forum.openwrt.org/t/access-point-multiple-routes/37009), has been closed already, as I haven't had time to mess around with that setup - now I'm on holidays and have plenty of time to play around :slight_smile:

Okay, first things first.
I installed and configured OpenWrt (OpenWrt SNAPSHOT r10069-33b81b5 / LuCI Master (f138fc93)) on the Linksys EA8300 (thanks @jeff once again for his nice work) and configured it as "dump ap" using this guide.
At this point I am able to connect via Wi-Fi and behave like I am directly connected to the router - everything works as it should.
Following the information of my configuration for network and wireless:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda0:6d9e:9136::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth1'
        option proto 'dhcp'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'
root@OpenWrt:~# 
root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel 'auto'
        option legacy_rates '1'
        option country 'DE'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '5ghz_1'
        option encryption 'psk2'
        option key 'REMOVED'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT20'
        option legacy_rates '1'
        option country 'DE'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '2_4ghz'
        option encryption 'psk'
        option key 'REMOVED'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'
        option country 'GB'
        option legacy_rates '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid '5ghz_2'
        option encryption 'psk2'
        option key 'REMOVED'

root@OpenWrt:~# 
root@OpenWrt:~# ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 30:23:03:6e:1a:52 brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 30:23:03:6e:1a:53 brd ff:ff:ff:ff:ff:ff
10: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 30:23:03:6e:1a:52 brd ff:ff:ff:ff:ff:ff
    inet 10.10.40.3/24 brd 10.10.40.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fda0:6d9e:9136::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::3223:3ff:fe6e:1a52/64 scope link 
       valid_lft forever preferred_lft forever
13: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 30:23:03:6e:1a:54 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::3223:3ff:fe6e:1a54/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 30:23:03:6e:1a:55 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::3223:3ff:fe6e:1a55/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 32:23:03:6e:1a:56 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::3023:3ff:fe6e:1a56/64 scope link 
       valid_lft forever preferred_lft forever
root@OpenWrt:~#

The bridge interface "br-lan" has the IP 10.10.40.3 and is connected via LAN1 on the switch.
In LuCi this looks like that:
switch_1vlan

Now I want to assign LAN2 the IP 10.10.20.3 in a separate VLAN to be able to assign to my Wi-Fi different outgoing directions (depending on the VLAN - it is described in my initial mentioned topic a bit more detailed).

However, I am actually failing to understand how this should work at all.
When I configure the switch as @lleachii described here and plug in the LAN cable to LAN2, I lose the connnection to the access point entirely and need to do a factory reset and start all over again.
I configured the switch like so (when I took the screenshot there was no cable in LAN2, but of course I tried it with the appropriate cable plugged into it):
switch_2vlans

My goal would be to have a setup like following (sorry for the bad drawing, I just quickly drew it as a sketch to visualize the goal somewhat):
goal

Hopefully somebody can help me out here, as I am totally overchallenged with this one.

Thanks!

Topic re-opened and posting moved to here (see above).

1 Like

There is some "unique" behavior associated with the integrated switch in the IPQ40xx devices, of which the EA8300 is just one impacted.

I haven't picked this back up again, but this is perhaps worth a read:

The DSA functionality in 4.19 turned out to be something of a dead end as, at least a couple months ago, it didn't support VLANs in any reasonable way.

I've got a couple projects on my desk along with an EA8300 and will be looking at getting both the QCA-specific packet tags and the VLAN tagging to be able to support this kind of application.

The "interesting" parts of qcom-ipq4019.dtsi include

                ess-switch@c000000 {
                        compatible = "qcom,ess-switch";
                        reg = <0xc000000 0x80000>;
                        switch_access_mode = "local bus";
                        resets = <&gcc ESS_RESET>;
                        reset-names = "ess_rst";
                        clocks = <&gcc GCC_ESS_CLK>;
                        clock-names = "ess_clk";
                        switch_cpu_bmp = <0x1>;
                        switch_lan_bmp = <0x1e>;
                        switch_wan_bmp = <0x20>;
                        switch_mac_mode = <0>; /* PORT_WRAPPER_PSGMII */
                        switch_initvlas = <0x7c 0x54>;
                        status = "disabled";
                };

which associate the ports with the CPU via the switch_*_bmp values

and

                        gmac0: gmac0 {
                                local-mac-address = [00 00 00 00 00 00];
                                vlan_tag = <1 0x1f>;
                        };

                        gmac1: gmac1 {
                                local-mac-address = [00 00 00 00 00 00];
                                qcom,phy_mdio_addr = <4>;
                                qcom,poll_required = <1>;
                                qcom,forced_speed = <1000>;
                                qcom,forced_duplex = <1>;
                                vlan_tag = <2 0x20>;
                        };

which, as I recall, effectively "hard codes" the switch's VLAN tags for those ports.

Edit: The driver code itself looks to be in drivers/net/phy/ar40xx.c, though I haven't re-found where the Ethernet mapping gets consumed yet.

Edit: See also drivers/net/ethernet/qualcomm/essedma/edma.c

So if I understand you correctly, I cannot do, what @lleachii described here?

Which means basically I cannot achieve my goal - at least with this router and for now. (Please correct me if I'm wrong)

"I can't confirm or deny that" as seems to be the catch-phrase of the last couple years.

If I were to go for a "quick" approach, I'd try the LAN ports for one subnet and the WAN port for the other. Untagged to the off-board switch, then tagged from there to the rest of your infrastructure.

Yes, on my short list to resolve, as I'd like to replace my "main" Archer C7v2 with one of my EA8300s, but neck deep in driver code for SPI NAND and getting it accepted upstream (Linux) right now.

I am so sorry:
But I have to get it clarified, as I don't (really) understand it.

What do I have to tag and what not, with which VLANs (assuming I have one LAN cable in the WAN port and the other LAN cable in LAN1)?

Thank you very much!!

I think you should be able to run "SSID 1" as untagged on a LAN port on one cable and "SSID 2" as untagged on the "WAN" port.

At least as far as I understand the switch / MAC configuration, the four LAN ports are tagged by the switch internally as VLAN 1 vlan_tag = <1 0x1f>; and sent to gmac0, while the Internet port is tagged internally as VLAN 2 vlan_tag = <2 0x20>; and sent to gmac1. (The second value there is, as I recall, a bit map of the ports to which it applies).

Edit: I wish I knew all the "rules" to help you with this one -- I had one here on the bench talking over a management VLAN, but I don't enough yet as to how and why to provide more guidance as to the limitations.

2 Likes

Thank you very much!!

I got it working just like you said (untagged) - this is good enough for me at the moment. Looking forward for your fix however! :slight_smile:

Nevertheless, I think I ran into another issue with the Wi-Fi devices (specifically with the 3rd band, which serves only channels starting from 100) - sometimes it seems like the SSID is not getting broadcasted (LuCi says "Wireless is not associated" for that SSID, although it is) and I cannot find it using any wireless device (tested with a Google Pixel 2 XL and a Lenovo ThinkPad [2018 model, forgot the exact naming, sorry]).
I have a feeling it is somehow associated to "DFS" - although I have just a really basic understanding of that topic, but I thought I'd point it out and you (or someone else) gets a clue through that.

I tried a lot of different settings, but apparently it is not associated to my total number of SSIDs (I have 4), as I am able to create all of them on the other 5GHz (2 of them here) and the 2,4GHz (2 of them here) bands.
I have checked via iw list, but as far as I understand the output, I am able to bring up 16 SSIDs per band - so far more than I need.
Here is the output of it:

root@OpenWrt:~# iw list
Wiphy phy2
        max # scan SSIDs: 16
        max scan IEs length: 199 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 2:
                Capabilities: 0x19ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                VHT Capabilities (0x339959b2):
                        Max MPDU length: 11454
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5180 MHz [36] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (disabled)
                        * 5765 MHz [153] (disabled)
                        * 5785 MHz [157] (disabled)
                        * 5805 MHz [161] (disabled)
                        * 5825 MHz [165] (disabled)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)
        valid interface combinations:
                 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ SET_SCAN_DWELL ]: scan dwell setting
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
Wiphy phy1
        max # scan SSIDs: 16
        max scan IEs length: 195 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 1:
                Capabilities: 0x19ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                VHT Capabilities (0x339959b2):
                        Max MPDU length: 11454
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ SET_SCAN_DWELL ]: scan dwell setting
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
Wiphy phy0
        max # scan SSIDs: 16
        max scan IEs length: 199 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 2:
                Capabilities: 0x19ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                VHT Capabilities (0x339979b2):
                        Max MPDU length: 11454
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        TX STBC
                        SU Beamformer
                        SU Beamformee
                        MU Beamformer
                        MU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5180 MHz [36] (disabled)
                        * 5200 MHz [40] (disabled)
                        * 5220 MHz [44] (disabled)
                        * 5240 MHz [48] (disabled)
                        * 5260 MHz [52] (disabled)
                        * 5280 MHz [56] (disabled)
                        * 5300 MHz [60] (disabled)
                        * 5320 MHz [64] (disabled)
                        * 5500 MHz [100] (26.0 dBm) (radar detection)
                        * 5520 MHz [104] (26.0 dBm) (radar detection)
                        * 5540 MHz [108] (26.0 dBm) (radar detection)
                        * 5560 MHz [112] (26.0 dBm) (radar detection)
                        * 5580 MHz [116] (26.0 dBm) (radar detection)
                        * 5600 MHz [120] (26.0 dBm) (radar detection)
                        * 5620 MHz [124] (26.0 dBm) (radar detection)
                        * 5640 MHz [128] (26.0 dBm) (radar detection)
                        * 5660 MHz [132] (26.0 dBm) (radar detection)
                        * 5680 MHz [136] (26.0 dBm) (radar detection)
                        * 5700 MHz [140] (26.0 dBm) (radar detection)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (13.0 dBm)
                        * 5765 MHz [153] (13.0 dBm)
                        * 5785 MHz [157] (13.0 dBm)
                        * 5805 MHz [161] (13.0 dBm)
                        * 5825 MHz [165] (13.0 dBm)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)
        valid interface combinations:
                 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ SET_SCAN_DWELL ]: scan dwell setting
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
root@OpenWrt:~# 

Also following the output of /etc/config/network:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda0:6d9e:9136::/48'

config interface 'home'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'
        option ip6assign '60'
        option delegate '0'

config interface 'office'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'dhcp'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

root@OpenWrt:~# 

And the output of /etc/config/wireless (with the current non-working settings for band3 (channel >= 100):

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'DE'
        option channel 'auto'
        option legacy_rates '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT20'
        option legacy_rates '1'
        option country 'DE'
        option txpower '20'
        option channel '6'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'
        option legacy_rates '1'
        option txpower '20'
        option channel '36'
        option country 'DE'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'Toadette'
        option encryption 'psk2'
        option key 'REMOVED'
        option network 'office'

config wifi-iface
        option device 'radio2'
        option mode 'ap'
        option network 'home'
        option encryption 'psk2'
        option key 'REMOVED'
        option ssid 'Yoshi'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'Kirby'
        option network 'home'
        option encryption 'psk2'
        option key 'REMOVED'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'Peach'
        option network 'office'
        option encryption 'psk2'
        option key 'REMOVED'

config wifi-iface
        option device 'radio2'
        option mode 'ap'
        option ssid 'Peach'
        option network 'office'
        option encryption 'psk2'
        option key 'REMOVED'

Please note, I added the second SSID Peach twice (for testing purposes only). I am only interested in bringing Peach up on the "3rd band".

BTW: Should I open another thread for this issue, or can we discuss it here?

Thank you very much!

Small note:
The EA8300 has definitely better Wi-Fi than my WRT3200ACMs (range wise), with still reasonable throughput (~300MBit on the 5GHz band) on mid range (~10-15m with two walls across) - I am super happy with that.

Third band?

This sounds like the DFS radar detector, it should not be used for WiFi setups.

It's a Tri-Band router - my understanding was I can actually use the third band.

Quote from Linksys page:

TRI-BAND TECHNOLOGY
Three bands that deliver the fastest combined Wi-Fi speeds to more devices.

Is my understanding wrong?

Interesting...I believe I stand corrected (regarding your specific device). I see this is a Linksys-based feature (and designed to provide channels in the DFS range).

  • Are you saying that you cannot configure channels greater than >=100 on your 3rd band?