Access Point in Metal Shed

I have a 12' X 24' aluminum shed for my workshop / man cave, I darn near live in it. I have wired internet that comes into the shop and goes to a WRT3200ACM running OpenWRT configured as a WAP which I have located as close to dead center as I could. My RECEPTION is excellent, I can put my phone with a WiFi scanner app in every corner, nook, and cranny inside and get max signal. Outside, not so good, but that's not what this is about. My SPEED inside is horrible!
I recognize I'm sitting inside a big Faraday cage which is why the signal does not get out. And I considered that perhaps the (grounded) aluminum walls were reflecting the signal leading to loads of self-interference. I've Googled this extensively, and all I can find is lots of articles explaining to non-engineers why you can't get a signal INTO your shed from outside. Every article of course sez that metal blocks the WiFi, a few though say that it absorbs it (not reflects)(which is how I understood it anyway).
So do I have a reflective interference problem, or do I need to keep looking elsewhere? I've already done a bunch of troubleshooting and eliminated the common causes.

Reflected signals can be very nasty, normally I'd suggest to try reducing tx power to the (reasonable-) possible minimum - but mvebu/ mwlwifi is afaik hardcoded to use full strength in hardware. If you can borrow some non-mwlwifi hardware (doesn't need to be OpenWrt, many OEM firmware allow reducing tx power in coarse steps) for an afternoon, it would make sense to test exactly that - putting the tx power down as much as possible and checking how the system as a whole behaves then.

1 Like

If you can change the WiFi power output, it can be done through LuCi in the Network > Wireless section. There are paired sections, one with a Scan button, one with Edit. The Edit pop-up would have a Maximum Transmit Power setting in the Device Configuration, General Setup.

It's worth checking if the setting exists. Wifi doesn't transmit at full power all the time.

on WRT3200ACM it DOES transmit at full power no matter what you do.

@DoctorWizard I totally agree with @slh in terms of trying to turn down the power by using a different device. I like the gl-inet ar750 as an access point. It's limited by its 100Mbps ethernet but otherwise really cute and inexpensive. Another option would be a dumb AP like the EAP225 from TP-Link. Both of those should have adjustable power output.

I'd suggest rather than putting it dead center, where reflections will travel out, hit all walls simultaneously, and travel back to the center potentially causing a bunch of cancellation, try putting it near one corner, use that corner like a corner reflector to spread the signal throughout the rest of the room.

1 Like

I have 3 metal sheds for storage of my automobiles boats and stuff and have each one ethernetted and access pointed and have not had any issues like this. one is shed is 40x40 feet and the 2 remaining are each 40x60 feet. come to think of it my modular house is also metal sides and metal roof and i dont have a problem with wifi speeds here either so i doubt your issues are metal shed based.

Do you use WRT3200 devices? They pump out a lot of power. It would make sense to me that the reflections could cause trouble.

If I was you I would take the access point into the house and see if the problem goes away. It could be the cable going to the shed. It could be the access point itself...... a quick and easy test anyway.