Access HH5a in Modem Bridge from behind DHCP

Is it possible to access my HH5a in DSL Bridge Modem Mode (192.168.100.1) from my LAN / DHCP which is on 192.168.0.1/24? Using the same single cable that's connecting the HH5a to the Router?

I want to be able to access the modem without having to be physically wired to it. And using the existing wired connection between HH5a <-> Unifi USG. Currently, it's wired from Port 1 on HH5a to the WAN port on the USG.

Here's a diagram of my setup.

And my /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd86:ec5f:9f6f::/48'

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'dsl0.101'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr '00:XX:XX:XX:a6:f2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.100.1'

config device
	option name 'eth0.2'
	option macaddr '00:XX:XX:XX:a6:f3'

config interface 'wan'
	option mtu '1500'
	option ipv6 '0'
	option device 'dsl0.101'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 2 0 1'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 5'
	option vid '2'

Yes, should work just fine without any configuration.
Your UniFi has two IP addresses, one is the 192.168.0.1/24 you described, the other one is within the range 192.168.100.0/24 which your OpenWRT announces to its clients via DHCP.
From the UniFis perspective, the 192.168.0.0/24 range is just "the internet" which your OpenWRT belongs to.

If I try to access LUCI or ping the OpenWRT Bridge Modem at 192.168.100.1 from a client (192.168.0.11), I get no response. So something ins't quite right.

The client is receiving an IP from DHCP on the Unifi USG and connected to 192.168.0.1/24 via Wifi.

Following the HH5a Guide , the DHCP on the HH5a is completely disabled. And the IP is set to static at 192.168.100.1.

Then an internet zone is set in USG (my ISP is setup as VDSL with DHCP), and so the internet IP is showing my external IP from my ISP. From what I can see, the USG has no knowlege of the HH5a's Bridge Modem IP (192.168.100.1). Does that make sense?

If your HH5a has no DHCP running, that means you must have set an IP within the range of 192.168.100.0/24 on the WAN interface of your UniFi.
If not, here's your problem.

And if the UniFi doesn't get its WAN IP from the OpenWRT router, then you must also set the default gateway to bei 192.168.100.1 on your UniFi in order to work.
If not, here's your problem.

The easiest way would be to enable DHCP on the OpenWRT and let the WAN interface of your UniFi get its WAN configuration via DHCP.