AC9260 failed to start in '11a' hwmode

Hi all, I am running OpenWRT as a VM on my unRaid and I wanted to passthrough an Intel AC9260 as an Access-Point.

System

Linux version 5.4.124 (gcc version 8.4.0)
OpenWrt 21.02.0-rc3 r16172-2aba3e9784

Installation

I installed a clean OpenWrt 21.02.0-rc3 and install required drivers and dependencies.

opkg install iwlwifi-firmware-iwl9260 pciutils kmod-iwlwifi hostapd wpa-supplicant wireless-tools wireless-regdb iwinfo

Then, I enabled wlan with:

11g works okay

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '6'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:02.3/0000:04:00.0'
        option htmode 'VH20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

11a not okay

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '149'
        option country 'US'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:02.3/0000:04:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

On LuCi, it says the Device is not active.

Tue Jul 20 10:21:05 2021 daemon.err uhttpd[2007]: luci: accepted login on /admin/network/wireless for root from 192.168.11.2
Tue Jul 20 10:21:52 2021 daemon.notice hostapd: Remove interface 'wlan0'
Tue Jul 20 10:21:52 2021 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Tue Jul 20 10:21:52 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Jul 20 10:21:52 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Tue Jul 20 10:21:52 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Jul 20 10:21:52 2021 kern.info kernel: [  492.736358] device wlan0 left promiscuous mode
Tue Jul 20 10:21:52 2021 kern.info kernel: [  492.737032] br-lan: port 2(wlan0) entered disabled state
Tue Jul 20 10:21:52 2021 daemon.notice netifd: Network device 'wlan0' link is down
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Tue Jul 20 10:21:54 2021 kern.warn kernel: [  494.290232] ACPI: \: failed to evaluate _DSM (0x1001)
Tue Jul 20 10:21:54 2021 kern.warn kernel: [  494.292830] ACPI: \: failed to evaluate _DSM (0x1001)
Tue Jul 20 10:21:54 2021 kern.info kernel: [  494.296397] br-lan: port 2(wlan0) entered blocking state
Tue Jul 20 10:21:54 2021 kern.info kernel: [  494.297665] br-lan: port 2(wlan0) entered disabled state
Tue Jul 20 10:21:54 2021 kern.info kernel: [  494.298956] device wlan0 entered promiscuous mode
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: Frequency 5745 (primary) not allowed for AP mode, flags: 0x20053 NO-IR
Tue Jul 20 10:21:54 2021 daemon.err hostapd: Primary frequency not allowed
Tue Jul 20 10:21:54 2021 daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (149) or frequency (5745) not found from the channel list of the current mode (2) IEEE 802.11a
Tue Jul 20 10:21:54 2021 daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel
Tue Jul 20 10:21:54 2021 daemon.err hostapd: Could not select hw_mode and channel. (-3)
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->DISABLED
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Jul 20 10:21:54 2021 daemon.err hostapd: wlan0: Unable to setup interface.
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Jul 20 10:21:54 2021 kern.info kernel: [  494.300728] device wlan0 left promiscuous mode
Tue Jul 20 10:21:54 2021 kern.info kernel: [  494.301853] br-lan: port 2(wlan0) entered disabled state
Tue Jul 20 10:21:54 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Tue Jul 20 10:21:54 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Tue Jul 20 10:21:54 2021 daemon.notice netifd: radio0 (2619): Command failed: Invalid argument
Tue Jul 20 10:21:54 2021 daemon.notice netifd: radio0 (2619): Device setup failed: HOSTAPD_START_FAILED

iw reg get output

country US: DFS-FCC
	(2400 - 2472 @ 40), (N/A, 30), (N/A)
	(5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5730 - 5850 @ 80), (N/A, 30), (N/A)
	(57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0 (self-managed)
country 00: DFS-UNSET
	(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
	(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
	(2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
	(5170 - 5190 @ 160), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, PASSIVE-SCAN
	(5190 - 5210 @ 160), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, PASSIVE-SCAN
	(5210 - 5230 @ 160), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, PASSIVE-SCAN
	(5230 - 5250 @ 160), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, PASSIVE-SCAN
	(5250 - 5270 @ 160), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5270 - 5290 @ 160), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5290 - 5310 @ 160), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5310 - 5330 @ 160), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5490 - 5510 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5510 - 5530 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5530 - 5550 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5550 - 5570 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5570 - 5590 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5590 - 5610 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5610 - 5630 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, PASSIVE-SCAN
	(5630 - 5650 @ 240), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, PASSIVE-SCAN
	(5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN

iw list output

	Band 2:
		Capabilities: 0x19ef
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 7935 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 4 usec (0x05)
		HT Max RX data rate: 300 Mbps
		HT TX/RX MCS rate indexes supported: 0-15
		VHT Capabilities (0x039071f6):
			Max MPDU length: 11454
			Supported Channel Width: 160 MHz
			RX LDPC
			short GI (80 MHz)
			short GI (160/80+80 MHz)
			TX STBC
			SU Beamformee
			MU Beamformee
		VHT RX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT RX highest supported: 0 Mbps
		VHT TX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT TX highest supported: 0 Mbps
		Frequencies:
			* 5180 MHz [36] (22.0 dBm) (no IR)
			* 5200 MHz [40] (22.0 dBm) (no IR)
			* 5220 MHz [44] (22.0 dBm) (no IR)
			* 5240 MHz [48] (22.0 dBm) (no IR)
			* 5260 MHz [52] (22.0 dBm) (no IR, radar detection)
			* 5280 MHz [56] (22.0 dBm) (no IR, radar detection)
			* 5300 MHz [60] (22.0 dBm) (no IR, radar detection)
			* 5320 MHz [64] (22.0 dBm) (no IR, radar detection)
			* 5340 MHz [68] (disabled)
			* 5360 MHz [72] (disabled)
			* 5380 MHz [76] (disabled)
			* 5400 MHz [80] (disabled)
			* 5420 MHz [84] (disabled)
			* 5440 MHz [88] (disabled)
			* 5460 MHz [92] (disabled)
			* 5480 MHz [96] (disabled)
			* 5500 MHz [100] (22.0 dBm) (no IR, radar detection)
			* 5520 MHz [104] (22.0 dBm) (no IR, radar detection)
			* 5540 MHz [108] (22.0 dBm) (no IR, radar detection)
			* 5560 MHz [112] (22.0 dBm) (no IR, radar detection)
			* 5580 MHz [116] (22.0 dBm) (no IR, radar detection)
			* 5600 MHz [120] (22.0 dBm) (no IR, radar detection)
			* 5620 MHz [124] (22.0 dBm) (no IR, radar detection)
			* 5640 MHz [128] (22.0 dBm) (no IR, radar detection)
			* 5660 MHz [132] (22.0 dBm) (no IR, radar detection)
			* 5680 MHz [136] (22.0 dBm) (no IR, radar detection)
			* 5700 MHz [140] (22.0 dBm) (no IR, radar detection)
			* 5720 MHz [144] (22.0 dBm) (no IR, radar detection)
			* 5745 MHz [149] (22.0 dBm) (no IR)
			* 5765 MHz [153] (22.0 dBm) (no IR)
			* 5785 MHz [157] (22.0 dBm) (no IR)
			* 5805 MHz [161] (22.0 dBm) (no IR)
			* 5825 MHz [165] (22.0 dBm) (no IR)
			* 5845 MHz [169] (disabled)
			* 5865 MHz [173] (disabled)
			* 5885 MHz [177] (disabled)
			* 5905 MHz [181] (disabled)
	valid interface combinations:
		 * #{ managed } <= 1, #{ AP, P2P-client, P2P-GO } <= 1, #{ P2P-device } <= 1,
		   total <= 3, #channels <= 2
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	max # scan plans: 2
	max scan plan interval: 65535
	max scan plan iterations: 254
	Supported extended features:
		* [ VHT_IBSS ]: VHT-IBSS
		* [ RRM ]: RRM
		* [ MU_MIMO_AIR_SNIFFER ]: MU-MIMO sniffer
		* [ SCAN_START_TIME ]: scan start timestamp
		* [ BSS_PARENT_TSF ]: BSS last beacon/probe TSF
		* [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
		* [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
		* [ ENABLE_FTM_RESPONDER ]: enable FTM (Fine Time Measurement) responder
		* [ EXT_KEY_ID ]: Extended Key ID support
		* [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
		* [ DEL_IBSS_STA ]: deletion of IBSS station support
		* [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
		* [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

It seems to be the configuration isn't supported by the hardware. Has anyone figured out a way to fix this? thank you in advance!

Correct, Intel intentionally and explicitly prevents using AP mode (or other modes initiatiating radiation by themselves, which puts higher demands on regulatory compliance) in the 5 GHz band. You need different hardware for that.

1 Like

Thank you for the reply!! May get a QCA6174 or RTL8822BE then.

Stay away from realtek.

…and QCA6174 is kind of a red-headed stepchild within the ath10k family (compared to QCA98xx/ QCA99xx), it works in principle - but isn't really dependable and crash prone.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.