AC68U (TM-AC1900) could not execute uploaded tool (--ash error?)

I was trying to debrick my router. Tried stock firmwares and their forks and even Tomato without success, I managed to flash OpenWRT 18.06.1 successfully. The debrick process requires two more steps: erase a factory partition marked as mtd5 partition and flash a modified CFE bootloader.

  • However, the OpenWRT layout was different and it seemed to use some kind of new filesystem ubifs, right? I did not see that factory partition or even the normal rootfs, rootfs_data. Is there anyway I can mount/see those kinds of partitions?
  • I uploaded the tool for flashing the modified CFE ("mtd-write") and chmoded it. However, even when I was in the same directory containing the tool, when I executed the tool, OpenWRT just gave out an error as if it could not see the tool to run ("--ash: command not found"). Why would that happen? How could I make OpenWRT see and execute an uploaded binary? (Btw, I see that OpenWRT has a "mtd" tool, don't know if that can be used to write Asus CFE to boot partition?)

I really know nothing about OpenWRT, and the new 18.06.1 seems to have some new features that the wiki has not covered. So, hope someone can give me some explanation/instructions for this issue. Thanks in advance.

Try ubinfo -a

Thanks, I saw rootfs and rootfs_data. However, didn't see the factory partition. I also took all time at work to read more about MTD, Ubifs and still at lost. I'll recap the situation with screenshots, hope that could make things clearer.

In the flash layout of a working router, you can see a mtd0 partition "boot" of the cfe bootloader and a mtd5 partition labeled "asus". I need to flash a modified CFE to that "boot" partition and erase that "asus" partition.

On my current bricked router:

  • OpenWRT spits garbage files once in a time, tried Lede 17.0.4 and OpenWRT 18.06.0 and 18.06.1 and they are all like that.
  • The system layout is different, the mtd0 "boot" partition is available, but not the "asus" one.
  • Uploaded and chmoded the tool for writing the modified CFE, "mtd-write", but OpenWRT just gave out error as if it could not see (-ash: tool_name: not found)

good bad