About IPv6 privacy extensions on OpenWrt

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd49:52b9:000e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'pppoe'
        option device 'wan.30'
        option username 'snipped'
        option password 'snipped'
        option ipv6 'auto'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '30'
        option name 'wan.30'

Thank you.

You have an address dynamically assigned to your WAN + you have a prefix (/64 subnet) delegated to you so it could be assigned to your LAN. PD you see on the screen stands for Prefix Delegation.

1 Like

My WAN is configured through PPPoE, not DHCP.

DHCPv6 interface is created automatically in order to obtain IPv6-related information from provider.
On the LAN host you may see even more addresses. Stable privacy address is often one of them, see

3 Likes