Ability to access the modem with manual IP in bridge mode

Hi
In LTE modem, I bridged my module to the LAN interface as IFNAME
That is, my LTE module gives IP directly to the system that is connected to the modem via LAN
Settings like this:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdca:8938:0be4::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 usb0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '40:d6:3c:2c:fb:d9'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '40:d6:3c:2c:fb:da'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'

config interface 'VPN'
	option ifname 'tun1'
	option proto 'pptp'
	option auto '0'

config interface 'VPNL2TP'
	option ifname 'tun0'
	option proto 'l2tp'
	option auto '0'


(device known by ECM called usb0)

Everything is fine except that when I manually enter the main IP of the modem on the Windows operating system, for example: (192.168.1.15) I can not access the modem panel
But there is no problem when I manually give IP on Ubuntu operating system
What could be the problem?

do you have dnsmaqs, odhcp disabled?

1 Like

No, I did not deactivate
Does the activation of these two items have an effect? Because I think the manual ip priority is higher

I disabled it now, but it made no difference

I think changing ip to 192.168.0.1 of openwrt would be fixed.

What is the difference?
Between ip 192.168.1.1 and 192.168.0.1

I think you are trying to access 192.168.1.15 in lan from openwrt and not from modem

I did not catch . I want to access the luci panel in openwrt via 192.168.1.1

i want set 192.168.1.15 for device ip and 192.168.1.1 gateway for access luci

you have to set dhcp pool 192.168.1.2 - 192.168.1.253 into modem

You may not fully understand the settings
I have created a bridge for direct access to the lte module via the lan port
This bridge works properly and the module gives ip via dhcp to pc
But when I want to access the modem lan with gateway 192.168.1.1 by manual ip can not on the pc
I can not on Windows
But on Ubuntu I can

What is the ip modem? and range dhcp pool?

Do you mean the modem lte module?
lte module range is 192.168.43.x
openwrt range is 192.168.1.x

Set up OpenWrt as router and this method should work: