ABB + OpenWrt modem + OpenWrt router setup help

Hello,

Could I please get some assistance setting up my openwrt modem and router to work with ABB (aussie broadband)

I have a netgear DM200 and linksys EA8500 both flashed w/ OpenWrt 19.07.7

I would like the modem bridged, and to be able to access the modem from behind the router, and prevent LAN leak

I get good sync with the below settings, however I cannot actually access the internet with PC directly connected to modem (to test) or with router, and I cannot access the modem like I should be able to

At present everything is connected via ethernet

modem /network:

 config dsl 'dsl'
 	option ds_snr_offset '0'
 	option line_mode 'vdsl'
 	option xfer_mode 'ptm'
 	option tone 'bv'
 	option annex 'b'
 	option firmware '/lib/firmware/dsl_vr9_firmware_xdsl-05.07.0B.05.00.07_05.07.05.04.00.01.bin'']

 config interface 'lan'
 	option proto 'static'
 	option ipaddr '192.168.1.1'
 	option netmask '255.255.255.0'
 	option ip6assign '60'
 	option ifname 'eth0'
 	option type 'bridge'

 config device 'lan_eth0_dev'
 	option name 'eth0'
 	option macaddr '10:da:43:0f:a5:b9'

 config interface 'wan'
 	option proto 'dhcp'
 	option delegate '0'
 	option hostname 'Modem'
 	option ifname 'eth0'
 	option type 'bridge'

 config device 'wan_dsl0_dev'
 	option name 'dsl0'
 	option macaddr '10:da:43:0f:a5:ba'

 config atm-bridge
 	option atmdev '0'
 	option encaps 'llc'
 	option vci '35'
 	option payload 'bridged'
 	option vpi '8'
 	option unit '0'

router /network

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'c0:56:27:18:cc:36'
config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'c0:56:27:18:cc:36'
config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'
config interface 'modem'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.100'
	option gateway '192.168.1.1'

router /firewall

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 modem'

Many thanks for any assistance

fwiw... had to give them a call tonight to undo the CGNAT they snuk onto the connection...

thankfully this is all that is required (and a fake reason) to remove it...