A question in using wireless bridge mode

Primary route IP: 192.168.1.1
Slave route IP: 192.168.2.1
Slave route:

  1. Install luci-proto-relay and relayd
  2. Use the client mode to access the wifi of the primary routing
  3. Add a network interface, the protocol is set to the Relay Bridge, and associates the lan port and the wwan port
  4. Close the DHCP service of lan port
  5. Slave route has obtained the primary routing IP: 192.168.1.150
  6. Use a computer to connect to the lan port from the slave route
  7. The computer obtained the primary routing IP: 192.168.1.164
  8. Use the computer to visit 192.168.1.1, successfully visit
  9. Use the computer to access 192.168.2.1, visited failed
    Is there any way to allow the computer to successfully access 192.168.2.1 under the current conditions (Of course, if the computer is set to static IP192.168.2.10, it can successfully visit 192.168.2.1, but do not want to change to static IP)

The slave router (192.168.1.150) and clients connected to it should use a 192.168.1.x IP per your statement above:

Why?

I thought you setup the slave router to be a relayd client so clients get 192.168.1.x IPs?

Maybe you should explain or provide a diagram of what you desire.

When I set it up, the IP address of the slave route and the client did get the IP address of 192.168.1.x.
The slave router IP:192.168.1.150
The client(PC) IP:192.168.164

1 Like

Correct. That's the IPs you configured for a relay interface. You would use those.

To access 192.168.2.x, you would connect to that interface (non-relay) - but your description seems as if you reconfigured lan so it's now the relay.

Yes,you are right, this is my purpose, but although I succeeded, I found that I could not directly visit the background management page of the slave router(192.168.2.1).Only when I set the PC's IP address to static 192.168.2.x, I can access it.

  • You should use 192.168.1.150 to access the slave router
  • 192.168.2.0 should not be in use on your relay interface

If you desired a different setup, provide more details of what you wish to accomplish in your use case.

Because the current PC IP is 192.168.1.164, it can only access the background management page of the main router (192.168.1.1), and cannot access the background management page of the router (192.168.2.1), so I now hope that it can access 192.168. 1.1, and can also access 192.168.2.1. In this case, without the need to modify the PC IP, I can check the main router and the configuration of the router at the same time.

Again.

Use 192.168.1.150 :white_check_mark: , not 192.168.2.1 :x: .

Your PC is incorrectly numbered in.192.168.2.x. [y]This is incorrect[/u].

I tried, but failed,using 192.168.1.150 can not access the slave router

What's the SRC IP?

(If you give a 192.168.2.x IP - you missed the conversation.)

192.168.1.164

  • Where is this device connected?
  • Can you ping 192.168.1.150 from this device?

It is connected to the slave router's lan port

Let me try, please wait for a few minutes

1 Like

OK - also let's see your configs.

cat /etc/config/network
cat /etc/config/wireless

Both routers if possible.

No, the ping is cannot access

Also

cat /etc/config/firewall

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option curmode 'repeater'

config device
        option name 'br-lan'
        option type 'bridge'
        option igmp_snooping '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
        option multicast_to_unicast '0'

config device
        option name 'lan1'
        option macaddr '00:60:A7:0B:9B:6C'

config device
        option name 'lan2'
        option macaddr '00:60:A7:0B:9B:6C'

config device
        option name 'lan3'
        option macaddr '00:60:A7:0B:9B:6C'

config device
        option name 'lan4'
        option macaddr '00:60:A7:0B:9B:6C'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option cwmp_LANDevice_instance '1'

config device
        option name 'wan'
        option macaddr '00:60:A7:0b:9b:6d'

config interface 'wan'
        option device 'wan'
        option reqopts '33 43 249'
        option vendorid 'dslforum.org'
        option proto 'dhcp'
        option disabled '1'
        option cwmp_WANConnectionDevice_instance '1'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option disabled '1'
        option cwmp_WANConnectionDevice_instance '2'

config interface 'agent'
        option proto 'dhcp'
        option device 'br-lan'
        option cwmp_WANConnectionDevice_instance '3'
        option disabled '1'

config interface 'wwan'
        option proto 'dhcp'
        option cwmp_WANConnectionDevice_instance '4'
        option disabled '0'

config interface 'bridgeqiao'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option cwmp_WANConnectionDevice_instance '5'

root@OpenWrt:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/wmac.1'
        option band '2g'
        option htmode 'HE20'
        option channel 'auto'
        option disabled '0'
        option country 'CN'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ifname 'wlan0-ap'
        option cwmp_WLANConfiguration_instance '1'
        option ssid 'CMCC-cKrb'
        option key 'NMPk5Jzy'
        option encryption 'sae-mixed'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/wmac.2'
        option band '5g'
        option htmode 'HE80'
        option channel 'auto'
        option disabled '0'
        option country 'CN'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ifname 'wlan1-ap'
        option cwmp_WLANConfiguration_instance '2'
        option ssid 'CMCC-cKrb-5G'
        option key 'NMPk5Jzy'
        option encryption 'sae-mixed'

config wifi-iface 'wlan0_ap_bh'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key '12345678'
        option encryption 'psk2'
        option ssid 'Tri_Mesh_BH_9B6C'
        option multi_ap '1'
        option wds '1'
        option ifname 'wlan0-ap-bh'
        option hidden '1'
        option disabled '1'

config wifi-iface 'wlan0_ap_fh'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key '12345678'
        option encryption 'psk2'
        option ssid 'Tri_Mesh_FH_9B6C'
        option multi_ap '2'
        option wds '1'
        option ifname 'wlan0-ap-fh'
        option hidden '0'
        option cwmp_WLANConfiguration_instance '3'
        option disabled '1'

config wifi-iface 'wlan1_ap_bh'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key '12345678'
        option encryption 'psk2'
        option ssid 'Tri_Mesh_BH_9B6C'
        option multi_ap '1'
        option wds '1'
        option ifname 'wlan1-ap-bh'
        option hidden '1'
        option disabled '1'

config wifi-iface 'wlan1_ap_fh'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key '12345678'
        option encryption 'psk2'
        option ssid 'Tri_Mesh_FH_9B6C'
        option multi_ap '2'
        option wds '1'
        option ifname 'wlan1-ap-fh'
        option hidden '0'
        option cwmp_WLANConfiguration_instance '4'
        option wps_pushbutton '0'
        option disabled '1'

config wifi-iface 'wlan0_sta_bh'
        option device 'radio0'
        option mode 'sta'
        option wds '1'
        option network 'lan'
        option multi_ap '1'
        option default_disabled '1'
        option ifname 'wlan0-sta-bh'
        option disabled '1'

config wifi-iface 'wlan1_sta_bh'
        option device 'radio1'
        option mode 'sta'
        option wds '1'
        option network 'lan'
        option multi_ap '1'
        option default_disabled '1'
        option ifname 'wlan1-sta-bh'
        option disabled '1'

config wifi-iface 'repeater'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ifname 'wlan0-sta-rp'
        option disabled '0'
        option ssid 'WIFITESETSSID'
        option key '12345678'
        option encryption 'psk2'
1 Like
root@OpenWrt:/# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'wwan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

Can you also show:

ubus call system board