A guest network with wireguard on main router, how to copy this to dumb ap's?

On the main router i have a interface, wireless interface and firewall settings for a guest wifi network, as im about privacy and like to secure the guests here over a forced vpn. The firewall makes sure that all traffic can only pass over the vpn, and ensures that guests can not access other devices on my wifi.
But it's only enabled on the main router, which is placed in the basement of the house. I'd like guests to have better wifi reception, so how do i make sure this guest network also works on dumb ap's? while of course still taking the guest network settings of the main router. Is there perhaps a guide for this?

You need to pass guest network as vlan over network cables.

2 Likes

Is your dumb AP only to provide clients with access to the public internet?

The main router is configured to route all traffic over wireguard. The normal wifi network i use at home, but also the guest wifi.
So for guest wlan on the main router, i can simply make a firewall rule with the guest network interface that also forces traffic to go over the wireguard interface.
But other routers (dump ap's) dont have these wireguard interfaces.

So you want the dumb AP traffic to also exit the overall network through the wireguard VPN?

Yes, both the ssid's. Main and guest. How would i set that up with what i described?

any guide how to do this?

AFAIK, there is no such universal guide.

If you need help, post the network configuration files of the main router and AP, redacting the sensitive info.

thanks! i posted my main config here two days ago.
Need to restart routers or wlan to fix connection issues almost daily now, how to fix? - Installing and Using OpenWrt - OpenWrt Forum

the dumb ap is a factory reset openwrt router, with disabled dhcp, static address given and wifi ssid's on and configured with a password. (but not guest wifi on) thats it. no firewall changes, no interfaces added, no advanced settings made, no packages installed. extremely basic.

Anyone? How to make this work perhaps over vlan?

The link you provided only contains the main router configuration.

Sensitive information is passwords/keys, SSIDs, public IPs and MAC addresses. When redacting interface names, someone has to solve puzzles to figure out which one is the guest network among all the ABCs...

Also tell us which ports are used to interconnect the two devices (main router and AP).

EDIT:

By "network configuration files" I mean only /etc/config/network and nothing else (so far).

You need to create a vlan for each network from the access point to the main router. Pleae share us the following files. /etc/config/network, /etc/config/wirreless at least, and maybe also the /etc/config/firewall from all the related devices. After that we can start the guesswork. You can also hide the passwords and macacddresses.

Thanks for wanting to help and sorry for the longer response, it's been super busy last days. this is the configuration of a openwrt dumb ap.
the second dumb ap will have the same configuration except for a other static ip.

root@Meshpoint-2-Terrace:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fb45:4a9e:1576::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.106'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@Meshpoint-2-Terrace:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option channel '132'
        option band '5g'
        option htmode 'HE80'
        option country 'US'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi+1'
        option channel '11'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option country 'US'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid 'xxxxxxxxx'
        option encryption 'psk2'
        option key 'xxxxxxxxx'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'xxxxxxxx'
        option encryption 'psk2'
        option key 'xxxxxxxx'
        option network 'lan'

and finally the firewall, i made zero changes to it since the factory reset:

root@Meshpoint-2-Terrace:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp