8devices jalapeno

Did anyone get one of these boards' WiFi working with any OpenWRT release?
I've tried to flash 18.06, and I can only seem to scan (which works), but whenever I try to actually enable wifi the board crashes and reboots.

Is there a specific version/build certified working for them?


I am the one that introduced support for it.
I use them regularly with various versions,both snapshots and 18.06.0 work without issues for me.

What are you powering the board with,because this sound like a power issue

I'm using a 5v 4A usb adapter.

Can you measure the voltage once you enable wifi?
Its looks really like voltage dropps too much.
I had that behaviour happen due to voltage

Is there anything I can run on the board to measure anything like this? or a voltmeter is needed?

Nope, you need a voltmeter.
One of those usb ones is fine

I'll have to see tomorrow if they have a usb one in the store.
I've tried changing a few adapters though since I suspected power output aswell (I only have 2 that are rated above 2A), and they all exhibit them same problem.

As far as I understand the board is supposed to draw ~2.5A at 5V.

Are you using just a regular usb charger?

Hm, actually board will peak around 13W if you load both radios at the same time.
10W should be max average load.

I power mine ones either from those Amazon basics multi port hubs or with USB-Y cable from 2 USB3.0 ports when debugging

Yeah than the 4A should provide 20W easily, frustrating :frowning:
Just to make sure we're doing the same thing, you simply press enable on the wireless tab right?
I tried enabling the 5Ghz and the 2Ghz separately, but both result in the crash.

I can press scan, I'll see the networks, and once I press enable the crash happens.
Also, luci never returns after the crash (it used to return on the original LEDE - no wifi there either).
I need to ssh into it, run firstboot than reboot and than luci shows up again.

Also, I'm not using any external antenna, just the stock dev board.

Hm,I dont usually use LUCi,but do it using console.
Hm,simply enabling the radio should not crash the module.
Can you connect to USB port on you Desktop or Notebook to capture the log at the moment of crash?
If not loaded it should be enough current.

I am also using the dev boards.

What would you run to enable radio from the cmdline (running OpenWrt 18.06.1, r7258-5eb055306f)?
Would be simpler than using LUCI

Simply edit /etc/config/wireless
And then /etc/init.d/network reload

Well,I work on various projects that mostly dont have LuCi.

This is having the computer connected via serial (which obviously doesn't provide enough power).
So i just changed radio0 to disabled '0', and the device immediately reboots.

root@OpenWrt:/# vim /etc/config/wireless
root@OpenWrt:/# /etc/init.d/network reload
'radio1' is disabled
'radio1' is disabled
root@OpenWrt:/# vim /etc/config/wireless[  271.308752] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  271.324097] br-lan: port 2(wlan0) entered blocking state
[  271.324142] br-lan: port 2(wlan0) entered disabled state
[  271.328901] device wlan0 entered promiscuous mode

Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset),  D - Delta,  S - Statistic
S - Boot Config, 0x00000021
S - Reset status Config, 0x00000000
S - Core 0 Frequency, 0 MHz
B -       262 - PBL, Start
B -      1342 - bootable_media_detect_entry, Start
B -      1683 - bootable_media_detect_success, Start

Hm, well simply enabling radio should not crash it, even when powered from one USB port.
I would RMA this one after you check with USB multimeter for current and voltage on the moment of enabling radio.
This should not happen.

I see, I'll check the voltage tomorrow and email 8devices if it looks okay.

Thanks again for the super quick help!
It really looks like a wonderful dev board, I wish I could have put it to use here :slight_smile: