8devices Jalapeno flashing

Hi all,

I have one of those 8devices Jalapeno devkits that I am trying to upgrade to the latest version of OpenWRT. I tried the firmware upgrade file available on https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=jala with no success. When using the LUCI GUI to flash a new build, I get the following:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

If I use instructions in https://github.com/openwrt/openwrt/pull/713 to force a sysupgrade, the device goes into a bootloop and needs to be recovered via uboot. If I don't use the -F flag, I get the following error:

Device jalapeno not supported by this image
Supported devices: 8dev,jalapeno
Image check 'fwtool_check_image' failed.

What am I doing wrong that I might be able to correct?

That means that you got one with a really old bootloader which does not accept generic FIT config partitions.
First update the bootloader, you got a precompiled one here as well as instructions

Then simply download Jalapeno sysupgrade image from OpenWrt download site and force sysupgrade.

Thanks @robimarko, your diagnosis was spot-on. I was able to flash the latest 18.06 build from OpenWRT downloads on my board.

I have been using those boards daily at work so I know all of the bugs

1 Like

Good to know! Is there anything I should be aware of with the latest release of OpenWRT on that board? Any ports/interfaces you know that don't function as expected?

Nothing, everything works as expected.
Been that way since my PR for Jalapeno was merged months ago

1 Like

Hey @robimarko, I was able to flash the OpenWRT binary that's provided as a download, but when I compiled the latest myself and tried to deploy that, it failed in the same manner as before. I've attached a bootlog here if it helps. Would you mind taking a look?

Hm, did you flash the factory version using do_recovery or sysupgrade?
I was doing some work on the bootloader and flashed a snapshot 2-3 days ago manually using the same commands that do_recovery does and it booted just fine.

If flashing fails that way(It really shouldnt) can you try booting the initramfs image and then simply sysupgrading

I've tried both ways - the log I attached was during do_recovery and it failed. Trying sysupgrade -n -F with the squashfs sysupgrade image file I generate from my OpenWRT build also fails. If it helps, I'm trying both these methods after recovering the device with the 8devices build from their website.

Where would I get the initramfs image? Would you say there's a problem in my make menuconfig which is generating an incorrect image?
Thanks again

Well simply download the initramfs image from OpenWrt website.

There could be an issue with your build

I tried that build, and it seems to work fine although it's minimal (no LUCI, sshd, etc). I'll double-check my build environment.

Can you foresee issues possibly due to Ubuntu 18.04? Which version have you been using?
Thanks again!

Well, OpenWrt snapshots dont include LuCi, but you can simply install anything you like with opkg.

I am using Fedora 28 for most of my builds, but I have built on 18.04 too without issues.

1 Like

Hey man, I think I'm going to have to reach out to 8Devices. I'm at a point where I have reflashed the bootloader, then flashed the 8devices jalapeno build (successfully) but I can't get to sysupgrade-ing the initramfs image from OpenWRT :frowning:

What are you doing exactly?
You dont sysupgrade the initramfs image from OpenWrt, as a fact you dont flash it at all.
You can use the initramfs image to load it to RAM and then boot it and then sysupgrade a sysupgrade image.

Maybe my n00b-ass is using the wrong term. Is this the initramfs image: http://downloads.openwrt.org/releases/18.06.1/targets/ipq40xx/generic/openwrt-18.06.1-ipq40xx-8dev_jalapeno-squashfs-nand-sysupgrade.bin

I reflashed the bootloader, used do_recovery to flash the Jalapeno build, then ssh'ed over the build I linked to above, tried to sysupgrade that one and that's not working.

No, that is the sysupgrade image like its name says.
Why dont you simply download a factory image and use do_recovery on it?

The factory image from 8devices works fine. I am trying to get to the latest 18.06 OpenWRT instead of that image so I can develop further. That jump from the LEDE-based factory firmware to 18.06 is the part that I can't figure out.
Thanks for all your help btw. This is awesome.

By factory image I meant OpenWrt factory image

You can simply do_recovery from bootloader with it.
But forcing sysupgrade in 8devices image should work with the sysupgrade image

1 Like

Wait ... I didn't know there was a factory OpenWRT firmware. I'll try it right now.

What link takes you to factory images?

Its literaly listed right above sysupgrade image and under initramfs one.
They are all listed in the same subtarget together,no special link