802.11s Mesh nodes do not connect

Hi all,
I've installed wpad-mesh-openssl on 2 of my TP-link Routers and configured a mesh on both in the same way. But it seems like the nodes will not connect.
If I type in 'iw dev wlan1-3 station dump' I get no outpout.

Here is my wireless config:

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'TP-LINK_6B54'
        option key 'xxxxxMyPassword'
        option encryption 'psk2'

config wifi-iface 'wifinet2'
        option ssid 'Palo Alto_Gast'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option key 'xxxxMyGuestPassword'
        option network 'guest'

config wifi-iface 'mesh'
        option device 'radio1'
        option mode 'mesh'
        option mesh_id 'JoesMesh'
        option key 'SamePassword as for my radio1-1'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option encryption 'sae'
        option network 'mesh lan'
        option ifname 'wlan1-3'

Can anyone give me a hint?

Thanks

Try HT20 and no encryption first. HT40 should almost never be used on 2.4 GHz.

I don't think you can (nor would you want to) specify two networks for a wifi interface. Bridge into the lan at first.

The radio channel on all nodes must be set to the same definite channel, not "auto".

1 Like

Thanks I will give it a try.

Try running these commands:


uci set wireless.radio1.noscan='1'
uci set wireless.radio1.channel=11
uci set wireless.default_radio1.disabled=0
uci set wireless.wifinet2.disabled=0
uci set wireless.wifinet2.network='lan'
uci set wireless.mesh.disabled=0
uci set wireless.mesh.network='lan'
uci commit wireless
wifi

HT40 is fine on 2.4GHz if you want 300Mb/s but you have to enable the noscan option.
@mk24 is right though in a way - if you have neighbors they will probably not be happy...
Yes use the same channel at both ends, not auto.

Depending on your hardware you may be limited to 2 virtual wireless interfaces - you are configuring 3 here.

1 Like

And if the neighbors don't realize or don't know about HT40?

Worst case is that is causes congestion. It does not break anything. It just means you are using 2 channels and in a highly populated area 2.4GHz channels are at a premium. In a street of houses it is unlikely to be an issue, in a block of apartments it could be.

1 Like

And just a heads up you must have an AP enabled if you want to use HT40 for mesh as HT 40 relies on hostapd for configuration.

ie
HT40
AP
Mesh
will work with HT40.

HT40
STA
Mesh
Will only connect with a HT20 configured Mesh as hostapd won't be running to configure the HT40 setting.

Hi Bluewavenet,
perfect, it seems to be connected. But signal seems to be very weak, isn't it?
Both routers are connect via Lan Port.

Router 1


Router 2

Excuse me if I'm wrong :wink:

Thanks in advance for your help.

It would be more informative to post the output of:

iw dev wlan1-3 station dump

How far apart are the two devices? Try a test with them next to each other.