802.11s Mesh: Node can't access resources of Mesh Portal via another node (Transitive connections not working)

I have a 802.11s based mesh network of Raspberry Pis (RPi) based on OpenWRT 21.02.0.

There is one main router based on a RPi 3B+ that connects to the internet via Ethernet. It then sets up an AP and a mesh node via a WLAN dongle. The mesh clients are based on an RPi Zero. They also create a mesh point and an AP with the same settings as the main router. An android device (e.g. a tablet) should now be able to connect to any AP and access the internet.

When I connect a tablet to a mesh client's AP (with the main router not in range), I have internet access. So, the way tablet->mesh client->main router seems to work.

When I connect to a mesh client that connects to the main router via another mesh client, I don't have internet access. So, the way tablet->mesh client->mesh client->main router is not working.

So, my question is: Why is the above mentioned case not working and what to do about it.

Configuration files for the main router:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf9:1cbf:74a5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrtMesh'
        option encryption 'psk2'
        option key 'foobar'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211r '1'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'

config wifi-iface 'mesh'
        option device 'radio1'
        option mode 'mesh'
        option mesh_id 'FooMesh'
        option encryption 'none'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'

Configuration files for the mesh client:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6b:1360:261d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtMesh'
        option key 'foobar'
        option encryption 'psk2'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211r '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'

config wifi-iface 'mesh'
        option device 'radio1'
        option mode 'mesh'
        option mesh_id 'FooMesh'
        option encryption 'none'
        option mesh_fwding '1'
        option network 'lan'
        option mesh_rssi_threshold '0'

Thanks